summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2021-05-07 13:35:59 +0200
committerMartin Väth <martin@mvath.de>2021-05-07 13:35:59 +0200
commitcc28e9cf8703da7a20313a19a097b1458e2cafd0 (patch)
tree326cefde5d5a877de6694a9ed72d2710e950212c /app-mobilephone
parentvirtual/freedesktop-icon-theme: Revision bump (diff)
downloadmv-cc28e9cf8703da7a20313a19a097b1458e2cafd0.tar.gz
mv-cc28e9cf8703da7a20313a19a097b1458e2cafd0.tar.bz2
mv-cc28e9cf8703da7a20313a19a097b1458e2cafd0.zip
python:3.9 and python:3.10
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/adb-sync/Manifest1
-rw-r--r--app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild32
-rw-r--r--app-mobilephone/adb-sync/metadata.xml12
3 files changed, 45 insertions, 0 deletions
diff --git a/app-mobilephone/adb-sync/Manifest b/app-mobilephone/adb-sync/Manifest
new file mode 100644
index 00000000..3616b559
--- /dev/null
+++ b/app-mobilephone/adb-sync/Manifest
@@ -0,0 +1 @@
+DIST adb-sync-0_p20190101.tar.gz 13956 BLAKE2B 380109fa302fc5376de8124aa31c3fa03a27ece22d7f2d74638a5387820ad7c2b294daa6e8185f6eef49524e987d7a7f1222a1ee3b6550247993ebcc7c1ac98d SHA512 8bd5eb514c63327860017402f509231a0882cd3624ed3350039b2383f38e503abc6cd319ff41a47d70031958b0b38b973c36272fc4af6e69cce54e15e6bb6990
diff --git a/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
new file mode 100644
index 00000000..01ee4b7d
--- /dev/null
+++ b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit python-single-r1
+
+COMMIT=fb7c549753de7a5579ed3400dd9f8ac71f7bf1b1
+
+DESCRIPTION="Synchronize files between a PC and an Android device using ADB"
+HOMEPAGE="https://github.com/google/adb-sync"
+SRC_URI="https://github.com/google/adb-sync/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+channel"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-util/android-tools
+ channel? ( net-misc/socat )"
+DEPEND=""
+
+S="${WORKDIR}/adb-sync-${COMMIT}"
+
+src_install() {
+ dodoc README.md
+ python_doscript adb-sync
+ use channel && dobin adb-channel
+}
diff --git a/app-mobilephone/adb-sync/metadata.xml b/app-mobilephone/adb-sync/metadata.xml
new file mode 100644
index 00000000..d076f30c
--- /dev/null
+++ b/app-mobilephone/adb-sync/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <bugs-to>https://github.com/google/adb-sync/issues</bugs-to>
+ <remote-id type="github">google/adb-sync</remote-id>
+ </upstream>
+ <use>
+ <flag name="channel">Install the adb-channel script</flag>
+ </use>
+</pkgmetadata>