summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2022-01-12 05:47:56 +0100
committerMartin Väth <martin@mvath.de>2022-01-12 05:47:56 +0100
commitc4d006afe68064d2176ff274dc85102098b712ec (patch)
treedb428fe01e595cf121a22c9b04989d3d7b4c1643 /games-action/trackballs/trackballs-1.1.4-r2.ebuild
parentmedia-video/pipewire x11-libs/gtk+: Version bump. media-video/handbrake: remove (diff)
downloadmv-c4d006afe68064d2176ff274dc85102098b712ec.tar.gz
mv-c4d006afe68064d2176ff274dc85102098b712ec.tar.bz2
mv-c4d006afe68064d2176ff274dc85102098b712ec.zip
acct-{group,user} for flexlm trackballs noip-updater schedule
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'games-action/trackballs/trackballs-1.1.4-r2.ebuild')
-rw-r--r--games-action/trackballs/trackballs-1.1.4-r2.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/games-action/trackballs/trackballs-1.1.4-r2.ebuild b/games-action/trackballs/trackballs-1.1.4-r2.ebuild
new file mode 100644
index 00000000..439b7551
--- /dev/null
+++ b/games-action/trackballs/trackballs-1.1.4-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2016-2022 Gentoo Authors and Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop
+RESTRICT="mirror"
+
+DESCRIPTION="simple game similar to the classical game Marble Madness"
+HOMEPAGE="http://trackballs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${PN}-music-1.4.tar.bz2"
+
+LICENSE="GPL-2 FML-1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[sound,joystick,video]
+ >=dev-scheme/guile-1.8:12[deprecated]
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ acct-group/gamestat"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e 's/icons //' \
+ -e 's/games/gamestat/' \
+ share/Makefile.in \
+ || die
+ sed -i \
+ -e '/^localedir/s:=.*:=/usr/share/locale:' \
+ src/Makefile.in \
+ po/Makefile.in.in \
+ || die
+ # Fix _FORTIFY_SOURCE buffer overflow due to wrong sizeof
+ sed -i \
+ -e 's/\(snprintf(\(name\),sizeof\)(str)/\1(\2)/' \
+ src/enterHighScoreMode.cc || die
+ # Fix -Wformat-security warning due to non-literal with no format arguments
+ sed -i \
+ -e 's/\(snprintf(levelname,sizeof(levelname),\)\(name)\)/\1 "%s", \2/' \
+ -e 's/\(snprintf(Settings::settings->specialLevel,sizeof(Settings::settings->specialLevel),\)\(levelname)\)/\1 "%s", \2/' \
+ src/editMode.cc || die
+ sed -i \
+ -e 's/\(snprintf(\(textureName\),\)63\(,textureNames\[i\])\)/\1 sizeof(\2), "%s"\3/' \
+ src/map.cc || die
+ eapply "${FILESDIR}"/${P}-warning.patch
+ default
+}
+
+src_configure() {
+ econf \
+ --datadir=/usr/share/games \
+ --datarootdir=/usr/share \
+ --disable-dependency-tracking \
+ --with-highscores=/var/games/${PN}.score \
+ $(use_enable nls)
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ insinto /usr/share/games/${PN}/music
+ doins "${WORKDIR}"/trackballs-music/*.ogg
+ newicon share/icons/${PN}-64x64.png ${PN}.png
+ make_desktop_entry ${PN} Trackballs
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO
+ fowners root:gamestat /usr/bin/${PN}
+ fperms 2755 /usr/bin/${PN}
+}