summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Phillips <write2david@gmail.com>2012-10-31 23:15:37 -0500
committerDavid Phillips <write2david@gmail.com>2012-10-31 23:15:37 -0500
commitf18cd15c06bf815dd04e73c5c744f23333fd47ad (patch)
tree6043752dbeb1e26f99980b52c51c3443688c0dff /x11-misc
parentOops, forgot to update the Manifests (diff)
downloadwrite2David-f18cd15c06bf815dd04e73c5c744f23333fd47ad.tar.gz
write2David-f18cd15c06bf815dd04e73c5c744f23333fd47ad.tar.bz2
write2David-f18cd15c06bf815dd04e73c5c744f23333fd47ad.zip
Fixing per upstream bug report...
...https://bugs.launchpad.net/cairo-dock-core/+bug/1073734
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/cairo-dock/Manifest2
-rw-r--r--x11-misc/cairo-dock/cairo-dock-9999.ebuild42
2 files changed, 23 insertions, 21 deletions
diff --git a/x11-misc/cairo-dock/Manifest b/x11-misc/cairo-dock/Manifest
index 6f06103..020054f 100644
--- a/x11-misc/cairo-dock/Manifest
+++ b/x11-misc/cairo-dock/Manifest
@@ -1,3 +1,3 @@
-EBUILD cairo-dock-9999.ebuild 3260 SHA256 b9315f7a03be18b796b9c953ca040a74c3a075513f4030363797a2d5f1abfcd1 SHA512 e57f05309442ee13938517a0fa3d83d484a344930f40944b0a1d4902220610b4af62a8ee8173ac540405e5fd4e7d53fb9fcfffcd955008333ec4cfad5db2cf78 WHIRLPOOL 8e2641624c8728b859fd20af1334b2030bc84e2eee79ce5511fb983004149c7414108a33fd57a5588734ae076ce2455532d515072de8f396511e7590916dddb6
+EBUILD cairo-dock-9999.ebuild 3514 SHA256 eec34c49b5e63e92a47c8eb8e70b3ea42c91809fd53b26a48bed523811249da9 SHA512 4608523822fc4d8eb97da34dc041541bca7acded641d896473d4423b846642fbe57b10f10ff3e43e3bec91be357b3cc9a6bae88bcbfbff197041c772c3807727 WHIRLPOOL d2051624dda8d0ee1e0ce6aa34a69fa7f643eadcca6c36661a383e6db88861103c0b19fdaa48c3b790a09eb5be4609e99174b93d064fee9944197a8ed14c6fda
MISC ChangeLog 240 SHA256 ffd103359939888e5c0463fda3245d4e54b55fdcc16782e5e83f14fbaaa31efd SHA512 73eaaece611870fb2b5dc5f6c9a49fb6690b8bd7a11edae9d889c0b4eb938ee7edca56ad624a29f7541c6d5743044241c252efb5259f4eb9655e391f00456c9f WHIRLPOOL 4d3d956b0c1c638b9ec0ffda00272ff97225daa41295de40e6dcf03e1653c464ed43c4d0077009a87c7f36d8dc857f60f5f5d730ac0f1d7524c7d47a34b1c721
MISC metadata.xml 276 SHA256 cc9796aef23ea695fd2cc82f8c763e3463f4ddcc335f716740ef0d568f4ca6e9 SHA512 a0930513ce3ede325f785bfa54d12436083f7ffeac0d41991cf3e7bb2a1904560ee07dc6210623983a025000e3217b02cb4a7f5b016cb25e90c33f8176b9e249 WHIRLPOOL a41cd867bdf8c7c303bba1e2b99d0a1737fb8067d6c937f973fe32c611c386d230586d619900545a59c5b9e24b5276491f367b005a2451a38d1d52db5ebc5e69
diff --git a/x11-misc/cairo-dock/cairo-dock-9999.ebuild b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
index 2981cd4..dace87a 100644
--- a/x11-misc/cairo-dock/cairo-dock-9999.ebuild
+++ b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
@@ -17,6 +17,7 @@ EBZR_REPO_URI="lp:cairo-dock-core"
DESCRIPTION="Cairo-dock is a fast, responsive, Mac OS X-like dock."
HOMEPAGE="https://launchpad.net/cairo-dock-core/"
+# Next line is not needed because the BZR repository is specified further above
SRC_URI=""
LICENSE="GPL-2"
@@ -59,30 +60,27 @@ pkg_setup()
{
ewarn ""
ewarn ""
- ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn "You are installing from a LIVE EBUILD, NOT AN OFFICIAL RELEASE."
ewarn " Thus, it may FAIL to build properly."
ewarn ""
- ewarn "This ebuild is not supported by an Gentoo developer."
- ewarn " So please do NOT report bugs to Gentoo's bugzilla."
+ ewarn "This ebuild is not supported by a Gentoo developer."
+ ewarn " So, please do NOT report bugs to Gentoo's bugzilla."
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""
- # Dealing with the weird behavior of cairo-dock installing
+ # We have to deal with the weird behavior of cairo-dock installing
# stuff under "/usr/usr/lib" for 32-bit systems.
- # Also, the weird reported behavior of cairo-dock installing
- # stuff under "/usr/usr/lib6464" for 64-bit system.
+ # ... installing stuff under "/usr/usr/lib6464" for 64-bit systems.
- # We are doing this so that files actually get placed into the normal directory
+ # So, we do the following so that files get installed into the normal directory...
mkdir /usr/usr
- ln -s /usr/lib /usr/usr/lib
- ln -s /usr/lib64 /usr/usr/lib6464/
+ ln -s /usr/lib /usr/usr/lib
+ ln -s /usr/lib64 /usr/usr/lib6464/
- # Note that the first 'ln' will fail if we're on a 64-bit system. That's
- # okay.
- # Note that the second 'ln' will fail if we're on a 32-bit system. THat's
- # okay.
+ # Note that the first 'ln' will fail if we're on a 64-bit system. That's okay.
+ # Note that the second 'ln' will fail if we're on a 32-bit system. That's okay.
}
@@ -107,12 +105,14 @@ src_configure() {
# With a solution inspired on...
# http://code.google.com/p/rion-overlay/source/browse/x11-misc/cairo-dock-plugins/cairo-dock-plugins-2.3.9999.ebuild?spec=svn71d4acbbb8c297b818ff886fb5dd434a6f54c377&r=71d4acbbb8c297b818ff886fb5dd434a6f54c377
- # These CMAKE variables are listed on the BZR installation instructions
- # (link above)
+ # These CMAKE variables are listed in the BZR installation instructions (link above)
+ # Some more info... http://www.cmake.org/Wiki/CMake_Useful_Variables
- # Some more info...
- # http://www.cmake.org/Wiki/CMake_Useful_Variables
- mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
+
+ # Adding the "-DLIB_SUFFIX" flag b/c https://bugs.launchpad.net/cairo-dock-core/+bug/1073734
+
+
+ mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr -DLIB_SUFFIX=\"\""
cmake-utils_src_configure
}
@@ -120,9 +120,11 @@ src_configure() {
pkg_postinst() {
ewarn ""
ewarn ""
- ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn "You have installed from a LIVE EBUILD, NOT AN OFFICIAL RELEASE."
ewarn " Thus, it may FAIL to run properly."
- ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn ""
+ ewarn "This ebuild is not supported by a Gentoo developer."
+ ewarn " So, please do NOT report bugs to Gentoo's bugzilla."
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""