summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-08-08 11:06:09 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-08-08 11:06:09 +0000
commit974f05abf6428c97d42742c11755ba2df1857c36 (patch)
treea9c27f8c47cde11e6e5224d8ef2ae3d98e76cae2
parentglibc patches: add support for 9999 patchset into 'make-tarball.sh' (diff)
downloadgentoo-974f05abf6428c97d42742c11755ba2df1857c36.tar.gz
gentoo-974f05abf6428c97d42742c11755ba2df1857c36.tar.bz2
gentoo-974f05abf6428c97d42742c11755ba2df1857c36.zip
disable ldconfig run in 9999 patchset
-rw-r--r--src/patchsets/glibc/9999/00_all_0001-disable-ldconfig-during-install.patch31
-rw-r--r--src/patchsets/glibc/9999/README.history2
-rw-r--r--src/patchsets/glibc/make-tarball.sh6
3 files changed, 34 insertions, 5 deletions
diff --git a/src/patchsets/glibc/9999/00_all_0001-disable-ldconfig-during-install.patch b/src/patchsets/glibc/9999/00_all_0001-disable-ldconfig-during-install.patch
new file mode 100644
index 0000000000..2b70636aa9
--- /dev/null
+++ b/src/patchsets/glibc/9999/00_all_0001-disable-ldconfig-during-install.patch
@@ -0,0 +1,31 @@
+From 1eff1226630034286c3ae5fa1376eb76211690df Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Wed, 1 Apr 2009 02:15:48 -0400
+Subject: [PATCH] disable ldconfig during install
+
+Do not bother running ldconfig on DESTDIR. It's a waste of time as we
+won't use the result (portage will rebuild the cache after install).
+Also, the Gentoo sandbox does not currently catch chroot() behavior so
+we end up (incorrectly) flagging it as a violation as a write to /etc.
+
+http://sourceware.org/ml/libc-alpha/2012-08/msg00118.html
+https://bugs.gentoo.org/431038
+---
+ Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile b/Makefile
+index 425cb796dba6..bf44b0467282 100644
+--- a/Makefile
++++ b/Makefile
+@@ -107,6 +107,7 @@ install-symbolic-link: subdir_install
+ rm -f $(symbolic-link-list)
+
+ install:
++dont-bother-with-destdir:
+ -test ! -x $(elf-objpfx)ldconfig || LC_ALL=C \
+ $(elf-objpfx)ldconfig $(addprefix -r ,$(install_root)) \
+ $(slibdir) $(libdir)
+--
+2.11.0
+
diff --git a/src/patchsets/glibc/9999/README.history b/src/patchsets/glibc/9999/README.history
index a1aed6ee23..8369156bb9 100644
--- a/src/patchsets/glibc/9999/README.history
+++ b/src/patchsets/glibc/9999/README.history
@@ -1,2 +1,4 @@
+2 08 Aug 2017
+ + 00_all_0001-disable-ldconfig-during-install.patch
1 07 Aug 2017
+ README.history: intentionally empty
diff --git a/src/patchsets/glibc/make-tarball.sh b/src/patchsets/glibc/make-tarball.sh
index 76914112d3..17626ebf94 100644
--- a/src/patchsets/glibc/make-tarball.sh
+++ b/src/patchsets/glibc/make-tarball.sh
@@ -33,11 +33,7 @@ rm -f ${PN}-${PV}-*.tar.bz2
mkdir -p tmp/patches
# copy README.Gentoo.patches
cp ../README* tmp/patches/ || exit 1
-if [[ ${PV} = 9999 ]]; then
- echo "Warning: ${PV} patchset includes only extra/"
-else
- cp ${PV}/*.patch tmp/patches/ || exit 1
-fi
+cp ${PV}/*.patch tmp/patches/ || exit 1
cp -r extra tmp/ || exit 1
cp ${PV}/README* tmp/patches/ 2>/dev/null || exit