summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2010-07-23 20:05:52 +0000
committerLuca Barbato <lu_zero@gentoo.org>2010-07-23 20:05:52 +0000
commit737c996898818ccbc69e161e279b40199212d156 (patch)
tree6ab1bee6ee6d68fb99fccf678f65d80059e2939e /src
parentFix g++ compilation from a cross compiler (diff)
downloadgentoo-737c996898818ccbc69e161e279b40199212d156.tar.gz
gentoo-737c996898818ccbc69e161e279b40199212d156.tar.bz2
gentoo-737c996898818ccbc69e161e279b40199212d156.zip
Fix typo: wget -o is different than wget -O
Diffstat (limited to 'src')
-rw-r--r--src/patchsets/gcc/4.5.0/gentoo/94_all_gcc-4.3.3-pch-nostdinc-tr1.patch33
1 files changed, 22 insertions, 11 deletions
diff --git a/src/patchsets/gcc/4.5.0/gentoo/94_all_gcc-4.3.3-pch-nostdinc-tr1.patch b/src/patchsets/gcc/4.5.0/gentoo/94_all_gcc-4.3.3-pch-nostdinc-tr1.patch
index af0ce1b76c..001636b9b7 100644
--- a/src/patchsets/gcc/4.5.0/gentoo/94_all_gcc-4.3.3-pch-nostdinc-tr1.patch
+++ b/src/patchsets/gcc/4.5.0/gentoo/94_all_gcc-4.3.3-pch-nostdinc-tr1.patch
@@ -1,11 +1,22 @@
---2010-07-21 18:33:30-- http://bugs.gentoo.org/attachment.cgi?id=187319
-Resolving bugs.gentoo.org (bugs.gentoo.org)... 94.100.119.165
-Connecting to bugs.gentoo.org (bugs.gentoo.org)|94.100.119.165|:80... connected.
-HTTP request sent, awaiting response... 200 OK
-Length: 1173 (1.1K) [text/plain]
-Saving to: “attachment.cgi?id=187319”
-
- 0K . 100% 178M=0s
-
-2010-07-21 18:33:30 (178 MB/s) - “attachment.cgi?id=187319” saved [1173/1173]
-
+--- gcc-4.3.3/libstdc++-v3/include/Makefile.am.orig 2009-04-04 21:33:37.000000000 +0200
++++ gcc-4.3.3/libstdc++-v3/include/Makefile.am 2009-04-04 21:36:36.000000000 +0200
+@@ -1084,7 +1084,7 @@
+ # Build a precompiled TR1 include, stdtr1c++.h.gch/O2.gch
+ ${pch2_output}: ${pch2_source} ${pch1_output}
+ -mkdir -p ${pch2_output_builddir}
+- $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch2_source} -o $@
++ $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -nostdinc++ -O2 -g ${pch2_source} -o $@
+
+ # Build a precompiled extension include, extc++.h.gch/O2.gch
+ ${pch3_output}: ${pch3_source} ${pch2_output}
+--- gcc-4.3.3/libstdc++-v3/include/Makefile.in.orig 2009-04-04 21:36:09.000000000 +0200
++++ gcc-4.3.3/libstdc++-v3/include/Makefile.in 2009-04-04 21:36:25.000000000 +0200
+@@ -1475,7 +1475,7 @@
+ # Build a precompiled TR1 include, stdtr1c++.h.gch/O2.gch
+ ${pch2_output}: ${pch2_source} ${pch1_output}
+ -mkdir -p ${pch2_output_builddir}
+- $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch2_source} -o $@
++ $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -nostdinc++ -O2 -g ${pch2_source} -o $@
+
+ # Build a precompiled extension include, extc++.h.gch/O2.gch
+ ${pch3_output}: ${pch3_source} ${pch2_output}