summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-03-13 17:28:56 +0000
committerChristoph Mende <angelos@gentoo.org>2011-03-13 17:28:56 +0000
commit015d27a6f7096939addfb5084f5992ec567a2c0c (patch)
treedc7cf5b1f6655b3c8cab6b55113c934c911861f4
parentLast rites for media-plugins/gmpc-coveramazon (diff)
downloadgentoo-2-015d27a6f7096939addfb5084f5992ec567a2c0c.tar.gz
gentoo-2-015d27a6f7096939addfb5084f5992ec567a2c0c.tar.bz2
gentoo-2-015d27a6f7096939addfb5084f5992ec567a2c0c.zip
Initial import
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
-rw-r--r--gnome-extra/docky/ChangeLog10
-rw-r--r--gnome-extra/docky/docky-2.1.1.ebuild45
-rw-r--r--gnome-extra/docky/files/docky-2.1.1-mono-2.10.patch139
-rw-r--r--gnome-extra/docky/metadata.xml9
4 files changed, 203 insertions, 0 deletions
diff --git a/gnome-extra/docky/ChangeLog b/gnome-extra/docky/ChangeLog
new file mode 100644
index 000000000000..2fb1a98f70ca
--- /dev/null
+++ b/gnome-extra/docky/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for gnome-extra/docky
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/docky/ChangeLog,v 1.1 2011/03/13 17:28:56 angelos Exp $
+
+*docky-2.1.1 (13 Mar 2011)
+
+ 13 Mar 2011; <angelos@gentoo.org> +docky-2.1.1.ebuild,
+ +files/docky-2.1.1-mono-2.10.patch:
+ Initial import
+
diff --git a/gnome-extra/docky/docky-2.1.1.ebuild b/gnome-extra/docky/docky-2.1.1.ebuild
new file mode 100644
index 000000000000..079db713d071
--- /dev/null
+++ b/gnome-extra/docky/docky-2.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/docky/docky-2.1.1.ebuild,v 1.1 2011/03/13 17:28:56 angelos Exp $
+
+EAPI=3
+inherit eutils gnome2 mono
+
+DESCRIPTION="Elegant, powerful, clean dock"
+HOMEPAGE="https://wiki.go-docky.com"
+SRC_URI="http://launchpad.net/${PN}/2.1/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls"
+
+RDEPEND="dev-dotnet/dbus-sharp
+ dev-dotnet/dbus-sharp-glib
+ dev-dotnet/gconf-sharp
+ >=dev-dotnet/gio-sharp-0.2-r1
+ dev-dotnet/glib-sharp
+ dev-dotnet/gnome-desktop-sharp
+ dev-dotnet/gnome-keyring-sharp
+ dev-dotnet/gtk-sharp
+ dev-dotnet/mono-addins
+ dev-dotnet/notify-sharp
+ dev-dotnet/rsvg-sharp
+ dev-dotnet/wnck-sharp"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --enable-release
+ $(use_enable nls)"
+
+ DOCS="AUTHORS NEWS"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-mono-2.10.patch
+}
diff --git a/gnome-extra/docky/files/docky-2.1.1-mono-2.10.patch b/gnome-extra/docky/files/docky-2.1.1-mono-2.10.patch
new file mode 100644
index 000000000000..74619e5f13a8
--- /dev/null
+++ b/gnome-extra/docky/files/docky-2.1.1-mono-2.10.patch
@@ -0,0 +1,139 @@
+=== modified file 'Docky.CairoHelper/Docky.CairoHelper/DockySurface.cs'
+--- Docky.CairoHelper/Docky.CairoHelper/DockySurface.cs 2010-12-29 15:35:31 +0000
++++ Docky.CairoHelper/Docky.CairoHelper/DockySurface.cs 2011-03-13 17:16:18 +0000
+@@ -150,7 +150,7 @@
+ {
+ DockySurface result = new DockySurface (area.Width, area.Height, this);
+
+- Internal.Show (result.Context, 0 - area.X, 0 - area.Y);
++ Internal.Show (result.Context, -area.X, -area.Y);
+
+ return result;
+ }
+
+=== modified file 'Docky.Items/Docky.Painters/PagingDockPainter.cs'
+--- Docky.Items/Docky.Painters/PagingDockPainter.cs 2011-01-26 04:43:08 +0000
++++ Docky.Items/Docky.Painters/PagingDockPainter.cs 2011-03-13 17:16:18 +0000
+@@ -117,7 +117,7 @@
+ ShowBuffer (surface, LastPage, offset);
+ } else {
+ ShowBuffer (surface, Page, Allocation.Width - offset);
+- ShowBuffer (surface, LastPage, 0 - offset);
++ ShowBuffer (surface, LastPage, -offset);
+ }
+
+ // fade out the edges during a slide
+
+=== modified file 'Docky/Docky/CairoHelper/DockySurface_Extensions.cs'
+--- Docky/Docky/CairoHelper/DockySurface_Extensions.cs 2010-12-29 08:12:28 +0000
++++ Docky/Docky/CairoHelper/DockySurface_Extensions.cs 2011-03-13 17:16:18 +0000
+@@ -44,15 +44,15 @@
+ double cos, sin;
+ cos = Math.Cos (rotation);
+ sin = Math.Sin (rotation);
+- Matrix m = new Matrix (cos, sin, 0 - sin, cos, point.X, point.Y);
++ Matrix m = new Matrix (cos, sin, -sin, cos, point.X, point.Y);
+ cr.Transform (m);
+
+ if (zoom != 1)
+ cr.Scale (zoom, zoom);
+
+ cr.SetSource (self.Internal,
+- 0 - self.Width / 2,
+- 0 - self.Height / 2);
++ -self.Width / 2,
++ -self.Height / 2);
+
+ cr.PaintWithAlpha (opacity);
+
+@@ -85,7 +85,7 @@
+ double cos, sin;
+ cos = Math.Cos (rotation);
+ sin = Math.Sin (rotation);
+- Matrix m = new Matrix (cos, sin, 0 - sin, cos, point.X, point.Y);
++ Matrix m = new Matrix (cos, sin, -sin, cos, point.X, point.Y);
+ cr.Transform (m);
+
+ if (zoom != 1)
+@@ -97,8 +97,8 @@
+ cr.Scale (1, -1);
+
+ cr.SetSource (self.Internal,
+- 0 - self.Width / 2,
+- 0 - self.Height / 2);
++ -self.Width / 2,
++ -self.Height / 2);
+
+ cr.PaintWithAlpha (opacity * .3);
+
+
+=== modified file 'Docky/Docky/Interface/DockWindow.cs'
+--- Docky/Docky/Interface/DockWindow.cs 2011-03-03 08:59:59 +0000
++++ Docky/Docky/Interface/DockWindow.cs 2011-03-13 17:16:18 +0000
+@@ -2749,10 +2749,10 @@
+ } else {
+ switch (Position) {
+ case DockPosition.Top:
+- cr.SetSource (main_buffer.Internal, 0, 0 - HideOffset * ZoomedDockHeight);
++ cr.SetSource (main_buffer.Internal, 0, -HideOffset * ZoomedDockHeight);
+ break;
+ case DockPosition.Left:
+- cr.SetSource (main_buffer.Internal, 0 - HideOffset * ZoomedDockHeight, 0);
++ cr.SetSource (main_buffer.Internal, -HideOffset * ZoomedDockHeight, 0);
+ break;
+ case DockPosition.Right:
+ cr.SetSource (main_buffer.Internal, HideOffset * ZoomedDockHeight, 0);
+
+=== modified file 'Docky/Docky/Menus/DockMenu.cs'
+--- Docky/Docky/Menus/DockMenu.cs 2010-10-15 15:32:36 +0000
++++ Docky/Docky/Menus/DockMenu.cs 2011-03-13 17:16:18 +0000
+@@ -543,15 +543,15 @@
+ switch (Orientation) {
+ case DockPosition.Top:
+ cr.Scale (1, -1);
+- cr.Translate (0, 0 - background_buffer.Height);
++ cr.Translate (0, -background_buffer.Height);
+ break;
+ case DockPosition.Left:
+ cr.Rotate (Math.PI * .5);
+- cr.Translate (0, 0 - background_buffer.Height);
++ cr.Translate (0, -background_buffer.Height);
+ break;
+ case DockPosition.Right:
+ cr.Rotate (Math.PI * -0.5);
+- cr.Translate (0 - background_buffer.Width, 0);
++ cr.Translate (-background_buffer.Width, 0);
+ break;
+ }
+
+
+=== modified file 'StandardPlugins/Clock/src/ClockDockItem.cs'
+--- StandardPlugins/Clock/src/ClockDockItem.cs 2010-11-21 22:19:54 +0000
++++ StandardPlugins/Clock/src/ClockDockItem.cs 2011-03-13 17:16:18 +0000
+@@ -388,20 +388,20 @@
+ double minuteRotation = 2 * Math.PI * (DateTime.Now.Minute / 60.0) + Math.PI;
+ cr.Rotate (minuteRotation);
+ cr.MoveTo (0, radius - radius * .35);
+- cr.LineTo (0, 0 - radius * .15);
++ cr.LineTo (0, -radius * .15);
+ cr.Stroke ();
+- cr.Rotate (0 - minuteRotation);
++ cr.Rotate (-minuteRotation);
+
+ cr.Color = new Cairo.Color (0, 0, 0);
+ double hourRotation = 2 * Math.PI * (DateTime.Now.Hour / (ShowMilitary ? 24.0 : 12.0)) +
+ Math.PI + (Math.PI / (ShowMilitary ? 12.0 : 6.0)) * DateTime.Now.Minute / 60.0;
+ cr.Rotate (hourRotation);
+ cr.MoveTo (0, radius - radius * .5);
+- cr.LineTo (0, 0 - radius * .15);
++ cr.LineTo (0, -radius * .15);
+ cr.Stroke ();
+- cr.Rotate (0 - hourRotation);
++ cr.Rotate (-hourRotation);
+
+- cr.Translate (0 - center, 0 - center);
++ cr.Translate (-center, -center);
+
+ RenderFileOntoContext (cr, System.IO.Path.Combine (ThemePath, "clock-glass.svg"), radius * 2);
+ RenderFileOntoContext (cr, System.IO.Path.Combine (ThemePath, "clock-frame.svg"), radius * 2);
+
diff --git a/gnome-extra/docky/metadata.xml b/gnome-extra/docky/metadata.xml
new file mode 100644
index 000000000000..b94e58c765fb
--- /dev/null
+++ b/gnome-extra/docky/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+</pkgmetadata>