summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-03-05 05:28:48 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-03-05 05:28:48 +0000
commit023b27104131816a337cb2a8741a7527a7144d08 (patch)
tree26543cb97d5fe57a19b4280a621196f61cd0a097
parentBig cleanup: Include some patches and a manpage from Debian, re-work the code... (diff)
downloadgentoo-2-023b27104131816a337cb2a8741a7527a7144d08.tar.gz
gentoo-2-023b27104131816a337cb2a8741a7527a7144d08.tar.bz2
gentoo-2-023b27104131816a337cb2a8741a7527a7144d08.zip
Restore version needed by nodejs
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-libs/libuv/ChangeLog7
-rw-r--r--dev-libs/libuv/libuv-1.1.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/libuv/ChangeLog b/dev-libs/libuv/ChangeLog
index 481c48935dca..5b16a807093b 100644
--- a/dev-libs/libuv/ChangeLog
+++ b/dev-libs/libuv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libuv
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.35 2015/03/05 02:23:17 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.36 2015/03/05 05:28:48 patrick Exp $
+
+*libuv-1.1.0 (05 Mar 2015)
+
+ 05 Mar 2015; Patrick Lauer <patrick@gentoo.org> +libuv-1.1.0.ebuild:
+ Restore version needed by nodejs
05 Mar 2015; Julian Ospald <hasufell@gentoo.org> libuv-0.11.25-r1.ebuild,
libuv-0.11.29.ebuild, metadata.xml:
diff --git a/dev-libs/libuv/libuv-1.1.0.ebuild b/dev-libs/libuv/libuv-1.1.0.ebuild
new file mode 100644
index 000000000000..f8b138a84584
--- /dev/null
+++ b/dev-libs/libuv/libuv-1.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/libuv-1.1.0.ebuild,v 1.3 2015/03/05 05:28:48 patrick Exp $
+
+EAPI=5
+
+inherit eutils autotools multilib-minimal
+
+DESCRIPTION="A new platform layer for Node"
+HOMEPAGE="https://github.com/joyent/libuv"
+SRC_URI="https://github.com/libuv/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BSD-2 ISC MIT"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
+ > m4/libuv-extra-automake-flags.m4 || die
+
+ sed -i \
+ -e '/libuv_la_CFLAGS/s#-g##' \
+ Makefile.am || die "fixing CFLAGS failed!"
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ mkdir "${BUILD_DIR}"/test || die
+ cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
+ default
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}