summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad House <brad_mssw@gentoo.org>2004-01-24 20:43:22 +0000
committerBrad House <brad_mssw@gentoo.org>2004-01-24 20:43:22 +0000
commit077983c0ffeaaead383d5657862c61375bd8f861 (patch)
tree1df1100b71ede4a326cdd3dd5cad1416d95fecf4
parentAdded version 1.3.1 as ~x86 and cleaning up old versions. (diff)
downloadgentoo-2-077983c0ffeaaead383d5657862c61375bd8f861.tar.gz
gentoo-2-077983c0ffeaaead383d5657862c61375bd8f861.tar.bz2
gentoo-2-077983c0ffeaaead383d5657862c61375bd8f861.zip
version bump
-rw-r--r--sys-kernel/gentoo-dev-sources/ChangeLog8
-rw-r--r--sys-kernel/gentoo-dev-sources/files/digest-gentoo-dev-sources-2.6.2_rc13
-rw-r--r--sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.2_rc1.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-dev-sources/ChangeLog b/sys-kernel/gentoo-dev-sources/ChangeLog
index 6f76c8679ba0..5c132b2cc1e1 100644
--- a/sys-kernel/gentoo-dev-sources/ChangeLog
+++ b/sys-kernel/gentoo-dev-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/gentoo-dev-sources
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-dev-sources/ChangeLog,v 1.30 2004/01/12 22:24:44 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-dev-sources/ChangeLog,v 1.31 2004/01/24 20:43:22 brad_mssw Exp $
+
+*gentoo-dev-sources-2.6.2_rc1 (24 Jan 2004)
+
+ 24 Jan 2004; Brad House <brad_mssw@gentoo.org>
+ gentoo-dev-sources-2.6.2_rc1.ebuild:
+ test version, bump to _rc1
12 Jan 2004; John Mylchreest <johnm@gentoo.org>
gentoo-dev-sources-2.6.1-r1.ebuild:
diff --git a/sys-kernel/gentoo-dev-sources/files/digest-gentoo-dev-sources-2.6.2_rc1 b/sys-kernel/gentoo-dev-sources/files/digest-gentoo-dev-sources-2.6.2_rc1
new file mode 100644
index 000000000000..d367b920ae5d
--- /dev/null
+++ b/sys-kernel/gentoo-dev-sources/files/digest-gentoo-dev-sources-2.6.2_rc1
@@ -0,0 +1,3 @@
+MD5 0f9885e1262d6abc453787088ce7c398 patch-2.6.2-rc1.bz2 2058256
+MD5 fa82d1e4be518261b2eeb78eabf9cca7 linux-2.6.1.tar.bz2 33240033
+MD5 798bb5ba2266a1e16bf3558d21774791 genpatches-2.6-2.17.tar.bz2 510870
diff --git a/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.2_rc1.ebuild b/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.2_rc1.ebuild
new file mode 100644
index 000000000000..b2854571944d
--- /dev/null
+++ b/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.2_rc1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.2_rc1.ebuild,v 1.1 2004/01/24 20:43:22 brad_mssw Exp $
+
+# As this is the example source to use kernel-2.eclass then a very brief explanation is to go here
+#
+# any logic required for K_NOSETEXTRAVERSION, K_NOUSENAME UNIPATCH_LIST, or UNIPATCH_DOCS should
+# go BEFORE the inherit.
+# if you choose to not use detect_version then you should set EXTRAVERSION, KV, OKV and possibly S
+# BEFORE the inherit also.
+# If you wish to display additional postinst messages it is desired to pass it within K_EXTRAEINFO
+# This isnt always suitable if you required it to keep original formatting.
+#
+# patches should be passed as a list in UNIPATCH_LIST, this can contain tarballs, individual files or
+# patch numbers which you wish to be excluded from patching.
+#
+# any documentation which comes distributed with the patches should be added into UNIPATCH_DOCS and will
+# therefore be merged into /usr/share/doc
+# all patches passed are extracted or moved to ${WORKDIR}/patches
+
+#version of gentoo patchset
+GPV=2.17
+#GPV_SRC="mirror://gentoo/genpatches-2.6-${GPV}.tar.bz2"
+GPV_SRC="http://dev.gentoo.org/~brad_mssw/kernel_patches/DO_NOT_UPLOAD_TO_MIRRORS_WITHOUT_ASKING_ME_FIRST/genpatches-2.6-2.17.tar.bz2"
+RESTRICT="nomirror"
+KEYWORDS="-*"
+#KEYWORDS="~x86 ~amd64"
+
+UNIPATCH_LIST="${DISTDIR}/genpatches-2.6-${GPV}.tar.bz2"
+UNIPATCH_DOCS="${WORKDIR}/patches/genpatches-${GPV}/README"
+
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources including the gentoo patchset for the 2.6 kernel tree"
+SRC_URI="${KERNEL_URI} ${GPV_SRC}"
+
+
+pkg_postinst() {
+ postinst_sources
+
+ ewarn "IMPORTANT:"
+ ewarn "ptyfs support has now been dropped from devfs and as a"
+ ewarn "result you are now required to compile this support into"
+ ewarn "the kernel. You can do so by enabling the following options"
+ ewarn " Device Drivers -> Character devices -> Unix98 PTY Support"
+ ewarn " File systems -> Pseudo filesystems -> /dev/pts filesystem."
+ echo
+ ewarn "If you choose to use UCL/gcloop please ensure you also"
+ ewarn "emerge ucl as well as it currently depends on this library."
+ ewarn "Also please ensure that you compile gcloop without -fstack-protector."
+ echo
+}