summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-02-03 13:58:50 +0000
committerFabian Groffen <grobian@gentoo.org>2010-02-03 13:58:50 +0000
commit0a918b44d80c81013ef6e3cb0fa262cdfe564d4f (patch)
treebbc24ecd01e55adc165e12d27e5c919644891bc9
parentFix installing of non-existant file. (diff)
downloadgentoo-2-0a918b44d80c81013ef6e3cb0fa262cdfe564d4f.tar.gz
gentoo-2-0a918b44d80c81013ef6e3cb0fa262cdfe564d4f.tar.bz2
gentoo-2-0a918b44d80c81013ef6e3cb0fa262cdfe564d4f.zip
Add patch from upstream bugtracker to solve compilation issue on OSX when gtk was built with aqua USE-flag (the default).
(Portage version: 2.2.00.15187-prefix/cvs/SunOS i386)
-rw-r--r--net-libs/webkit-gtk/ChangeLog8
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.1.15.4-darwin-quartz.patch70
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild5
3 files changed, 81 insertions, 2 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index 9ce3313f847a..fc3bbde13cd5 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.62 2010/01/19 17:25:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.63 2010/02/03 13:58:49 grobian Exp $
+
+ 03 Feb 2010; Fabian Groffen <grobian@gentoo.org>
+ webkit-gtk-1.1.15.4.ebuild,
+ +files/webkit-gtk-1.1.15.4-darwin-quartz.patch:
+ Add patch from upstream bugtracker to solve compilation issue on OSX when
+ gtk was built with aqua USE-flag (the default).
19 Jan 2010; Raúl Porcel <armin76@gentoo.org> webkit-gtk-1.1.15.2.ebuild:
arm stable
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.1.15.4-darwin-quartz.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.1.15.4-darwin-quartz.patch
new file mode 100644
index 000000000000..a9eb7d079bcf
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.1.15.4-darwin-quartz.patch
@@ -0,0 +1,70 @@
+https://bugs.webkit.org/show_bug.cgi?id=28727
+https://bugs.webkit.org/attachment.cgi?id=41762
+
+Index: GNUmakefile.am
+===================================================================
+--- GNUmakefile.am (revision 49997)
++++ GNUmakefile.am (working copy)
+@@ -115,6 +115,9 @@
+ if !TARGET_WIN32
+ corekit_cppflags += -DXP_UNIX
+ endif
++if TARGET_QUARTZ
++corekit_cppflags += -DQUARTZ
++endif
+
+ # Default compiler flags
+ global_cflags += \
+Index: WebCore/plugins/gtk/PluginViewGtk.cpp
+===================================================================
+--- WebCore/plugins/gtk/PluginViewGtk.cpp (revision 49997)
++++ WebCore/plugins/gtk/PluginViewGtk.cpp (working copy)
+@@ -59,7 +59,7 @@
+ #include <gdkconfig.h>
+ #include <gtk/gtk.h>
+
+-#if defined(XP_UNIX)
++#if defined(XP_UNIX) && not defined(QUARTZ)
+ #include "gtk2xtbin.h"
+ #include <gdk/gdkx.h>
+ #elif defined(GDK_WINDOWING_WIN32)
+@@ -322,7 +322,7 @@
+
+ switch (variable) {
+ case NPNVxDisplay:
+-#if defined(XP_UNIX)
++#if defined(XP_UNIX) && not defined(QUARTZ)
+ if (m_needsXEmbed)
+ *(void **)value = (void *)GDK_DISPLAY();
+ else
+@@ -380,7 +380,7 @@
+ #endif
+
+ case NPNVnetscapeWindow: {
+-#if defined(XP_UNIX)
++#if defined(XP_UNIX) and not defined(QUARTZ)
+ void* w = reinterpret_cast<void*>(value);
+ *((XID *)w) = GDK_WINDOW_XWINDOW(m_parentFrame->view()->hostWindow()->platformPageClient()->window);
+ #endif
+@@ -456,8 +456,11 @@
+ setPlatformWidget(gtk_socket_new());
+ gtk_container_add(GTK_CONTAINER(m_parentFrame->view()->hostWindow()->platformPageClient()), platformPluginWidget());
+ g_signal_connect(platformPluginWidget(), "plug_removed", G_CALLBACK(plug_removed_cb), NULL);
+- } else if (m_isWindowed)
++ }
++#ifndef QUARTZ
++ else if (m_isWindowed)
+ setPlatformWidget(gtk_xtbin_new(m_parentFrame->view()->hostWindow()->platformPageClient()->window, 0));
++#endif
+ #else
+ setPlatformWidget(gtk_socket_new());
+ gtk_container_add(GTK_CONTAINER(m_parentFrame->view()->hostWindow()->platformPageClient()), platformPluginWidget());
+@@ -466,7 +469,7 @@
+
+ if (m_isWindowed) {
+ m_npWindow.type = NPWindowTypeWindow;
+-#if defined(XP_UNIX)
++#if defined(XP_UNIX) && not defined(QUARTZ)
+ NPSetWindowCallbackStruct *ws = new NPSetWindowCallbackStruct();
+
+ ws->type = 0;
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild
index f7531fe93224..775219cf7318 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild,v 1.4 2010/01/10 16:24:51 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild,v 1.5 2010/02/03 13:58:49 grobian Exp $
EAPI="2"
@@ -56,6 +56,9 @@ src_prepare() {
# FIXME: Fix unaligned accesses on ARM, IA64 and SPARC
use sparc && epatch "${FILESDIR}"/webkit-gtk-1.1.15.2-unaligned.patch
+ # Darwin/Aqua build is broken, needs autoreconf
+ epatch "${FILESDIR}"/${P}-darwin-quartz.patch
+
# Make it libtool-1 compatible
rm -v autotools/lt* autotools/libtool.m4 \
|| die "removing libtool macros failed"