summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-03 11:56:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-03 11:56:19 +0000
commit0ae07d04c035332ed84575c1a5f5b80a2dbfa6e4 (patch)
tree4b121f44becae77316b8df97859fa732d184ca58
parentVersion bump. (diff)
downloadgentoo-2-0ae07d04c035332ed84575c1a5f5b80a2dbfa6e4.tar.gz
gentoo-2-0ae07d04c035332ed84575c1a5f5b80a2dbfa6e4.tar.bz2
gentoo-2-0ae07d04c035332ed84575c1a5f5b80a2dbfa6e4.zip
Bump to 2.5.14
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
-rw-r--r--dev-util/duma/ChangeLog9
-rw-r--r--dev-util/duma/duma-2.5.14.ebuild81
2 files changed, 88 insertions, 2 deletions
diff --git a/dev-util/duma/ChangeLog b/dev-util/duma/ChangeLog
index ab67b5d2eccd..da22a18256f5 100644
--- a/dev-util/duma/ChangeLog
+++ b/dev-util/duma/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/duma
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/ChangeLog,v 1.7 2008/11/22 17:54:01 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/ChangeLog,v 1.8 2009/01/03 11:56:19 patrick Exp $
+
+*duma-2.5.14 (03 Jan 2009)
+
+ 03 Jan 2009; Patrick Lauer <patrick@gentoo.org> +duma-2.5.14.ebuild:
+ Bump to 2.5.14
22 Nov 2008; Markus Meier <maekke@gentoo.org> duma-2.5.13.ebuild:
amd64 stable, bug #243332
diff --git a/dev-util/duma/duma-2.5.14.ebuild b/dev-util/duma/duma-2.5.14.ebuild
new file mode 100644
index 000000000000..820b345a992e
--- /dev/null
+++ b/dev-util/duma/duma-2.5.14.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.5.14.ebuild,v 1.1 2009/01/03 11:56:19 patrick Exp $
+
+inherit eutils toolchain-funcs versionator
+
+MY_P="${PN}_$(replace_all_version_separators '_')"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="DUMA (Detect Unintended Memory Access) is a memory debugging library."
+HOMEPAGE="http://duma.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/duma/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ app-shells/bash"
+
+pkg_setup() {
+ #DUMA_OPTIONS="-DDUMA_LIB_NO_LEAKDETECTION"
+ DUMA_OPTIONS="-DDUMA_USE_FRAMENO"
+ if [ -n "${DUMA_OPTIONS}" ]; then
+ ewarn ""
+ elog "Custom build options are ${DUMA_OPTIONS}."
+ else
+ ewarn ""
+ elog "Custom build options are not set!"
+ fi
+ elog "See the package Makefile for for more options (also installed"
+ elog "with package docs as Makefile.duma)."
+ ewarn ""
+}
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:(prefix)/lib:(prefix)/$(get_libdir):g" Makefile
+ sed -i -e "s:share/doc/duma:share/doc/${P}:g" Makefile
+}
+
+src_compile(){
+ use amd64 && export DUMA_ALIGNMENT=16
+ # append-flags doesn't work here (stupid static makefile) and neither
+ # does distcc :(
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" CC=$(tc-getCC) \
+ || die "make failed"
+}
+
+src_test() {
+ ewarn "Control-C now if you want to disable tests..."
+ epause 5
+
+ cd "${S}"
+ use amd64 && export DUMA_ALIGNMENT=16
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" \
+ CC=$(tc-getCC) test || die "make test failed"
+
+ elog ""
+ ewarn "Check output above to verify all tests have passed. Both"
+ ewarn "static and dynamic confidence tests should say PASSED."
+ elog ""
+}
+
+src_install(){
+ # make install fails nicely here on the first file...
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGELOG TODO
+ # All the good comments on duma build options are in the Makefile
+ newdoc Makefile Makefile.duma
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins example[1-6].cpp
+ doins example_makes/ex6/Makefile
+ fi
+}