summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-23 13:35:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-23 13:35:32 +0000
commit0ba664bcc2c45cd41f7ab81aa16ed0fe2d46d365 (patch)
treecbdee9047cb2a69e3497275a0017aed62146b8dc
parentversion bump (diff)
downloadgentoo-2-0ba664bcc2c45cd41f7ab81aa16ed0fe2d46d365.tar.gz
gentoo-2-0ba664bcc2c45cd41f7ab81aa16ed0fe2d46d365.tar.bz2
gentoo-2-0ba664bcc2c45cd41f7ab81aa16ed0fe2d46d365.zip
version bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
-rw-r--r--media-sound/jalv/ChangeLog9
-rw-r--r--media-sound/jalv/jalv-1.4.0.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/media-sound/jalv/ChangeLog b/media-sound/jalv/ChangeLog
index 6943a7f52955..dbc29e8885e4 100644
--- a/media-sound/jalv/ChangeLog
+++ b/media-sound/jalv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/jalv
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/jalv/ChangeLog,v 1.3 2012/10/15 22:33:32 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jalv/ChangeLog,v 1.4 2013/02/23 13:35:32 aballier Exp $
+
+*jalv-1.4.0 (23 Feb 2013)
+
+ 23 Feb 2013; Alexis Ballier <aballier@gentoo.org> +jalv-1.4.0.ebuild:
+ version bump
*jalv-1.2.0 (15 Oct 2012)
diff --git a/media-sound/jalv/jalv-1.4.0.ebuild b/media-sound/jalv/jalv-1.4.0.ebuild
new file mode 100644
index 000000000000..3879d38c912b
--- /dev/null
+++ b/media-sound/jalv/jalv-1.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jalv/jalv-1.4.0.ebuild,v 1.1 2013/02/23 13:35:32 aballier Exp $
+
+EAPI=4
+
+inherit waf-utils
+
+DESCRIPTION="Simple but fully featured LV2 host for Jack"
+HOMEPAGE="http://drobilla.net/software/jalv/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gtk gtk2 gtkmm qt4"
+
+RDEPEND=">=media-libs/lv2-1.3.0
+ >=media-libs/lilv-0.15.1
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.12.0
+ >=media-libs/suil-0.6.0
+ >=media-libs/sratom-0.4.0
+ >=media-sound/jack-audio-connection-kit-0.120.0
+ gtk? ( >=x11-libs/gtk+-3.0.0:3 )
+ gtk2? ( >=x11-libs/gtk+-2.18.0:2 )
+ gtkmm? ( >=dev-cpp/gtkmm-2.20.0:2.4 )
+ qt4? ( x11-libs/qt-gui:4 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_configure() {
+ # otherwise automagic
+ use gtk || sed -i -e 's/gtk+-3.0/DiSaBlEd/' wscript
+ use gtk2 || sed -i -e 's/gtk+-2.0/DiSaBlEd/' wscript
+ use gtkmm || sed -i -e 's/gtkmm-2.4/DiSaBlEd/' wscript
+ use qt4 || sed -i -e 's/QtGui/DiSaBlEd/' wscript
+ waf-utils_src_configure \
+ "--docdir=/usr/share/doc/${PF}"
+}