summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Tolboom <ryan@gentoo.org>2001-05-27 22:39:02 +0000
committerRyan Tolboom <ryan@gentoo.org>2001-05-27 22:39:02 +0000
commit0bf39921ce704b6dde9eee87621741a3df4e839a (patch)
tree1afc1de7597bac1243fb0e43f122deecb55892c5
parentmore fixes to linux-2.4.4-r5 (diff)
downloadgentoo-2-0bf39921ce704b6dde9eee87621741a3df4e839a.tar.gz
gentoo-2-0bf39921ce704b6dde9eee87621741a3df4e839a.tar.bz2
gentoo-2-0bf39921ce704b6dde9eee87621741a3df4e839a.zip
Added DarcNES a multi-system emulator
-rw-r--r--ChangeLog6
-rw-r--r--app-emulation/darcnes/dn9b-0401.ebuild48
-rw-r--r--app-emulation/darcnes/files/digest-dn9b-04011
-rw-r--r--current-packages.new1
4 files changed, 56 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index f81d6396521d..9645b05e4136 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+date 27 May 2001
+
+new app-emulation/dn9b-0401
+ryan
+DarcNES is a multi-system emulator
+
date 25 May 2001
new app-emulation/fceultra-054
diff --git a/app-emulation/darcnes/dn9b-0401.ebuild b/app-emulation/darcnes/dn9b-0401.ebuild
new file mode 100644
index 000000000000..e50f24af836e
--- /dev/null
+++ b/app-emulation/darcnes/dn9b-0401.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ryan Tolboom <ryan@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/darcnes/dn9b-0401.ebuild,v 1.1 2001/05/27 22:39:02 ryan Exp $
+
+A=dn9b0401.tgz
+S=${WORKDIR}/darcnes
+DESCRIPTION="A multi-system emulator"
+SRC_URI="http://www.dridus.com/~nyef/darcnes/download/${A}"
+HOMEPAGE="http://www.netway.com/~nyef"
+
+DEPEND=">=media-libs/svgalib-1.4.2
+ X? ( virtual/x11 )
+ gtk? ( >=x11-libs/gtk+-1.2.8 )"
+
+src_compile() {
+
+ cp cd_unix.c cd_unix.c.orig
+ cat cd_unix.c.orig | sed "s:CDROM_DEVICE \"/dev/cdrom\"$:CDROM_DEVICE \"/dev/cdroms/cdrom0\":"\
+ > cd_unix.c
+ cp Makefile Makefile.orig
+ if [ "`use X`" ]
+ then
+ if [ "`use gtk`" ]
+ then
+ cat Makefile.orig | sed "s:^TARGET?=Linux_X$:TARGET?=Linux_GTK:" \
+ > Makefile
+ fi
+ try make
+ fi
+ cat Makefile.orig | sed "s:^TARGET?=Linux_X$:TARGET?=Linux_svgalib:" \
+ > Makefile
+ try make
+
+}
+
+src_install () {
+
+ exeinto /usr/bin
+ doexe sdarcnes
+ if [ "`use X`" ]
+ then
+ exeinto /usr/X11R6/bin
+ doexe darcnes
+ fi
+ dodoc readme
+
+}
diff --git a/app-emulation/darcnes/files/digest-dn9b-0401 b/app-emulation/darcnes/files/digest-dn9b-0401
new file mode 100644
index 000000000000..52909ccd7004
--- /dev/null
+++ b/app-emulation/darcnes/files/digest-dn9b-0401
@@ -0,0 +1 @@
+MD5 84d0cb6fc00017e5bf7cc09acd5e365b dn9b0401.tgz
diff --git a/current-packages.new b/current-packages.new
index f1b9f8b6fe7e..a4265d85297b 100644
--- a/current-packages.new
+++ b/current-packages.new
@@ -32,6 +32,7 @@
./app-editors/vim-gtk/vim-gtk-5.7-r2.ebuild
./app-editors/elvis/elvis-2.4.1.ebuild
./app-emulation/fceultra/fceu-054.ebuild
+./app-emulation/darcnes/dn9b-0401.ebuild
#./app-emulation/wine/wine-20001002.ebuild
./app-misc/gfontview/gfontview-0.4.1-r1.ebuild
./app-misc/lhinv/lhinv-1.1-r1.ebuild