summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2014-09-18 19:02:52 +0000
committerWilliam Hubbs <williamh@gentoo.org>2014-09-18 19:02:52 +0000
commit0d74c25cbb184468ce44ac0f69a7ad139af73aee (patch)
treeae217f95e1f36976655d1f2ba89f65f3de3da5de
parentVersion bump (diff)
downloadgentoo-2-0d74c25cbb184468ce44ac0f69a7ad139af73aee.tar.gz
gentoo-2-0d74c25cbb184468ce44ac0f69a7ad139af73aee.tar.bz2
gentoo-2-0d74c25cbb184468ce44ac0f69a7ad139af73aee.zip
import upstream patch to fix ipv6 related segmentation fault for bug #523128
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
-rw-r--r--net-misc/dhcpcd/ChangeLog8
-rw-r--r--net-misc/dhcpcd/dhcpcd-6.4.4-r1.ebuild119
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-6.4.4-fix-ipv6.patch19
3 files changed, 145 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 1ba160893e24..ed6ece47edd6 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.419 2014/09/16 22:25:35 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.420 2014/09/18 19:02:52 williamh Exp $
+
+*dhcpcd-6.4.4-r1 (18 Sep 2014)
+
+ 18 Sep 2014; William Hubbs <williamh@gentoo.org> +dhcpcd-6.4.4-r1.ebuild,
+ +files/dhcpcd-6.4.4-fix-ipv6.patch:
+ import upstream patch to fix ipv6 related segmentation fault for bug #523128
*dhcpcd-6.4.4 (16 Sep 2014)
diff --git a/net-misc/dhcpcd/dhcpcd-6.4.4-r1.ebuild b/net-misc/dhcpcd/dhcpcd-6.4.4-r1.ebuild
new file mode 100644
index 000000000000..0509f4ad85fd
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-6.4.4-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-6.4.4-r1.ebuild,v 1.1 2014/09/18 19:02:52 williamh Exp $
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]]; then
+ FOSSIL_URI="http://roy.marples.name/projects/dhcpcd"
+else
+ MY_P="${P/_alpha/-alpha}"
+ MY_P="${MY_P/_beta/-beta}"
+ MY_P="${MY_P/_rc/-rc}"
+ SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="elibc_glibc ipv6 kernel_linux +udev"
+
+COMMON_DEPEND="udev? ( virtual/udev )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+if [[ ${PV} == "9999" ]]; then
+ DEPEND+=" dev-vcs/fossil"
+
+ src_unpack()
+ {
+ local distdir=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}
+ local repo=${distdir}/fossil/${PN}.fossil
+
+ addwrite "${distdir}"
+
+ if [[ -e "${repo}" ]]; then
+ fossil pull "${FOSSIL_URI}" -R "${repo}" || die
+ else
+ mkdir -p "${distdir}/fossil" || die
+ fossil clone "${FOSSIL_URI}" "${repo}" || die
+ fi
+
+ mkdir -p "${S}" || die
+ cd "${S}" || die
+ fossil open "${repo}" || die
+ }
+fi
+
+src_prepare()
+{
+ epatch "${FILESDIR}"/${P}-fix-ipv6.patch
+ epatch_user
+}
+
+src_configure()
+{
+ local dev hooks rundir
+ use udev || dev="--without-dev --without-udev"
+ hooks="--with-hook=ntp.conf"
+ use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ use kernel_linux && rundir="--rundir=${EPREFIX}/run"
+ econf \
+ --prefix="${EPREFIX}" \
+ --libexecdir="${EPREFIX}/lib/dhcpcd" \
+ --dbdir="${EPREFIX}/var/lib/dhcpcd" \
+ --localstatedir="${EPREFIX}/var" \
+ ${rundir} \
+ $(use_enable ipv6) \
+ ${dev} \
+ ${hooks}
+}
+
+src_install()
+{
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst()
+{
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ if [ -z "$REPLACING_VERSIONS" ]; then
+ elog
+ elog "dhcpcd has zeroconf support active by default."
+ elog "This means it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the noipv4ll configuration"
+ elog "file option or the -L command line switch."
+ elog "See the dhcpcd and dhcpcd.conf man pages for more details."
+
+ elog
+ elog "Dhcpcd has duid enabled by default, and this may cause issues"
+ elog "with some dhcp servers. For more information, see"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
+ fi
+
+ if ! has_version net-dns/bind-tools; then
+ elog
+ elog "If you activate the lookup-hostname hook to look up your hostname"
+ elog "using the dns, you need to install net-dns/bind-tools."
+ fi
+}
diff --git a/net-misc/dhcpcd/files/dhcpcd-6.4.4-fix-ipv6.patch b/net-misc/dhcpcd/files/dhcpcd-6.4.4-fix-ipv6.patch
new file mode 100644
index 000000000000..ae070bf16463
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-6.4.4-fix-ipv6.patch
@@ -0,0 +1,19 @@
+Index: ipv6nd.c
+==================================================================
+--- ipv6nd.c
++++ ipv6nd.c
+@@ -394,10 +394,13 @@
+ int
+ ipv6nd_addrexists(struct dhcpcd_ctx *ctx, const struct ipv6_addr *addr)
+ {
+ struct ra *rap;
+ struct ipv6_addr *ap;
++
++ if (ctx->ipv6 == NULL)
++ return 0;
+
+ TAILQ_FOREACH(rap, ctx->ipv6->ra_routers, next) {
+ TAILQ_FOREACH(ap, &rap->addrs, next) {
+ if (addr == NULL) {
+ if ((ap->flags &
+