summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-25 18:28:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-25 18:28:14 +0000
commit13fd95dba50ef35b8570dec32c5f1eda545fd53e (patch)
treeac8090d32a8e28d922d3ae627c43424aa6789bfc
parentDelete older ebuild. (diff)
downloadgentoo-2-13fd95dba50ef35b8570dec32c5f1eda545fd53e.tar.gz
gentoo-2-13fd95dba50ef35b8570dec32c5f1eda545fd53e.tar.bz2
gentoo-2-13fd95dba50ef35b8570dec32c5f1eda545fd53e.zip
Delete calls to deprecated python_version().
(Portage version: HEAD/cvs/Linux x86_64)
-rw-r--r--dev-libs/boost/ChangeLog7
-rw-r--r--dev-libs/boost/boost-1.35.0-r2.ebuild11
-rw-r--r--dev-libs/boost/boost-1.35.0-r5.ebuild15
-rw-r--r--dev-libs/boost/boost-1.37.0-r1.ebuild15
-rw-r--r--dev-libs/boost/boost-1.39.0.ebuild15
-rw-r--r--dev-libs/boost/boost-1.41.0-r3.ebuild16
-rw-r--r--dev-libs/boost/boost-1.42.0.ebuild16
7 files changed, 46 insertions, 49 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 32e751dfad91..74deb036a903 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.195 2010/04/22 17:25:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.196 2010/04/25 18:28:14 arfrever Exp $
+
+ 25 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ boost-1.35.0-r2.ebuild, boost-1.35.0-r5.ebuild, boost-1.37.0-r1.ebuild,
+ boost-1.39.0.ebuild, boost-1.41.0-r3.ebuild, boost-1.42.0.ebuild:
+ Delete calls to deprecated python_version().
22 Apr 2010; Samuli Suominen <ssuominen@gentoo.org>
-boost-1.36.0-r1.ebuild:
diff --git a/dev-libs/boost/boost-1.35.0-r2.ebuild b/dev-libs/boost/boost-1.35.0-r2.ebuild
index f52e05d9168c..645c77bfe996 100644
--- a/dev-libs/boost/boost-1.35.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.35.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r2.ebuild,v 1.14 2009/10/21 16:57:23 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r2.ebuild,v 1.15 2010/04/25 18:28:14 arfrever Exp $
inherit python flag-o-matic multilib toolchain-funcs versionator check-reqs
@@ -94,7 +94,6 @@ generate_options() {
generate_userconfig() {
einfo "Writing new user-config.jam"
- python_version
local compiler compilerVersion compilerExecutable
if [[ ${CHOST} == *-darwin* ]] ; then
@@ -114,7 +113,7 @@ variant gentoorelease : release : <optimization>none <debug-symbols>none ;
variant gentoodebug : debug : <optimization>none <debug-symbols>none ;
using ${compiler} : ${compilerVersion} : ${compilerExecutable} : <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
-using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;
+using python : $(python_get_version) : /usr : $(python_get_includedir) : $(python_get_libdir) ;
__EOF__
@@ -171,8 +170,8 @@ src_install () {
# Move the mpi.so to the right place
if use mpi; then
- mkdir -p "${D}/usr/$(get_libdir)/python${PYVER}/site-packages"
- mv "${D}/usr/$(get_libdir)/mpi.so" "${D}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ mkdir -p "${D}$(python_get_sitedir)"
+ mv "${D}/usr/$(get_libdir)/mpi.so" "${D}$(python_get_sitedir)"
fi
if use doc ; then
diff --git a/dev-libs/boost/boost-1.35.0-r5.ebuild b/dev-libs/boost/boost-1.35.0-r5.ebuild
index 25ae3e48a0d8..a8f32276fd28 100644
--- a/dev-libs/boost/boost-1.35.0-r5.ebuild
+++ b/dev-libs/boost/boost-1.35.0-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r5.ebuild,v 1.14 2009/12/27 12:51:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r5.ebuild,v 1.15 2010/04/25 18:28:14 arfrever Exp $
EAPI="2"
@@ -110,8 +110,7 @@ src_configure() {
use mpi && mpi="using mpi ;"
if use python ; then
- python_version
- pystring="using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;"
+ pystring="using python : $(python_get_version) : /usr : $(python_get_includedir) : $(python_get_libdir) ;"
fi
cat > "${S}/user-config.jam" << __EOF__
@@ -192,10 +191,10 @@ src_install () {
# Move the mpi.so to the right place and make sure it's slotted
if use mpi && use python; then
- mkdir -p "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}"
- mv "${D}/usr/$(get_libdir)/mpi.so" "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/"
- touch "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/__init__.py"
- _add_line "python=\"/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/mpi.so\""
+ mkdir -p "${D}$(python_get_sitedir)/boost_${MAJOR_PV}"
+ mv "${D}/usr/$(get_libdir)/mpi.so" "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/"
+ touch "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/__init__.py"
+ _add_line "python=\"$(python_get_sitedir)/boost_${MAJOR_PV}/mpi.so\""
fi
if use doc ; then
diff --git a/dev-libs/boost/boost-1.37.0-r1.ebuild b/dev-libs/boost/boost-1.37.0-r1.ebuild
index a0b98c3823d5..5f4a999cc005 100644
--- a/dev-libs/boost/boost-1.37.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.37.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.37.0-r1.ebuild,v 1.14 2009/11/25 17:59:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.37.0-r1.ebuild,v 1.15 2010/04/25 18:28:14 arfrever Exp $
EAPI="2"
@@ -123,8 +123,7 @@ src_configure() {
use mpi && mpi="using mpi ;"
if use python ; then
- python_version
- pystring="using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;"
+ pystring="using python : $(python_get_version) : /usr : $(python_get_includedir) : $(python_get_libdir) ;"
fi
cat > "${S}/user-config.jam" << __EOF__
@@ -227,10 +226,10 @@ src_install () {
# Move the mpi.so to the right place and make sure it's slotted
if use mpi && use python; then
- mkdir -p "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}"
- mv "${D}/usr/$(get_libdir)/mpi.so" "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/"
- touch "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/__init__.py"
- _add_line "python=\"/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/mpi.so\""
+ mkdir -p "${D}$(python_get_sitedir)/boost_${MAJOR_PV}"
+ mv "${D}/usr/$(get_libdir)/mpi.so" "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/"
+ touch "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/__init__.py"
+ _add_line "python=\"$(python_get_sitedir)/boost_${MAJOR_PV}/mpi.so\""
fi
if use doc ; then
diff --git a/dev-libs/boost/boost-1.39.0.ebuild b/dev-libs/boost/boost-1.39.0.ebuild
index 27733ce2b64a..c07ea6483aad 100644
--- a/dev-libs/boost/boost-1.39.0.ebuild
+++ b/dev-libs/boost/boost-1.39.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.39.0.ebuild,v 1.8 2009/11/25 17:59:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.39.0.ebuild,v 1.9 2010/04/25 18:28:14 arfrever Exp $
EAPI="2"
@@ -117,8 +117,7 @@ src_configure() {
use mpi && mpi="using mpi ;"
if use python ; then
- python_version
- pystring="using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;"
+ pystring="using python : $(python_get_version) : /usr : $(python_get_includedir) : $(python_get_libdir) ;"
fi
cat > "${S}/user-config.jam" << __EOF__
@@ -221,10 +220,10 @@ src_install () {
# Move the mpi.so to the right place and make sure it's slotted
if use mpi && use python; then
- mkdir -p "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}"
- mv "${D}/usr/$(get_libdir)/mpi.so" "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/"
- touch "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/__init__.py"
- _add_line "python=\"/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/mpi.so\""
+ mkdir -p "${D}$(python_get_sitedir)/boost_${MAJOR_PV}"
+ mv "${D}/usr/$(get_libdir)/mpi.so" "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/"
+ touch "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/__init__.py"
+ _add_line "python=\"$(python_get_sitedir)/boost_${MAJOR_PV}/mpi.so\""
fi
if use doc ; then
diff --git a/dev-libs/boost/boost-1.41.0-r3.ebuild b/dev-libs/boost/boost-1.41.0-r3.ebuild
index 53b7d9daa8dd..eb8f8730e032 100644
--- a/dev-libs/boost/boost-1.41.0-r3.ebuild
+++ b/dev-libs/boost/boost-1.41.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.41.0-r3.ebuild,v 1.9 2010/04/17 23:52:17 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.41.0-r3.ebuild,v 1.10 2010/04/25 18:28:14 arfrever Exp $
EAPI="2"
@@ -51,8 +51,7 @@ _add_line() {
pkg_setup() {
# It doesn't compile with USE="python mpi" and python-3 (bug 295705)
if use python && use mpi ; then
- python_version
- if [[ "${PYVER_MAJOR}" != "2" ]]; then
+ if [[ "$(python_get_version --major)" != "2" ]]; then
eerror "The Boost.MPI python bindings do not support any other python version"
eerror "than 2.x. Please either use eselect to select a python 2.x version or"
eerror "disable the python and/or mpi use flag for =${CATEGORY}/${PF}."
@@ -142,8 +141,7 @@ src_configure() {
use mpi && mpi="using mpi ;"
if use python ; then
- python_version
- pystring="using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;"
+ pystring="using python : $(python_get_version) : /usr : $(python_get_includedir) : $(python_get_libdir) ;"
fi
cat > "${S}/user-config.jam" << __EOF__
@@ -264,10 +262,10 @@ src_install () {
# Move the mpi.so to the right place and make sure it's slotted
if use mpi && use python; then
- mkdir -p "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}"
- mv "${D}/usr/$(get_libdir)/mpi.so" "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/"
- touch "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/__init__.py"
- _add_line "python=\"/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/mpi.so\""
+ mkdir -p "${D}$(python_get_sitedir)/boost_${MAJOR_PV}"
+ mv "${D}/usr/$(get_libdir)/mpi.so" "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/"
+ touch "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/__init__.py"
+ _add_line "python=\"$(python_get_sitedir)/boost_${MAJOR_PV}/mpi.so\""
fi
if use doc ; then
diff --git a/dev-libs/boost/boost-1.42.0.ebuild b/dev-libs/boost/boost-1.42.0.ebuild
index 9dd8df0140a7..9be5b07bb920 100644
--- a/dev-libs/boost/boost-1.42.0.ebuild
+++ b/dev-libs/boost/boost-1.42.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.42.0.ebuild,v 1.2 2010/03/28 17:16:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.42.0.ebuild,v 1.3 2010/04/25 18:28:14 arfrever Exp $
EAPI="2"
@@ -50,8 +50,7 @@ _add_line() {
pkg_setup() {
# It doesn't compile with USE="python mpi" and python-3 (bug 295705)
if use python && use mpi ; then
- python_version
- if [[ "${PYVER_MAJOR}" != "2" ]]; then
+ if [[ "$(python_get_version --major)" != "2" ]]; then
eerror "The Boost.MPI python bindings do not support any other python version"
eerror "than 2.x. Please either use eselect to select a python 2.x version or"
eerror "disable the python and/or mpi use flag for =${CATEGORY}/${PF}."
@@ -127,8 +126,7 @@ src_configure() {
use mpi && mpi="using mpi ;"
if use python ; then
- python_version
- pystring="using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;"
+ pystring="using python : $(python_get_version) : /usr : $(python_get_includedir) : $(python_get_libdir) ;"
fi
cat > "${S}/user-config.jam" << __EOF__
@@ -258,10 +256,10 @@ src_install () {
# Move the mpi.so to the right place and make sure it's slotted
if use mpi && use python; then
- mkdir -p "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}" || die
- mv "${D}/usr/$(get_libdir)/mpi.so" "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/" || die
- touch "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/__init__.py" || die
- _add_line "python=\"/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/mpi.so\""
+ mkdir -p "${D}$(python_get_sitedir)/boost_${MAJOR_PV}" || die
+ mv "${D}/usr/$(get_libdir)/mpi.so" "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/" || die
+ touch "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/__init__.py" || die
+ _add_line "python=\"$(python_get_sitedir)/boost_${MAJOR_PV}/mpi.so\""
fi
if use doc ; then