summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-05-06 00:46:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-05-06 00:46:08 +0000
commit18152e1b07c281d6e923b76059c0064210074914 (patch)
treea808f52d8fb07acce4a9faae6f281ecd721320e3
parentCommiting again as last commit didn't complete successfully :| (diff)
downloadgentoo-2-18152e1b07c281d6e923b76059c0064210074914.tar.gz
gentoo-2-18152e1b07c281d6e923b76059c0064210074914.tar.bz2
gentoo-2-18152e1b07c281d6e923b76059c0064210074914.zip
version bump
(Portage version: 2.1.2.2)
-rw-r--r--games-action/blobandconquer/ChangeLog8
-rw-r--r--games-action/blobandconquer/blobandconquer-0.90.ebuild58
-rw-r--r--games-action/blobandconquer/files/digest-blobandconquer-0.903
3 files changed, 68 insertions, 1 deletions
diff --git a/games-action/blobandconquer/ChangeLog b/games-action/blobandconquer/ChangeLog
index 43af4d153d75..a35428c3aa1d 100644
--- a/games-action/blobandconquer/ChangeLog
+++ b/games-action/blobandconquer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/blobandconquer
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/ChangeLog,v 1.2 2007/02/27 12:39:17 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/ChangeLog,v 1.3 2007/05/06 00:46:08 mr_bones_ Exp $
+
+*blobandconquer-0.90 (06 May 2007)
+
+ 06 May 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +blobandconquer-0.90.ebuild:
+ version bump
27 Feb 2007; Simon Stelling <blubb@gentoo.org> blobandconquer-0.8.ebuild:
marked ~amd64; bug 167102
diff --git a/games-action/blobandconquer/blobandconquer-0.90.ebuild b/games-action/blobandconquer/blobandconquer-0.90.ebuild
new file mode 100644
index 000000000000..54ff4e15327b
--- /dev/null
+++ b/games-action/blobandconquer/blobandconquer-0.90.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/blobandconquer-0.90.ebuild,v 1.1 2007/05/06 00:46:08 mr_bones_ Exp $
+
+inherit eutils flag-o-matic toolchain-funcs games
+
+MY_PN=blobAndConquer
+DESCRIPTION="Mission and objective based 3D action game"
+HOMEPAGE="http://www.parallelrealities.co.uk/blobAndConquer.php"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:CFLAGS:CXXFLAGS:' makefile || die "sed failed"
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+ emake \
+ CXX=$(tc-getCXX) \
+ LIBPATH="${LDFLAGS}" \
+ DATADIR="${GAMES_DATADIR}"/${PN}/ \
+ DOCDIR=/usr/share/doc/${PF}/html/ \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${MY_PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data gfx music sound textures || die "doins failed"
+ doicon icons/${MY_PN}.png
+ domenu icons/${MY_PN}.desktop
+ cd doc
+ dohtml -r images pages index.html
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "Until ${PN}-1.0, save games may be incompatible with previous"
+ ewarn "versions."
+}
diff --git a/games-action/blobandconquer/files/digest-blobandconquer-0.90 b/games-action/blobandconquer/files/digest-blobandconquer-0.90
new file mode 100644
index 000000000000..80c14e315e08
--- /dev/null
+++ b/games-action/blobandconquer/files/digest-blobandconquer-0.90
@@ -0,0 +1,3 @@
+MD5 1be4fe4b85ce27868d616c6c10967334 blobAndConquer-0.90-1.tar.gz 35253483
+RMD160 709e4e5f159538d30223a0b2d5b895a482a83f88 blobAndConquer-0.90-1.tar.gz 35253483
+SHA256 ce3c3bab5bc79a13b05a80e9adf62d3d4a94d2389be5f2f105759d55542f9176 blobAndConquer-0.90-1.tar.gz 35253483