summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-16 12:13:32 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-16 12:13:32 +0000
commit1988a9bbd7b8eb408969e8ef5240c6ecaf6b4c8e (patch)
tree1926642bc73276c8051970756ba0d15ec0ee4b4e
parentVersion bump to 1.7.0.45, fixes bug #488174. (diff)
downloadgentoo-2-1988a9bbd7b8eb408969e8ef5240c6ecaf6b4c8e.tar.gz
gentoo-2-1988a9bbd7b8eb408969e8ef5240c6ecaf6b4c8e.tar.bz2
gentoo-2-1988a9bbd7b8eb408969e8ef5240c6ecaf6b4c8e.zip
Switch to git-r3. Add SLOT operators to dependencies.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--net-im/ekg2/ChangeLog5
-rw-r--r--net-im/ekg2/ekg2-9999.ebuild42
2 files changed, 25 insertions, 22 deletions
diff --git a/net-im/ekg2/ChangeLog b/net-im/ekg2/ChangeLog
index 6896a78a46c3..058ad6f8d5da 100644
--- a/net-im/ekg2/ChangeLog
+++ b/net-im/ekg2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/ekg2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg2/ChangeLog,v 1.52 2013/09/05 18:59:51 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg2/ChangeLog,v 1.53 2013/10/16 12:13:32 mgorny Exp $
+
+ 16 Oct 2013; Michał Górny <mgorny@gentoo.org> ekg2-9999.ebuild:
+ Switch to git-r3. Add SLOT operators to dependencies.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> ekg2-0.3.1-r1.ebuild,
ekg2-9999.ebuild:
diff --git a/net-im/ekg2/ekg2-9999.ebuild b/net-im/ekg2/ekg2-9999.ebuild
index 028cb4527c3e..a347e44214f8 100644
--- a/net-im/ekg2/ekg2-9999.ebuild
+++ b/net-im/ekg2/ekg2-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg2/ekg2-9999.ebuild,v 1.7 2013/09/05 18:59:51 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg2/ekg2-9999.ebuild,v 1.8 2013/10/16 12:13:32 mgorny Exp $
EAPI=5
@@ -9,7 +9,7 @@ AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/leafnode/${PN}.git
http://github.com/leafnode/${PN}.git"
-inherit git-2
+inherit git-r3
#endif
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -25,26 +25,26 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="gadu gpm gpg gtk minimal ncurses nls nntp openssl
perl python readline rss spell sqlite sqlite2 ssl xmpp unicode zlib"
-RDEPEND="dev-libs/glib:2
- gadu? ( net-libs/libgadu )
- gpg? ( app-crypt/gpgme )
- gtk? ( x11-libs/gtk+:2 )
- nls? ( virtual/libintl )
- openssl? ( dev-libs/openssl )
- perl? ( dev-lang/perl )
+RDEPEND="dev-libs/glib:2=
+ gadu? ( net-libs/libgadu:0= )
+ gpg? ( app-crypt/gpgme:1= )
+ gtk? ( x11-libs/gtk+:2= )
+ nls? ( virtual/libintl:0= )
+ openssl? ( dev-libs/openssl:0= )
+ perl? ( dev-lang/perl:0= )
python? ( ${PYTHON_DEPS} )
- readline? ( sys-libs/readline )
- rss? ( dev-libs/expat )
- ssl? ( net-libs/gnutls )
- xmpp? ( dev-libs/expat )
- zlib? ( sys-libs/zlib )
-
- ncurses? ( sys-libs/ncurses[unicode=]
- gpm? ( sys-libs/gpm )
- spell? ( app-text/aspell ) )
+ readline? ( sys-libs/readline:0= )
+ rss? ( dev-libs/expat:0= )
+ ssl? ( net-libs/gnutls:0= )
+ xmpp? ( dev-libs/expat:0= )
+ zlib? ( sys-libs/zlib:0= )
+
+ ncurses? ( sys-libs/ncurses:5=[unicode=]
+ gpm? ( sys-libs/gpm:0= )
+ spell? ( app-text/aspell:0= ) )
sqlite? (
- !sqlite2? ( dev-db/sqlite:3 )
- sqlite2? ( dev-db/sqlite:0 ) )"
+ !sqlite2? ( dev-db/sqlite:3= )
+ sqlite2? ( dev-db/sqlite:0= ) )"
DEPEND="${RDEPEND}
sys-devel/gettext"
@@ -63,7 +63,7 @@ SRC_URI=
pkg_pretend() {
if ! use gtk && ! use ncurses && ! use readline; then
- ewarn 'ekg2 is being compiled without any frontend, you should consider'
+ ewarn 'ekg2 is being compiled without any frontend. You should consider'
ewarn 'enabling at least one of following USEflags:'
ewarn ' gtk, ncurses, readline.'
fi