summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-08-30 11:28:01 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-08-30 11:28:01 +0000
commit1b33ab45e91cab305a0d37658113c468e4278a5f (patch)
tree7131ee3b5bc03c4e09c9da34803c3bd02c251aae
parentStable for amd64 wrt bug #517878 (diff)
downloadgentoo-2-1b33ab45e91cab305a0d37658113c468e4278a5f.tar.gz
gentoo-2-1b33ab45e91cab305a0d37658113c468e4278a5f.tar.bz2
gentoo-2-1b33ab45e91cab305a0d37658113c468e4278a5f.zip
Cleanup old.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--dev-ruby/multi_json/ChangeLog6
-rw-r--r--dev-ruby/multi_json/multi_json-1.10.0.ebuild73
-rw-r--r--dev-ruby/multi_json/multi_json-1.6.1.ebuild58
-rw-r--r--dev-ruby/multi_json/multi_json-1.9.2.ebuild74
4 files changed, 5 insertions, 206 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index 7d74003be048..15586d585b35 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.45 2014/08/30 10:27:56 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.46 2014/08/30 11:28:01 mrueg Exp $
+
+ 30 Aug 2014; Manuel Rüger <mrueg@gentoo.org> -multi_json-1.10.0.ebuild,
+ -multi_json-1.6.1.ebuild, -multi_json-1.9.2.ebuild:
+ Cleanup old.
30 Aug 2014; Manuel Rüger <mrueg@gentoo.org> multi_json-1.6.1-r1.ebuild:
Stable on amd64.
diff --git a/dev-ruby/multi_json/multi_json-1.10.0.ebuild b/dev-ruby/multi_json/multi_json-1.10.0.ebuild
deleted file mode 100644
index affbced1a3bf..000000000000
--- a/dev-ruby/multi_json/multi_json-1.10.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.10.0.ebuild,v 1.2 2014/08/15 16:56:41 armin76 Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem to provide swappable JSON backends"
-HOMEPAGE="http://github.com/intridea/multi_json"
-LICENSE="MIT"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-1.0 =dev-ruby/activesupport-3* )"
-
-ruby_add_bdepend "doc? ( dev-ruby/rspec:2 dev-ruby/yard )"
-
-ruby_add_bdepend "test? ( dev-ruby/json )"
-
-USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
-
- # Remove unimportant rspec options not supported by rspec 2.6.
- rm .rspec || die
-
- # Remove specs specific to oj since we don't package oj yet.
- sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
- -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
- -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
- -e '/using one-shot parser/,/^ end/ s:^:#:' \
- spec/multi_json_spec.rb
-
- # Avoid simplecov which only works with ruby 1.9
- sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
-
- # Remove unpackaged and for our purposes unneeded coveralls
- sed -i -e '/coveralls/d' spec/spec_helper.rb || die
-
- # Avoid testing unpackaged adapters
- rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Compiled code is not supported for jruby 1.6
- rm spec/json_gem_adapter_spec.rb || die
- # jr_jackson is not supported but needed for the common tests.
- rm spec/multi_json_spec.rb || die
- ;;
- esac
-}
-
-each_ruby_test() {
- for t in spec/*_spec.rb; do
- ${RUBY} -S rspec ${t} || die
- done
-}
diff --git a/dev-ruby/multi_json/multi_json-1.6.1.ebuild b/dev-ruby/multi_json/multi_json-1.6.1.ebuild
deleted file mode 100644
index 4aaee84134c0..000000000000
--- a/dev-ruby/multi_json/multi_json-1.6.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.6.1.ebuild,v 1.4 2014/08/15 16:56:41 armin76 Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 jruby"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem to provide swappable JSON backends"
-HOMEPAGE="http://github.com/intridea/multi_json"
-LICENSE="MIT"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
-
-ruby_add_bdepend "doc? ( dev-ruby/rspec:2 dev-ruby/yard )"
-
-ruby_add_bdepend "test? ( dev-ruby/json )"
-
-USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
- rm Gemfile || die "Unable to remove bundler Gemfile."
-
- # Remove unimportant rspec options not supported by rspec 2.6.
- rm .rspec || die
-
- # Remove specs specific to oj since we don't package oj yet.
- sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
- sed -i -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' spec/multi_json_spec.rb
-
- # Contains hardcoded yajl reference with no special case for jruby
- sed -i -e '/can set adapter for a block/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
-
- # Avoid simplecov which only works with ruby 1.9
- sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/helper.rb || die
-
- # Remove unpackaged and for our purposes unneeded coveralls
- sed -i -e '/coveralls/d' spec/helper.rb || die
-}
-
-each_ruby_test() {
- CI=true each_fakegem_test
-}
diff --git a/dev-ruby/multi_json/multi_json-1.9.2.ebuild b/dev-ruby/multi_json/multi_json-1.9.2.ebuild
deleted file mode 100644
index c91d1340bf90..000000000000
--- a/dev-ruby/multi_json/multi_json-1.9.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.9.2.ebuild,v 1.2 2014/08/15 16:56:41 armin76 Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem to provide swappable JSON backends"
-HOMEPAGE="http://github.com/intridea/multi_json"
-LICENSE="MIT"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
-
-ruby_add_bdepend "doc? ( dev-ruby/rspec:2 dev-ruby/yard )"
-
-ruby_add_bdepend "test? ( dev-ruby/json )"
-
-USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
- rm Gemfile || die "Unable to remove bundler Gemfile."
-
- # Remove unimportant rspec options not supported by rspec 2.6.
- rm .rspec || die
-
- # Remove specs specific to oj since we don't package oj yet.
- sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
- -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
- -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
- -e '/using one-shot parser/,/^ end/ s:^:#:' \
- spec/multi_json_spec.rb
-
- # Avoid simplecov which only works with ruby 1.9
- sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
-
- # Remove unpackaged and for our purposes unneeded coveralls
- sed -i -e '/coveralls/d' spec/spec_helper.rb || die
-
- # Avoid testing unpackaged adapters
- rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Compiled code is not supported for jruby 1.6
- rm spec/json_gem_adapter_spec.rb || die
- # jr_jackson is not supported but needed for the common tests.
- rm spec/multi_json_spec.rb || die
- ;;
- esac
-}
-
-each_ruby_test() {
- for t in spec/*_spec.rb; do
- ${RUBY} -S rspec ${t} || die
- done
-}