summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2012-03-28 18:44:16 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2012-03-28 18:44:16 +0000
commit20259420d3781d5727e177f9df5b0d4ee88d5dea (patch)
tree96e727d7f208593cb35c7b6323f319073381e8d7
parentwebrtc-audio-processing is only supported on x86/amd64. Possibly arm can be a... (diff)
downloadgentoo-2-20259420d3781d5727e177f9df5b0d4ee88d5dea.tar.gz
gentoo-2-20259420d3781d5727e177f9df5b0d4ee88d5dea.tar.bz2
gentoo-2-20259420d3781d5727e177f9df5b0d4ee88d5dea.zip
Add a 2.0 RC2 ebuild. Lots of features and fixes (sample rate switching, new echo canceller, jack detection, virtual surround module, Xen support and lots more). Packaging-wise: add support a new echo canceller on-by-default, drop esound support, make ALSA plugins work out of the box.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
-rw-r--r--media-sound/pulseaudio/ChangeLog11
-rw-r--r--media-sound/pulseaudio/metadata.xml5
-rw-r--r--media-sound/pulseaudio/pulseaudio-1.99.2.ebuild218
-rw-r--r--media-sound/pulseaudio/pulseaudio-9999.ebuild7
4 files changed, 238 insertions, 3 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index 0c316ce6484a..b1102f1971e1 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.265 2012/03/20 23:49:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.266 2012/03/28 18:44:16 ford_prefect Exp $
+
+*pulseaudio-1.99.2 (28 Mar 2012)
+
+ 28 Mar 2012; Arun Raghavan <ford_prefect@gentoo.org>
+ +pulseaudio-1.99.2.ebuild, pulseaudio-9999.ebuild, metadata.xml:
+ Add a 2.0 RC2 ebuild. Lots of features and fixes (sample rate switching, new
+ echo canceller, jack detection, virtual surround module, Xen support and lots
+ more). Packaging-wise: add support a new echo canceller on-by-default, drop
+ esound support, make ALSA plugins work out of the box.
20 Mar 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml,
pulseaudio-1.1-r1.ebuild, pulseaudio-9999.ebuild:
diff --git a/media-sound/pulseaudio/metadata.xml b/media-sound/pulseaudio/metadata.xml
index 7f6bf29c1a1c..f845af763254 100644
--- a/media-sound/pulseaudio/metadata.xml
+++ b/media-sound/pulseaudio/metadata.xml
@@ -56,5 +56,10 @@
databases. Recommended for desktop usage. This flag causes the
whole package to be licensed under GPL-2 or later.
</flag>
+ <flag name="webrtc-aec">
+ Uses the webrtc.org AudioProcessing library for enhancing VoIP calls
+ greatly in applications that support it by performing acoustic echo
+ cancellation, analog gain control, noise suppression and other processing.
+ </flag>
</use>
</pkgmetadata>
diff --git a/media-sound/pulseaudio/pulseaudio-1.99.2.ebuild b/media-sound/pulseaudio/pulseaudio-1.99.2.ebuild
new file mode 100644
index 000000000000..cf843496e8d9
--- /dev/null
+++ b/media-sound/pulseaudio/pulseaudio-1.99.2.ebuild
@@ -0,0 +1,218 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-1.99.2.ebuild,v 1.1 2012/03/28 18:44:16 ford_prefect Exp $
+
+EAPI=4
+
+inherit eutils libtool flag-o-matic versionator
+
+DESCRIPTION="A networked sound server with an advanced plugin system"
+HOMEPAGE="http://www.pulseaudio.org/"
+
+SRC_URI="http://freedesktop.org/software/pulseaudio/releases/${P}.tar.xz"
+
+# libpulse-simple and libpulse link to libpulse-core; this is daemon's
+# library and can link to gdbm and other GPL-only libraries. In this
+# cases, we have a fully GPL-2 package. Leaving the rest of the
+# GPL-forcing USE flags for those who use them.
+LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+alsa avahi +caps equalizer jack lirc oss tcpd +X dbus libsamplerate gnome bluetooth +asyncns +glib test doc +udev ipv6 system-wide realtime +orc ssl +gdbm +webrtc-aec"
+
+RDEPEND=">=media-libs/libsndfile-1.0.20
+ X? (
+ >=x11-libs/libX11-1.4.0
+ >=x11-libs/libxcb-1.6
+ >=x11-libs/xcb-util-0.3.1
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXtst
+ )
+ caps? ( sys-libs/libcap )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.1-r1 )
+ alsa? ( >=media-libs/alsa-lib-1.0.19 )
+ glib? ( >=dev-libs/glib-2.4.0 )
+ avahi? ( >=net-dns/avahi-0.6.12[dbus] )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.117 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ lirc? ( app-misc/lirc )
+ dbus? ( >=sys-apps/dbus-1.0.0 )
+ gnome? ( >=gnome-base/gconf-2.4.0 )
+ bluetooth? (
+ >=net-wireless/bluez-4
+ >=sys-apps/dbus-1.0.0
+ )
+ asyncns? ( net-libs/libasyncns )
+ udev? ( || ( >=sys-fs/udev-171[hwdb] >=sys-fs/udev-143[extras] ) )
+ realtime? ( sys-auth/rtkit )
+ equalizer? ( sci-libs/fftw:3.0 )
+ orc? ( >=dev-lang/orc-0.4.9 )
+ ssl? ( dev-libs/openssl )
+ >=media-libs/speex-1.2_rc1
+ gdbm? ( sys-libs/gdbm )
+ webrtc-aec? ( media-libs/webrtc-audio-processing )
+ dev-libs/json-c
+ >=sys-devel/libtool-2.2.4" # it's a valid RDEPEND, libltdl.so is used
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ X? (
+ x11-proto/xproto
+ >=x11-libs/libXtst-1.0.99.2
+ )
+ dev-libs/libatomic_ops
+ dev-util/pkgconfig
+ system-wide? ( || ( dev-util/unifdef sys-freebsd/freebsd-ubin ) )
+ dev-util/intltool"
+# This is a PDEPEND to avoid a circular dep
+PDEPEND="media-plugins/alsa-plugins[pulseaudio]"
+
+# alsa-utils dep is for the alsasound init.d script (see bug #155707)
+# bluez dep is for the bluetooth init.d script
+RDEPEND="${RDEPEND}
+ X? ( gnome-extra/gnome-audio )
+ system-wide? (
+ sys-apps/openrc
+ alsa? ( media-sound/alsa-utils )
+ bluetooth? ( >=net-wireless/bluez-4 )
+ )"
+
+# See "*** BLUEZ support not found (requires D-Bus)" in configure.ac
+REQUIRED_USE="bluetooth? ( dbus )"
+
+pkg_setup() {
+ enewgroup audio 18 # Just make sure it exists
+ enewgroup pulse-access
+ enewgroup pulse
+ enewuser pulse -1 -1 /var/run/pulse pulse,audio
+}
+
+src_configure() {
+ # It's a binutils bug, once I can find time to fix that I'll add a
+ # proper dependency and fix this up. — flameeyes
+ append-ldflags $(no-as-needed)
+
+ if use gdbm; then
+ myconf+=" --with-database=gdbm"
+ #elif use tdb; then
+ # myconf+=" --with-database=tdb"
+ else
+ myconf+=" --with-database=simple"
+ fi
+
+ econf \
+ --enable-largefile \
+ $(use_enable glib glib2) \
+ --disable-solaris \
+ $(use_enable asyncns) \
+ $(use_enable oss oss-output) \
+ $(use_enable alsa) \
+ $(use_enable lirc) \
+ $(use_enable tcpd tcpwrap) \
+ $(use_enable jack) \
+ $(use_enable lirc) \
+ $(use_enable avahi) \
+ --disable-hal \
+ $(use_enable dbus) \
+ $(use_enable gnome gconf) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable bluetooth bluez) \
+ $(use_enable X x11) \
+ $(use_enable test default-build-tests) \
+ $(use_enable udev) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ $(use_with caps) \
+ $(use_with equalizer fftw) \
+ $(use_with webrtc-aec) \
+ --disable-adrian-aec \
+ --disable-esound \
+ --localstatedir="${EPREFIX}"/var \
+ --with-udev-rules-dir="${EPREFIX}/lib/udev/rules.d" \
+ ${myconf}
+
+ if use doc; then
+ pushd doxygen
+ doxygen doxygen.conf
+ popd
+ fi
+}
+
+src_test() {
+ # We avoid running the toplevel check target because that will run
+ # po/'s tests too, and they are broken. Officially, it should work
+ # with intltool 0.41, but that doesn't look like a stable release.
+ emake -C src check
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ # Drop the script entirely if X is disabled
+ use X || rm "${ED}"/usr/bin/start-pulseaudio-x11
+
+ if use system-wide; then
+ newconfd "${FILESDIR}/pulseaudio.conf.d" pulseaudio
+
+ use_define() {
+ local define=${2:-$(echo $1 | tr '[:lower:]' '[:upper:]')}
+
+ use "$1" && echo "-D$define" || echo "-U$define"
+ }
+
+ unifdef $(use_define avahi) \
+ $(use_define alsa) \
+ $(use_define bluetooth) \
+ $(use_define udev) \
+ "${FILESDIR}/pulseaudio.init.d-5" \
+ > "${T}/pulseaudio"
+
+ doinitd "${T}/pulseaudio"
+ fi
+
+ use avahi && sed -i -e '/module-zeroconf-publish/s:^#::' "${ED}/etc/pulse/default.pa"
+
+ dodoc README todo
+
+ if use doc; then
+ pushd doxygen/html
+ dohtml *
+ popd
+ fi
+
+ # Create the state directory
+ use prefix || diropts -o pulse -g pulse -m0755
+ keepdir /var/run/pulse
+
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ if use system-wide; then
+ elog "PulseAudio in Gentoo can use a system-wide pulseaudio daemon."
+ elog "This support is enabled by starting the pulseaudio init.d ."
+ elog "To be able to access that you need to be in the group pulse-access."
+ elog "If you choose to use this feature, please make sure that you"
+ elog "really want to run PulseAudio this way:"
+ elog " http://pulseaudio.org/wiki/WhatIsWrongWithSystemMode"
+ elog "For more information about system-wide support, please refer to:"
+ elog " http://pulseaudio.org/wiki/SystemWideInstance"
+ if use gnome ; then
+ elog
+ elog "By enabling gnome USE flag, you enabled gconf support. Please note"
+ elog "that you might need to remove the gnome USE flag or disable the"
+ elog "gconf module on /etc/pulse/system.pa to be able to use PulseAudio"
+ elog "with a system-wide instance."
+ fi
+ fi
+ if use bluetooth; then
+ elog
+ elog "The Bluetooth proximity module is not enabled in the default"
+ elog "configuration file. If you do enable it, you'll have to have"
+ elog "your Bluetooth controller enabled and inserted at bootup or"
+ elog "PulseAudio will refuse to start."
+ fi
+
+ eselect esd update --if-unset
+}
diff --git a/media-sound/pulseaudio/pulseaudio-9999.ebuild b/media-sound/pulseaudio/pulseaudio-9999.ebuild
index e7d86af80620..5b331207251a 100644
--- a/media-sound/pulseaudio/pulseaudio-9999.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-9999.ebuild,v 1.20 2012/03/20 23:49:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-9999.ebuild,v 1.21 2012/03/28 18:44:16 ford_prefect Exp $
EAPI=4
@@ -18,7 +18,7 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/pulseaudio/pulseaudio.git"
LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
SLOT="0"
KEYWORDS=""
-IUSE="+alsa avahi +caps equalizer jack lirc oss tcpd +X dbus libsamplerate gnome bluetooth +asyncns +glib test doc +udev ipv6 system-wide realtime +orc ssl +gdbm"
+IUSE="+alsa avahi +caps equalizer jack lirc oss tcpd +X dbus libsamplerate gnome bluetooth +asyncns +glib test doc +udev ipv6 system-wide realtime +orc ssl +gdbm +webrtc-aec"
RDEPEND=">=media-libs/libsndfile-1.0.20
X? (
@@ -51,6 +51,7 @@ RDEPEND=">=media-libs/libsndfile-1.0.20
ssl? ( dev-libs/openssl )
>=media-libs/speex-1.2_rc1
gdbm? ( sys-libs/gdbm )
+ webrtc-aec? ( media-libs/webrtc-audio-processing )
dev-libs/json-c
>=sys-devel/libtool-2.2.4" # it's a valid RDEPEND, libltdl.so is used
@@ -126,6 +127,8 @@ src_configure() {
$(use_enable ssl openssl) \
$(use_with caps) \
$(use_with equalizer fftw) \
+ $(use_with webrtc-aec) \
+ --disable-adrian-aec \
--disable-esound \
--localstatedir="${EPREFIX}"/var \
--with-udev-rules-dir="${EPREFIX}/lib/udev/rules.d" \