summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-05-11 08:04:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-05-11 08:04:49 +0000
commit209d2addb163f120259e7b997846f4441382608a (patch)
tree3a4dea16e5757db7041aba8b6ee59695ae63113d
parentBug #132722, version bump. (diff)
downloadgentoo-2-209d2addb163f120259e7b997846f4441382608a.tar.gz
gentoo-2-209d2addb163f120259e7b997846f4441382608a.tar.bz2
gentoo-2-209d2addb163f120259e7b997846f4441382608a.zip
Compile fix - clean up usage of LDFLAGS/CC/CXX to allow them to work with multiple arguments.
(Portage version: 2.1_pre10-r5)
-rw-r--r--sci-mathematics/octave/ChangeLog6
-rw-r--r--sci-mathematics/octave/octave-2.1.72.ebuild9
2 files changed, 10 insertions, 5 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index abdd99b40e33..e6f4cd612bd8 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.29 2006/04/27 22:30:42 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.30 2006/05/11 08:04:49 robbat2 Exp $
+
+ 11 May 2006; Robin H. Johnson <robbat2@gentoo.org> octave-2.1.72.ebuild:
+ Compile fix - clean up usage of LDFLAGS/CC/CXX to allow them to work with
+ multiple arguments.
27 Apr 2006; Alec Warner <antarus@gentoo.org>
files/digest-octave-2.1.57-r1, files/digest-octave-2.1.69, Manifest:
diff --git a/sci-mathematics/octave/octave-2.1.72.ebuild b/sci-mathematics/octave/octave-2.1.72.ebuild
index 6c3797945bab..f4301c410922 100644
--- a/sci-mathematics/octave/octave-2.1.72.ebuild
+++ b/sci-mathematics/octave/octave-2.1.72.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.72.ebuild,v 1.4 2006/04/24 23:22:32 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.72.ebuild,v 1.5 2006/05/11 08:04:49 robbat2 Exp $
inherit flag-o-matic fortran
@@ -48,7 +48,7 @@ src_compile() {
# Only add -lz to LDFLAGS if we have zlib in USE !
# BUG #52604
# Danny van Dyk 2004/08/26
- use zlib && LDFLAGS="${LDFLAGS} -lz"
+ use zlib && append-ldflags -lz
# MPI requires the use of gcc/g++ wrappers
# mpicc/mpic++
@@ -66,12 +66,13 @@ src_compile() {
fi
+ LDFLAGS="${LDFLAGS}" \
+ CC="${CC}" CXX="${CXX}" \
econf \
$(use_with hdf5) \
$(use_enable readline) \
${myconf} \
- LDFLAGS="${LDFLAGS}" \
- CC="${CC}" CXX="${CXX}" || die "econf failed"
+ || die "econf failed"
emake || die "emake failed"
}