summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-11-30 13:35:59 +0000
committerNaohiro Aota <naota@gentoo.org>2013-11-30 13:35:59 +0000
commit20b7f505d89c450fed9a6ecc7481cafd4c57f8e8 (patch)
tree04826b6e6e94b5c256b50b5acb80dcce776b69c3
parentMask more ruby18-only packages. (diff)
downloadgentoo-2-20b7f505d89c450fed9a6ecc7481cafd4c57f8e8.tar.gz
gentoo-2-20b7f505d89c450fed9a6ecc7481cafd4c57f8e8.tar.bz2
gentoo-2-20b7f505d89c450fed9a6ecc7481cafd4c57f8e8.zip
Use pam_ftpusers on FreeBSD. #462204
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F8551514)
-rw-r--r--net-ftp/ftpbase/ChangeLog5
-rw-r--r--net-ftp/ftpbase/ftpbase-0.01-r2.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/net-ftp/ftpbase/ChangeLog b/net-ftp/ftpbase/ChangeLog
index 72aba8ef140c..335fc476e034 100644
--- a/net-ftp/ftpbase/ChangeLog
+++ b/net-ftp/ftpbase/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-ftp/ftpbase
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.30 2013/03/03 09:00:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.31 2013/11/30 13:35:59 naota Exp $
+
+ 30 Nov 2013; Naohiro Aota <naota@gentoo.org> ftpbase-0.01-r2.ebuild:
+ Use pam_ftpusers on FreeBSD. #462204
03 Mar 2013; Mike Frysinger <vapier@gentoo.org> ftpbase-0.00.ebuild,
ftpbase-0.01-r1.ebuild, ftpbase-0.01-r2.ebuild, ftpbase-0.01.ebuild:
diff --git a/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild b/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild
index 937b4bb4a78d..dd8f64d4916e 100644
--- a/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild
+++ b/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild,v 1.8 2013/03/03 09:00:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild,v 1.9 2013/11/30 13:35:59 naota Exp $
inherit eutils pam user
@@ -45,5 +45,10 @@ src_install() {
# Ideally we would create the home directory here with a dodir.
# But we cannot until bug #9849 is solved - so we kludge in pkg_postinst()
- newpamd "${FILESDIR}/ftp-pamd-include" ftp
+ cp "${FILESDIR}/ftp-pamd-include" "${T}" || die
+ if use elibc_FreeBSD; then
+ sed -i -e "/pam_listfile.so/s/^.*$/account required pam_ftpusers.so no_warn disallow/" \
+ "${T}"/ftp-pamd-include || die
+ fi
+ newpamd "${T}"/ftp-pamd-include ftp
}