summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-04-11 12:40:37 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-04-11 12:40:37 +0000
commit2705bb9db3b1b05aa3d6d2c1eeb7c907d96451c8 (patch)
tree6ab2fca77052c518e03c48a8248d1bd70bc286b2
parentBump to latest sed (diff)
downloadgentoo-2-2705bb9db3b1b05aa3d6d2c1eeb7c907d96451c8.tar.gz
gentoo-2-2705bb9db3b1b05aa3d6d2c1eeb7c907d96451c8.tar.bz2
gentoo-2-2705bb9db3b1b05aa3d6d2c1eeb7c907d96451c8.zip
Bump to latest sed
-rw-r--r--sys-apps/sed/Manifest2
-rw-r--r--sys-apps/sed/files/digest-sed-4.0.71
-rw-r--r--sys-apps/sed/sed-4.0.7.ebuild48
3 files changed, 50 insertions, 1 deletions
diff --git a/sys-apps/sed/Manifest b/sys-apps/sed/Manifest
index adf26787c0d7..715e6fe49eec 100644
--- a/sys-apps/sed/Manifest
+++ b/sys-apps/sed/Manifest
@@ -1,6 +1,6 @@
MD5 eba5e60712ff9499349f58d0f5ddf111 sed-4.0.6.ebuild 1152
MD5 6ee85d78a6a6748f35ce9b32d6b05ada sed-4.0.5.ebuild 954
-MD5 eba5e60712ff9499349f58d0f5ddf111 sed-4.0.7.ebuild 1152
+MD5 5ae20e2c1dad61597be663a8af449da9 sed-4.0.7.ebuild 1159
MD5 4f9a8ae4b665dbfeaddb72b12dc7ef46 ChangeLog 4234
MD5 2c6bc627ad547d2e936cad3935dfa5ef sed-4.0.5-r1.ebuild 1084
MD5 1f789b81b2d7992345e1490c68ad5477 files/dos2unix 59
diff --git a/sys-apps/sed/files/digest-sed-4.0.7 b/sys-apps/sed/files/digest-sed-4.0.7
new file mode 100644
index 000000000000..dc392c15c3f6
--- /dev/null
+++ b/sys-apps/sed/files/digest-sed-4.0.7
@@ -0,0 +1 @@
+MD5 005738e7f97bd77d95b6907156c8202a sed-4.0.7.tar.gz 693903
diff --git a/sys-apps/sed/sed-4.0.7.ebuild b/sys-apps/sed/sed-4.0.7.ebuild
new file mode 100644
index 000000000000..2e9172d5e8bb
--- /dev/null
+++ b/sys-apps/sed/sed-4.0.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.7.ebuild,v 1.1 2003/04/11 12:40:33 lostlogic Exp $
+
+DESCRIPTION="Super-useful stream editor"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/sed/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/sed/sed.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls static build"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die "Configure failed"
+ if [ -z `use static` ] ; then
+ emake || die "Shared build failed"
+ else
+ emake LDFLAGS=-static || die "Static build failed"
+ fi
+}
+
+src_install() {
+ into /
+ dobin sed/sed
+ if [ -z "`use build`" ]
+ then
+ einstall || die "Install failed"
+ dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE ChangeLog
+ docinto examples
+ dodoc ${FILESDIR}/dos2unix ${FILESDIR}/unix2dos
+
+ else
+ dodir /usr/bin
+ fi
+
+ rm -f ${D}/usr/bin/sed
+ dosym ../../bin/sed /usr/bin/sed
+}