summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-02-18 21:27:58 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-02-18 21:27:58 +0000
commit2a61cd940b732106b283bc0fac99bad8569e482b (patch)
tree76464815ffb7d2a08a4b3f46e30ed5bc78c22b77
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-2a61cd940b732106b283bc0fac99bad8569e482b.tar.gz
gentoo-2-2a61cd940b732106b283bc0fac99bad8569e482b.tar.bz2
gentoo-2-2a61cd940b732106b283bc0fac99bad8569e482b.zip
Version bump wrt bug 164991
(Portage version: 2.1.2-r9)
-rw-r--r--net-irc/unrealircd/ChangeLog9
-rw-r--r--net-irc/unrealircd/files/digest-unrealircd-3.2.63
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.6.ebuild136
3 files changed, 146 insertions, 2 deletions
diff --git a/net-irc/unrealircd/ChangeLog b/net-irc/unrealircd/ChangeLog
index 47753d445515..ee9696d766f6 100644
--- a/net-irc/unrealircd/ChangeLog
+++ b/net-irc/unrealircd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/unrealircd
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.49 2006/11/19 01:10:41 swegener Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.50 2007/02/18 21:27:58 armin76 Exp $
+
+*unrealircd-3.2.6 (18 Feb 2007)
+
+ 18 Feb 2007; Raúl Porcel <armin76@gentoo.org> +unrealircd-3.2.6.ebuild:
+ Version bump wrt bug 164991
19 Nov 2006; Sven Wegener <swegener@gentoo.org> unrealircd-3.2.5.ebuild:
Update SRC_URI and add mirror://gentoo/ to prevent future breakage.
diff --git a/net-irc/unrealircd/files/digest-unrealircd-3.2.6 b/net-irc/unrealircd/files/digest-unrealircd-3.2.6
new file mode 100644
index 000000000000..c20008cf013d
--- /dev/null
+++ b/net-irc/unrealircd/files/digest-unrealircd-3.2.6
@@ -0,0 +1,3 @@
+MD5 788a22bca06fc2d10494972d881b60bb Unreal3.2.6.tar.gz 2629222
+RMD160 a6b0d0f96a1668c7ea3d4c9d72f1f9aa65765f3b Unreal3.2.6.tar.gz 2629222
+SHA256 1db1295ac854e8d5424dbbbdce3f4e1443b389be0e5962870b3a8624312ee6c1 Unreal3.2.6.tar.gz 2629222
diff --git a/net-irc/unrealircd/unrealircd-3.2.6.ebuild b/net-irc/unrealircd/unrealircd-3.2.6.ebuild
new file mode 100644
index 000000000000..63a5cc77e1bf
--- /dev/null
+++ b/net-irc/unrealircd/unrealircd-3.2.6.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.6.ebuild,v 1.1 2007/02/18 21:27:58 armin76 Exp $
+
+inherit eutils ssl-cert versionator multilib
+
+MY_P=Unreal${PV}
+
+DESCRIPTION="aimed to be an advanced (not easy) IRCd"
+HOMEPAGE="http://www.unrealircd.com/"
+SRC_URI="http://unreal.brueggisite.de/${MY_P}.tar.gz
+ http://www.secureirc.org/unrealircd/${MY_P}.tar.gz
+ http://www.blurryfox.com/unreal/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="hub ipv6 ssl zlib curl"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/Unreal$(get_version_component_range 1-2)"
+
+pkg_setup() {
+ if use curl && ( ! built_with_use net-misc/curl ares || built_with_use net-misc/curl ipv6 )
+ then
+ eerror "You need net-misc/curl compiled with the ares USE flag to be able to use"
+ eerror "net-irc/unrealircd with the curl USE flag. Please note that ares support"
+ eerror "for net-misc/curl is incompatible with the ipv6 USE flag."
+ die "need net-misc/curl with ares support"
+ fi
+
+ enewuser unrealircd
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:ircd\.pid:/var/run/unrealircd/ircd.pid:" \
+ -e "s:ircd\.log:/var/log/unrealircd/ircd.log:" \
+ -e "s:debug\.log:/var/log/unrealircd/debug.log:" \
+ -e "s:ircd\.tune:/var/lib/unrealircd/ircd.tune:" \
+ include/config.h
+}
+
+src_compile() {
+ local myconf=""
+ use curl && myconf="${myconf} --enable-libcurl=/usr"
+ use ipv6 && myconf="${myconf} --enable-inet6"
+ use zlib && myconf="${myconf} --enable-ziplinks"
+ use hub && myconf="${myconf} --enable-hub"
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ econf \
+ --with-listen=5 \
+ --with-dpath=${D}/etc/unrealircd \
+ --with-spath=/usr/bin/unrealircd \
+ --with-nick-history=2000 \
+ --with-sendq=3000000 \
+ --with-bufferpool=18 \
+ --with-hostname=$(hostname -f) \
+ --with-permissions=0600 \
+ --with-fd-setsize=1024 \
+ --enable-dynamic-linking \
+ --enable-prefixaq \
+ ${myconf} \
+ || die "econf failed"
+
+ sed -i \
+ -e "s:${D}::" \
+ include/setup.h \
+ ircdcron/ircdchk
+
+ emake MAKE=make IRCDDIR=/etc/unrealircd || die "emake failed"
+}
+
+src_install() {
+ keepdir /var/{lib,log,run}/unrealircd
+
+ newbin src/ircd unrealircd
+
+ exeinto /usr/$(get_libdir)/unrealircd/modules
+ doexe src/modules/*.so
+
+ dodir /etc/unrealircd
+ dosym /var/lib/unrealircd /etc/unrealircd/tmp
+
+ insinto /etc/unrealircd
+ doins {badwords.*,help,spamfilter,dccallow}.conf
+ newins doc/example.conf unrealircd.conf
+
+ use ssl \
+ && docert server.cert \
+ && dosym server.cert.key /etc/unrealircd/server.key.pem
+
+ insinto /etc/unrealircd/aliases
+ doins aliases/*.conf
+ insinto /etc/unrealircd/networks
+ doins networks/*.network
+
+ sed -i \
+ -e s:src/modules:/usr/$(get_libdir)/unrealircd/modules: \
+ -e s:ircd\\.log:/var/log/unrealircd/ircd.log: \
+ ${D}/etc/unrealircd/unrealircd.conf
+
+ dodoc \
+ Changes Donation Unreal.nfo networks/makenet \
+ ircdcron/{ircd.cron,ircdchk} \
+ || die "dodoc failed"
+ dohtml doc/*.html
+
+ newinitd ${FILESDIR}/unrealircd.rc unrealircd
+ newconfd ${FILESDIR}/unrealircd.confd unrealircd
+
+ fperms 700 /etc/unrealircd
+ chown -R unrealircd ${D}/{etc,var/{lib,log,run}}/unrealircd
+}
+
+pkg_postinst() {
+ einfo
+ einfo "UnrealIRCd will not run until you've set up /etc/unrealircd/unrealircd.conf"
+ einfo
+ einfo "You can find example cron scripts here:"
+ einfo " /usr/share/doc/${PF}/ircd.cron.gz"
+ einfo " /usr/share/doc/${PF}/ircdchk.gz"
+ einfo
+ einfo "You can also use /etc/init.d/unrealircd to start at boot"
+ einfo
+}