summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-22 10:45:02 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-22 10:45:02 +0000
commit2dcc57737e5f0ea4202f90764d862e664a783062 (patch)
treeeee4ad2cc9f8f7e4c8152e88b193e2b63368b4cb
parentVersion bump (diff)
downloadgentoo-2-2dcc57737e5f0ea4202f90764d862e664a783062.tar.gz
gentoo-2-2dcc57737e5f0ea4202f90764d862e664a783062.tar.bz2
gentoo-2-2dcc57737e5f0ea4202f90764d862e664a783062.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
-rw-r--r--dev-tex/style-check/ChangeLog10
-rw-r--r--dev-tex/style-check/files/style-check-0.13-fix-msg.patch11
-rw-r--r--dev-tex/style-check/style-check-0.13.ebuild29
3 files changed, 48 insertions, 2 deletions
diff --git a/dev-tex/style-check/ChangeLog b/dev-tex/style-check/ChangeLog
index aea8e38203ec..86584506f350 100644
--- a/dev-tex/style-check/ChangeLog
+++ b/dev-tex/style-check/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tex/style-check
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/style-check/ChangeLog,v 1.11 2010/08/07 13:28:35 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/style-check/ChangeLog,v 1.12 2011/08/22 10:45:02 radhermit Exp $
+
+*style-check-0.13 (22 Aug 2011)
+
+ 22 Aug 2011; Tim Harder <radhermit@gentoo.org> +style-check-0.13.ebuild,
+ +files/style-check-0.13-fix-msg.patch:
+ Version bump.
07 Aug 2010; Hans de Graaff <graaff@gentoo.org> style-check-0.7.ebuild,
style-check-0.12.ebuild:
diff --git a/dev-tex/style-check/files/style-check-0.13-fix-msg.patch b/dev-tex/style-check/files/style-check-0.13-fix-msg.patch
new file mode 100644
index 000000000000..cfb09225cc07
--- /dev/null
+++ b/dev-tex/style-check/files/style-check-0.13-fix-msg.patch
@@ -0,0 +1,11 @@
+--- style-check-0.13/style-check.rb.orig
++++ style-check-0.13/style-check.rb
+@@ -124,7 +124,7 @@
+ PreCensored_phrases[
+ Regexp.new(/(table|figure|section)~\\ref/) ] = "Table, Figure, and Section refs should be capitalized"
+ PreCensored_phrases[
+- Regexp.new(/\\url\{(?!http|ftp|rtsp|mailto)/) ] = "~\url{} should start with http:// (or ftp or rtsp or maybe mailto)."
++ Regexp.new(/\\url\{(?!http|ftp|rtsp|mailto)/) ] = "~\\url{} should start with http:// (or ftp or rtsp or maybe mailto)."
+
+ PctCensored_phrases[
+ Regexp.new(/[0-9]%/) ] = "a percent following a number is rarely an intended comment."
diff --git a/dev-tex/style-check/style-check-0.13.ebuild b/dev-tex/style-check/style-check-0.13.ebuild
new file mode 100644
index 000000000000..728d9531489d
--- /dev/null
+++ b/dev-tex/style-check/style-check-0.13.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/style-check/style-check-0.13.ebuild,v 1.1 2011/08/22 10:45:02 radhermit Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Parses latex-formatted text in search of forbidden phrases"
+HOMEPAGE="http://www.cs.umd.edu/~nspring/software/style-check-readme.html"
+SRC_URI="http://www.cs.umd.edu/~nspring/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/ruby"
+DEPEND="test? ( dev-lang/ruby )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-msg.patch
+}
+
+src_install() {
+ dodir /etc/style-check.d
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${ED}" install
+ dohtml README.html
+}