summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2014-05-11 10:23:50 +0000
committerThomas Sachau <tommy@gentoo.org>2014-05-11 10:23:50 +0000
commit2de363e2759ab394fccfb4144721fca12c44d2af (patch)
tree666b069459b1632200b282521dc9632ba6fad2cd
parentRestore gtk2 useflag which was dropped for no good reason (diff)
downloadgentoo-2-2de363e2759ab394fccfb4144721fca12c44d2af.tar.gz
gentoo-2-2de363e2759ab394fccfb4144721fca12c44d2af.tar.bz2
gentoo-2-2de363e2759ab394fccfb4144721fca12c44d2af.zip
Import of e18 from the overlay, including version bump to 0.18.7
(Portage version: 2.2.6-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
-rw-r--r--x11-wm/enlightenment/ChangeLog8
-rw-r--r--x11-wm/enlightenment/enlightenment-0.18.7.ebuild92
-rw-r--r--x11-wm/enlightenment/metadata.xml9
3 files changed, 108 insertions, 1 deletions
diff --git a/x11-wm/enlightenment/ChangeLog b/x11-wm/enlightenment/ChangeLog
index 30bd4ed4c3ff..38acc32e6906 100644
--- a/x11-wm/enlightenment/ChangeLog
+++ b/x11-wm/enlightenment/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/enlightenment
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.197 2014/05/04 11:13:42 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.198 2014/05/11 10:23:50 tommy Exp $
+
+*enlightenment-0.18.7 (11 May 2014)
+
+ 11 May 2014; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +enlightenment-0.18.7.ebuild, metadata.xml:
+ Import of e18 from the overlay, including version bump to 0.18.7
04 May 2014; Mikle Kolyada <zlogene@gentoo.org> enlightenment-0.17.6.ebuild:
x86 stable wrt bug #455548
diff --git a/x11-wm/enlightenment/enlightenment-0.18.7.ebuild b/x11-wm/enlightenment/enlightenment-0.18.7.ebuild
new file mode 100644
index 000000000000..5ba308d4c98c
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.18.7.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.18.7.ebuild,v 1.1 2014/05/11 10:23:50 tommy Exp $
+
+EAPI=5
+
+MY_P=${P/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="http://download.enlightenment.org/rel/apps/${PN}/${MY_P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment DR17 window manager"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0.17/${PV%%_*}"
+
+# The @ is just an anchor to expand from
+__EVRY_MODS=""
+__CONF_MODS="
+ +@applications +@comp +@dialogs +@display
+ +@interaction +@intl +@menus
+ +@paths +@performance +@randr +@shelves +@theme +@wallpaper2
+ +@window-manipulation +@window-remembers"
+__NORM_MODS="
+ @access +@appmenu +@backlight +@bluez4 +@battery +@clock
+ +@connman +@contact +@cpufreq +@everything +@fileman
+ +@fileman-opinfo +@gadman +@ibar +@ibox +@illume2 +@mixer +@msgbus
+ +@music-control +@notification +@pager +@quickaccess +@shot
+ +@start +@syscon +@systray +@tasks +@teamwork +@temperature +@tiling
+ +@winlist +@wizard @wl-desktop-shell @wl-screenshot +@xkbswitch"
+IUSE_E_MODULES="
+ ${__CONF_MODS//@/enlightenment_modules_conf-}
+ ${__NORM_MODS//@/enlightenment_modules_}"
+
+IUSE="pam spell static-libs systemd +udev ukit wayland ${IUSE_E_MODULES}"
+
+RDEPEND="
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd )
+ wayland? ( dev-libs/efl[wayland]
+ >=dev-libs/wayland-1.2.0
+ >=x11-libs/pixman-0.31.1
+ >=x11-libs/libxkbcommon-0.3.1
+ )
+ >=dev-libs/efl-1.8.3
+ || ( >=dev-libs/efl-1.8.3[X] >=dev-libs/efl-1.8.3[xcb] )
+ >=media-libs/elementary-1.8.2
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/quickstart.diff
+ enlightenment_src_prepare
+}
+
+src_configure() {
+ E_ECONF+=(
+ --disable-install-sysactions
+ $(use_enable doc)
+ --disable-device-hal
+ $(use_enable nls)
+ $(use_enable pam)
+ $(use_enable systemd)
+ --enable-device-udev
+ $(use_enable udev mount-eeze)
+ $(use_enable ukit mount-udisks)
+ $(use_enable wayland wayland-clients)
+ )
+ local u c
+ for u in ${IUSE_E_MODULES} ; do
+ u=${u#+}
+ c=${u#enlightenment_modules_}
+ E_ECONF+=( $(use_enable ${u} ${c}) )
+ done
+ enlightenment_src_configure
+}
+
+src_install() {
+ enlightenment_src_install
+ insinto /etc/enlightenment
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
+}
diff --git a/x11-wm/enlightenment/metadata.xml b/x11-wm/enlightenment/metadata.xml
index 9072d72d5375..30ab00a13b2f 100644
--- a/x11-wm/enlightenment/metadata.xml
+++ b/x11-wm/enlightenment/metadata.xml
@@ -56,11 +56,14 @@ Enlightenment Features:
<flag name='udev'>Use sys-fs/udev to determine available devices</flag>
<flag name='ukit'>Use upower/udisks to automount devices</flag>
<flag name="enlightenment_modules_access">Accessibility module designed to improve ease of use for the vision impaired and the blind</flag>
+ <flag name="enlightenment_modules_appmenu">Gadget that hold the toolbar of the foreground application</flag>
<flag name="enlightenment_modules_backlight">Backlight control slider gadget</flag>
<flag name="enlightenment_modules_battery">A gadget to visualize your battery status</flag>
+ <flag name="enlightenment_modules_bluez4">Configure Bluetooth devices</flag>
<flag name="enlightenment_modules_clock">Nice clock gadget to show current time</flag>
<flag name="enlightenment_modules_comp">Enlightenment Composite Manager</flag>
<flag name="enlightenment_modules_connman">Control Wifi and wired networks as a user</flag>
+ <flag name="enlightenment_modules_contact">Enable the contact module</flag>
<flag name="enlightenment_modules_cpufreq">Gadget to monitor and change the CPU frequency</flag>
<flag name="enlightenment_modules_dropshadow">Module to add a dropshadow to windows</flag>
<flag name="enlightenment_modules_everything">The run command module provides an application launcher dialog</flag>
@@ -72,6 +75,7 @@ Enlightenment Features:
<flag name="enlightenment_modules_illume2">Illume2 - next generation of illume - special WM mode for embedded devices and set of plugins with same purpose</flag>
<flag name="enlightenment_modules_mixer">A module to provide a mixer for changing volume</flag>
<flag name="enlightenment_modules_msgbus">DBus Extension</flag>
+ <flag name="enlightenment_modules_music-control">Control your music in your shelf</flag>
<flag name="enlightenment_modules_notification">notification-daemon alternative. Popup if an event occur</flag>
<flag name="enlightenment_modules_pager">Gadget to allow you to visualize your virtual desktops and the windows they contain</flag>
<flag name="enlightenment_modules_quickaccess">Enlightenment Quickaccess Launcher</flag>
@@ -80,12 +84,16 @@ Enlightenment Features:
<flag name="enlightenment_modules_syscon">This module provides a unified popup dialog for all the system actions in Enlightenment</flag>
<flag name="enlightenment_modules_systray">system tray that hold applications icons like Skype, Pidgin, Kopete and others</flag>
<flag name="enlightenment_modules_tasks">Gadget to allow you to switch tasks</flag>
+ <flag name="enlightenment_modules_teamwork">Enable teamwork module</flag>
<flag name="enlightenment_modules_temperature">Temperature monitor</flag>
<flag name="enlightenment_modules_tiling">Positions/resizes your windows tilingly</flag>
<flag name="enlightenment_modules_winlist">A module to show the list of client applications presently running</flag>
<flag name="enlightenment_modules_wizard">First Run Wizard</flag>
+ <flag name="enlightenment_modules_wl-desktop-shell">Enlightenment Wayland Desktop Shell</flag>
+ <flag name="enlightenment_modules_wl-screenshot">Enlightenment Wayland Screenshot module</flag>
<flag name="enlightenment_modules_xkbswitch">Keyboard layout configuration and switcher</flag>
<flag name="enlightenment_modules_conf-applications">Allows configuration of Ibar, Restart, and Startup applications</flag>
+ <flag name="enlightenment_modules_conf-comp">Configure default dialog properties</flag>
<flag name="enlightenment_modules_conf-dialogs">Configure default dialog properties</flag>
<flag name="enlightenment_modules_conf-display">Used to configure your screen</flag>
<flag name="enlightenment_modules_conf-edgebindings">Configure your edge bindings here</flag>
@@ -98,6 +106,7 @@ Enlightenment Features:
<flag name="enlightenment_modules_conf-randr">Used to configure your screen's resolution</flag>
<flag name="enlightenment_modules_conf-shelves">Shelf configuration dialog</flag>
<flag name="enlightenment_modules_conf-theme">Used to configure your theme preferences</flag>
+ <flag name="enlightenment_modules_conf-wallpaper2">Used to configure your theme preferences</flag>
<flag name="enlightenment_modules_conf-window-manipulation">Configures window raise, resistance, and maximize policies</flag>
<flag name="enlightenment_modules_conf-window-remembers">Delete existing window remembers</flag>
</use>