summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-03 15:27:52 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-03 15:27:52 +0000
commit2f07c4b84331b09ac819fa443db13506135d7314 (patch)
tree26c6b318a619d581cb1d7801c832c3ece4853284
parentChanging download location (Manifest recommit) (diff)
downloadgentoo-2-2f07c4b84331b09ac819fa443db13506135d7314.tar.gz
gentoo-2-2f07c4b84331b09ac819fa443db13506135d7314.tar.bz2
gentoo-2-2f07c4b84331b09ac819fa443db13506135d7314.zip
moving webapp-detect inside functions
-rw-r--r--net-www/phpmp/ChangeLog5
-rw-r--r--net-www/phpmp/files/digest-phpmp-0.9.01
-rw-r--r--net-www/phpmp/phpmp-0.9.0.ebuild46
-rw-r--r--net-www/phpmp/phpmp-0.9.1.ebuild10
4 files changed, 10 insertions, 52 deletions
diff --git a/net-www/phpmp/ChangeLog b/net-www/phpmp/ChangeLog
index 895c0e429f77..fee6993fcb8a 100644
--- a/net-www/phpmp/ChangeLog
+++ b/net-www/phpmp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/phpmp
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpmp/ChangeLog,v 1.10 2004/02/23 19:27:15 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpmp/ChangeLog,v 1.11 2004/03/03 15:27:52 mholzer Exp $
+
+ 03 Mar 2004; Martin Holzer <mholzer@gentoo.org> phpmp-0.9.1.ebuild:
+ moving webapp-detect inside functions
23 Feb 2004; Stuart Herbert <stuart@gentoo.org> phpmp-0.9.1.ebuild:
Unmasked on x86; fixes bug #38891
diff --git a/net-www/phpmp/files/digest-phpmp-0.9.0 b/net-www/phpmp/files/digest-phpmp-0.9.0
deleted file mode 100644
index 0af8d8dc04a1..000000000000
--- a/net-www/phpmp/files/digest-phpmp-0.9.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d80241a84f06a855c4d987a92926fd68 phpMp-0.9.0.tar.gz 18451
diff --git a/net-www/phpmp/phpmp-0.9.0.ebuild b/net-www/phpmp/phpmp-0.9.0.ebuild
deleted file mode 100644
index de65ac3dc35d..000000000000
--- a/net-www/phpmp/phpmp-0.9.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpmp/phpmp-0.9.0.ebuild,v 1.5 2003/12/15 20:44:39 stuart Exp $
-
-MY_PN="phpMp"
-MY_P="${MY_PN}-${PV}"
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="phpMp is a client program for Music Player Daemon (mpd)"
-HOMEPAGE="http://www.musicpd.org/"
-SRC_URI="mirror://sourceforge/musicpd/${MY_P}.tar.gz"
-RESTRICT="nomirror"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc ~alpha"
-IUSE=""
-
-DEPEND=">=net-www/apache-1.3.27-r1 >=mod_php-4.2.3-r2"
-
-inherit webapp-apache
-webapp-detect || NO_WEBSERVER=1
-
-PHPMP_DIR="${HTTPD_ROOT}/${MY_PN}"
-
-pkg_setup() {
- webapp-pkg_setup "${NO_WEBSERVER}"
-}
-
-src_compile() {
- #we need to have this empty function ... default compile hangs
- echo "Nothing to compile"
-}
-
-src_install() {
- webapp-mkdirs
-
- insinto "${PHPMP_DIR}"
- doins *.php
-
- chown -R "${HTTPD_USER}:${HTTPD_GROUP}" "${D}/${PHPMP_DIR}"
-}
-
-pkg_postinst() {
- einfo "Remember to edit the config file in:"
- einfo " ${PHPMP_DIR}/"
-}
diff --git a/net-www/phpmp/phpmp-0.9.1.ebuild b/net-www/phpmp/phpmp-0.9.1.ebuild
index b5eb16b52055..3912c2322d32 100644
--- a/net-www/phpmp/phpmp-0.9.1.ebuild
+++ b/net-www/phpmp/phpmp-0.9.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpmp/phpmp-0.9.1.ebuild,v 1.4 2004/02/23 19:27:15 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpmp/phpmp-0.9.1.ebuild,v 1.5 2004/03/03 15:27:52 mholzer Exp $
+
+inherit webapp-apache
MY_PN="phpMp"
MY_P="${MY_PN}-${PV}"
@@ -17,12 +19,10 @@ IUSE=""
DEPEND=">=net-www/apache-1.3.27-r1 >=mod_php-4.2.3-r2"
-inherit webapp-apache
-webapp-detect || NO_WEBSERVER=1
-
PHPMP_DIR="${HTTPD_ROOT}/${MY_PN}"
pkg_setup() {
+ webapp-detect || NO_WEBSERVER=1
webapp-pkg_setup "${NO_WEBSERVER}"
}
@@ -32,7 +32,9 @@ src_compile() {
}
src_install() {
+ webapp-detect || NO_WEBSERVER=1
webapp-mkdirs
+
insinto "${PHPMP_DIR}"
doins *.php