summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-26 03:17:40 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-26 03:17:40 +0000
commit323f41cdf51c564261cfd7a8ca354a5a91d2adf0 (patch)
tree647f5a55428b59beeed3efd74f8d45af502a0f65
parentReally don't use gnome-online-accounts when USE=-gnome-online-accounts (bug #... (diff)
downloadgentoo-2-323f41cdf51c564261cfd7a8ca354a5a91d2adf0.tar.gz
gentoo-2-323f41cdf51c564261cfd7a8ca354a5a91d2adf0.tar.bz2
gentoo-2-323f41cdf51c564261cfd7a8ca354a5a91d2adf0.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
-rw-r--r--net-misc/youtube-dl/ChangeLog9
-rw-r--r--net-misc/youtube-dl/youtube-dl-2014.06.04.ebuild57
-rw-r--r--net-misc/youtube-dl/youtube-dl-2014.06.09.ebuild57
-rw-r--r--net-misc/youtube-dl/youtube-dl-2014.06.16.ebuild57
-rw-r--r--net-misc/youtube-dl/youtube-dl-2014.06.25.ebuild (renamed from net-misc/youtube-dl/youtube-dl-2014.06.07.ebuild)2
5 files changed, 9 insertions, 173 deletions
diff --git a/net-misc/youtube-dl/ChangeLog b/net-misc/youtube-dl/ChangeLog
index 095c501960c4..d8ac554a843d 100644
--- a/net-misc/youtube-dl/ChangeLog
+++ b/net-misc/youtube-dl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/youtube-dl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.350 2014/06/24 12:23:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.351 2014/06/26 03:17:40 jer Exp $
+
+*youtube-dl-2014.06.25 (26 Jun 2014)
+
+ 26 Jun 2014; Jeroen Roovers <jer@gentoo.org> -youtube-dl-2014.06.04.ebuild,
+ -youtube-dl-2014.06.07.ebuild, -youtube-dl-2014.06.09.ebuild,
+ -youtube-dl-2014.06.16.ebuild, +youtube-dl-2014.06.25.ebuild:
+ Version bump.
*youtube-dl-2014.06.24.1 (24 Jun 2014)
diff --git a/net-misc/youtube-dl/youtube-dl-2014.06.04.ebuild b/net-misc/youtube-dl/youtube-dl-2014.06.04.ebuild
deleted file mode 100644
index 8a69b0479db7..000000000000
--- a/net-misc/youtube-dl/youtube-dl-2014.06.04.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.06.04.ebuild,v 1.2 2014/06/06 15:55:00 jer Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=(python{2_6,2_7,3_3,3_4})
-DISTUTILS_SINGLE_IMPL=true
-inherit bash-completion-r1 distutils-r1 eutils
-
-DESCRIPTION="Download videos from YouTube.com (and mores sites...)"
-HOMEPAGE="http://rg3.github.com/youtube-dl/"
-SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="offensive test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- if ! use offensive; then
- sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
- youtube_dl/version.py || die
- local xxx=(
- extremetube fourtube hentaistigma mofosex pornhd pornhub pornotube
- redtube slutload spankwire thisav trutube tube8 xbef xhamster xnxx
- xtube xvideos youjizz youporn
- )
- sed -i -e $( printf '/%s/d;' ${xxx[@]} ) youtube_dl/extractor/__init__.py || die
- rm $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
- test/test_age_restriction.py || die
- fi
-}
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- python_domodule youtube_dl
- dobin bin/${PN}
- dodoc README.txt
- doman ${PN}.1
- newbashcomp ${PN}.bash-completion ${PN}
- python_fix_shebang "${ED}"
-}
diff --git a/net-misc/youtube-dl/youtube-dl-2014.06.09.ebuild b/net-misc/youtube-dl/youtube-dl-2014.06.09.ebuild
deleted file mode 100644
index 40fd58734450..000000000000
--- a/net-misc/youtube-dl/youtube-dl-2014.06.09.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.06.09.ebuild,v 1.1 2014/06/09 22:24:42 jer Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=(python{2_6,2_7,3_3,3_4})
-DISTUTILS_SINGLE_IMPL=true
-inherit bash-completion-r1 distutils-r1 eutils
-
-DESCRIPTION="Download videos from YouTube.com (and mores sites...)"
-HOMEPAGE="http://rg3.github.com/youtube-dl/"
-SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="offensive test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- if ! use offensive; then
- sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
- youtube_dl/version.py || die
- local xxx=(
- extremetube fourtube hentaistigma mofosex pornhd pornhub pornotube
- redtube slutload spankwire thisav trutube tube8 xbef xhamster xnxx
- xtube xvideos youjizz youporn
- )
- sed -i -e $( printf '/%s/d;' ${xxx[@]} ) youtube_dl/extractor/__init__.py || die
- rm $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
- test/test_age_restriction.py || die
- fi
-}
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- python_domodule youtube_dl
- dobin bin/${PN}
- dodoc README.txt
- doman ${PN}.1
- newbashcomp ${PN}.bash-completion ${PN}
- python_fix_shebang "${ED}"
-}
diff --git a/net-misc/youtube-dl/youtube-dl-2014.06.16.ebuild b/net-misc/youtube-dl/youtube-dl-2014.06.16.ebuild
deleted file mode 100644
index 4fafa94a1866..000000000000
--- a/net-misc/youtube-dl/youtube-dl-2014.06.16.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.06.16.ebuild,v 1.1 2014/06/16 13:17:23 jer Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=(python{2_6,2_7,3_3,3_4})
-DISTUTILS_SINGLE_IMPL=true
-inherit bash-completion-r1 distutils-r1 eutils
-
-DESCRIPTION="Download videos from YouTube.com (and mores sites...)"
-HOMEPAGE="http://rg3.github.com/youtube-dl/"
-SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="offensive test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- if ! use offensive; then
- sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
- youtube_dl/version.py || die
- local xxx=(
- extremetube fourtube hentaistigma mofosex pornhd pornhub pornotube
- redtube slutload spankwire thisav trutube tube8 xbef xhamster xnxx
- xtube xvideos youjizz youporn
- )
- sed -i -e $( printf '/%s/d;' ${xxx[@]} ) youtube_dl/extractor/__init__.py || die
- rm $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
- test/test_age_restriction.py || die
- fi
-}
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- python_domodule youtube_dl
- dobin bin/${PN}
- dodoc README.txt
- doman ${PN}.1
- newbashcomp ${PN}.bash-completion ${PN}
- python_fix_shebang "${ED}"
-}
diff --git a/net-misc/youtube-dl/youtube-dl-2014.06.07.ebuild b/net-misc/youtube-dl/youtube-dl-2014.06.25.ebuild
index 86286019b7ad..d856c58e82da 100644
--- a/net-misc/youtube-dl/youtube-dl-2014.06.07.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-2014.06.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.06.07.ebuild,v 1.1 2014/06/08 12:23:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.06.25.ebuild,v 1.1 2014/06/26 03:17:40 jer Exp $
EAPI=5