summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 15:02:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 15:02:43 +0000
commit3a92abd5dcb59d2005c5e9e52ef95aca4b906966 (patch)
tree28a1095879fb70667f5eaad31b97e088744d5390
parentVersion bump with fixed source tarball (diff)
downloadgentoo-2-3a92abd5dcb59d2005c5e9e52ef95aca4b906966.tar.gz
gentoo-2-3a92abd5dcb59d2005c5e9e52ef95aca4b906966.tar.bz2
gentoo-2-3a92abd5dcb59d2005c5e9e52ef95aca4b906966.zip
Disable tests with USE="-threads" (bug #322755).
(Portage version: HEAD/cvs/Linux x86_64)
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-3.1.2-r3.ebuild7
2 files changed, 11 insertions, 2 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 8e7afb2e8967..0fdfe141408d 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.472 2010/05/26 16:18:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.473 2010/06/04 15:02:43 arfrever Exp $
+
+ 04 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-3.1.2-r3.ebuild:
+ Disable tests with USE="-threads" (bug #322755).
26 May 2010; Markos Chandras <hwoarang@gentoo.org> python-3.1.2-r3.ebuild:
Stable on amd64 wrt bug #320043
diff --git a/dev-lang/python/python-3.1.2-r3.ebuild b/dev-lang/python/python-3.1.2-r3.ebuild
index ac9ebeffc01c..5ab9d60f1d63 100644
--- a/dev-lang/python/python-3.1.2-r3.ebuild
+++ b/dev-lang/python/python-3.1.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.10 2010/05/26 16:18:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.11 2010/06/04 15:02:43 arfrever Exp $
EAPI="3"
@@ -179,6 +179,11 @@ src_test() {
return
fi
+ if ! use threads; then
+ ewarn "Disabling tests due to USE=\"-threads\""
+ return
+ fi
+
# Byte compiling should be enabled here.
# Otherwise test_import fails.
python_enable_pyc