summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-10-16 16:50:08 +0000
committerAlex Alexander <wired@gentoo.org>2009-10-16 16:50:08 +0000
commit3ef18899de1592aecd0434ceb0629e22ae8adbf6 (patch)
tree84ef6d97c44dd7c7679f15f9ecc5615712e34119
parentadded version 4.6.0_beta1 (diff)
downloadgentoo-2-3ef18899de1592aecd0434ceb0629e22ae8adbf6.tar.gz
gentoo-2-3ef18899de1592aecd0434ceb0629e22ae8adbf6.tar.bz2
gentoo-2-3ef18899de1592aecd0434ceb0629e22ae8adbf6.zip
added version 4.6.0_beta1
(Portage version: 2.2_rc46/cvs/Linux x86_64)
-rw-r--r--x11-libs/qt-svg/ChangeLog7
-rw-r--r--x11-libs/qt-svg/qt-svg-4.6.0_beta1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index cc0f84181bdc..adeb0c934b98 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.41 2009/10/11 17:12:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.42 2009/10/16 16:50:08 wired Exp $
+
+*qt-svg-4.6.0_beta1 (16 Oct 2009)
+
+ 16 Oct 2009; Alex Alexander <wired@gentoo.org> +qt-svg-4.6.0_beta1.ebuild:
+ added version 4.6.0_beta1
11 Oct 2009; Raúl Porcel <armin76@gentoo.org> qt-svg-4.5.2.ebuild:
alpha/ia64/sparc stable wrt #286653
diff --git a/x11-libs/qt-svg/qt-svg-4.6.0_beta1.ebuild b/x11-libs/qt-svg/qt-svg-4.6.0_beta1.ebuild
new file mode 100644
index 000000000000..8ca503a4ba9d
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.6.0_beta1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.6.0_beta1.ebuild,v 1.1 2009/10/16 16:50:08 wired Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-gui-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/svg
+src/plugins/imageformats/svg
+src/plugins/iconengines/svgiconengine"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtSvg/
+include/Qt/
+include/QtGui/
+include/QtCore/
+include/QtXml/
+src/corelib/
+src/gui/
+src/plugins/
+src/xml
+src/3rdparty"
+
+QCONFIG_ADD="svg"
+QCONFIG_DEFINE="QT_SVG"
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -svg -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -v -no-fontconfig -no-glib -no-opengl -no-gtkstyle -continue"
+ qt4-build_src_configure
+}