summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-20 06:10:33 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-20 06:10:33 +0000
commit43bd4a1d03c3ec8098963d5c02347bfbd2470c6d (patch)
treef82a67475bff547f247bde42ea4046dd54b594a9
parentExplicitly disable apache-using tests to prevent access violation (bug #43810... (diff)
downloadgentoo-2-43bd4a1d03c3ec8098963d5c02347bfbd2470c6d.tar.gz
gentoo-2-43bd4a1d03c3ec8098963d5c02347bfbd2470c6d.tar.bz2
gentoo-2-43bd4a1d03c3ec8098963d5c02347bfbd2470c6d.zip
Disable apache-using tests in a cleaner way.
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
-rw-r--r--net-libs/libsoup/ChangeLog6
-rw-r--r--net-libs/libsoup/libsoup-2.36.1-r1.ebuild6
-rw-r--r--net-libs/libsoup/libsoup-2.36.1.ebuild6
-rw-r--r--net-libs/libsoup/libsoup-2.38.1.ebuild6
4 files changed, 14 insertions, 10 deletions
diff --git a/net-libs/libsoup/ChangeLog b/net-libs/libsoup/ChangeLog
index 42b9ee3b4856..e1e6e906e10a 100644
--- a/net-libs/libsoup/ChangeLog
+++ b/net-libs/libsoup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libsoup
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.292 2012/10/16 04:46:44 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.293 2012/10/20 06:10:33 tetromino Exp $
+
+ 20 Oct 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ libsoup-2.36.1.ebuild, libsoup-2.36.1-r1.ebuild, libsoup-2.38.1.ebuild:
+ Disable apache-using tests in a cleaner way.
16 Oct 2012; Anthony G. Basile <blueness@gentoo.org> libsoup-2.38.1.ebuild:
stable ppc, bug #427544
diff --git a/net-libs/libsoup/libsoup-2.36.1-r1.ebuild b/net-libs/libsoup/libsoup-2.36.1-r1.ebuild
index 0597b9019a1a..a11ccf81d510 100644
--- a/net-libs/libsoup/libsoup-2.36.1-r1.ebuild
+++ b/net-libs/libsoup/libsoup-2.36.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.36.1-r1.ebuild,v 1.11 2012/10/10 03:18:13 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.36.1-r1.ebuild,v 1.12 2012/10/20 06:10:33 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -33,13 +33,13 @@ DEPEND="${RDEPEND}
# net-libs/glib-networking[ssl])"
pkg_setup() {
- # Set invalid apache module dir until apache tests are ready, bug #326957
+ # Disable apache tests until they are usable on Gentoo, bug #326957
DOCS="AUTHORS NEWS README"
G2CONF="${G2CONF}
--disable-static
--disable-tls-check
--without-gnome
- --with-apache-module-dir="${T}"
+ --without-apache-httpd
$(use_enable introspection)
$(use_with samba ntlm-auth ${EPREFIX}/usr/bin/ntlm_auth)"
}
diff --git a/net-libs/libsoup/libsoup-2.36.1.ebuild b/net-libs/libsoup/libsoup-2.36.1.ebuild
index 087ab48d8a74..3bb7deda36d9 100644
--- a/net-libs/libsoup/libsoup-2.36.1.ebuild
+++ b/net-libs/libsoup/libsoup-2.36.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.36.1.ebuild,v 1.11 2012/10/10 03:18:13 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.36.1.ebuild,v 1.12 2012/10/20 06:10:33 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -33,13 +33,13 @@ DEPEND="${RDEPEND}
# net-libs/glib-networking[ssl])"
pkg_setup() {
- # Set invalid apache module dir until apache tests are ready, bug #326957
+ # Disable apache tests until they are usable on Gentoo, bug #326957
DOCS="AUTHORS NEWS README"
G2CONF="${G2CONF}
--disable-static
--disable-tls-check
--without-gnome
- --with-apache-module-dir="${T}"
+ --without-apache-httpd
$(use_enable introspection)
$(use_with samba ntlm-auth ${EPREFIX}/usr/bin/ntlm_auth)"
}
diff --git a/net-libs/libsoup/libsoup-2.38.1.ebuild b/net-libs/libsoup/libsoup-2.38.1.ebuild
index 05a360ade1ed..50f0bf103b91 100644
--- a/net-libs/libsoup/libsoup-2.38.1.ebuild
+++ b/net-libs/libsoup/libsoup-2.38.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.38.1.ebuild,v 1.11 2012/10/16 04:46:44 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.38.1.ebuild,v 1.12 2012/10/20 06:10:33 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -32,13 +32,13 @@ DEPEND="${RDEPEND}
# net-libs/glib-networking[ssl])"
pkg_setup() {
- # Set invalid apache module dir until apache tests are ready, bug #326957
+ # Disable apache tests until they are usable on Gentoo, bug #326957
DOCS="AUTHORS NEWS README"
G2CONF="${G2CONF}
--disable-static
--disable-tls-check
--without-gnome
- --with-apache-module-dir="${T}"
+ --without-apache-httpd
$(use_enable introspection)
$(use_with samba ntlm-auth ${EPREFIX}/usr/bin/ntlm_auth)"
}