summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-04-06 17:13:28 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-04-06 17:13:28 +0000
commit44cbd854fa08e3dd6802685da29942b7755d8ed1 (patch)
tree30615c8b764da100d3ec8fa21eb2158e573882c2
parentVersion bump. Remove intermediate version. (diff)
downloadgentoo-2-44cbd854fa08e3dd6802685da29942b7755d8ed1.tar.gz
gentoo-2-44cbd854fa08e3dd6802685da29942b7755d8ed1.tar.bz2
gentoo-2-44cbd854fa08e3dd6802685da29942b7755d8ed1.zip
use new qmail.eclass; ebuild cleanup
(Portage version: 2.1.4.4)
-rw-r--r--net-mail/checkpassword/ChangeLog10
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r3.ebuild37
-rw-r--r--net-mail/checkpassword/files/0.90-exit.patch10
3 files changed, 55 insertions, 2 deletions
diff --git a/net-mail/checkpassword/ChangeLog b/net-mail/checkpassword/ChangeLog
index 3d65d4fec6e5..a1120cd9ede8 100644
--- a/net-mail/checkpassword/ChangeLog
+++ b/net-mail/checkpassword/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/checkpassword
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/ChangeLog,v 1.21 2006/10/21 19:45:18 hansmi Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/ChangeLog,v 1.22 2008/04/06 17:13:28 hollow Exp $
+
+*checkpassword-0.90-r3 (06 Apr 2008)
+
+ 06 Apr 2008; Benedikt Böhm <hollow@gentoo.org> +files/0.90-exit.patch,
+ +checkpassword-0.90-r3.ebuild:
+ use new qmail.eclass; ebuild cleanup
21 Oct 2006; Michael Hanselmann <hansmi@gentoo.org>
checkpassword-0.90-r2.ebuild:
diff --git a/net-mail/checkpassword/checkpassword-0.90-r3.ebuild b/net-mail/checkpassword/checkpassword-0.90-r3.ebuild
new file mode 100644
index 000000000000..1ac822a60f79
--- /dev/null
+++ b/net-mail/checkpassword/checkpassword-0.90-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r3.ebuild,v 1.1 2008/04/06 17:13:28 hollow Exp $
+
+inherit eutils fixheadtails flag-o-matic qmail
+
+DESCRIPTION="A uniform password checking interface for root applications"
+HOMEPAGE="http://cr.yp.to/checkpwd.html"
+SRC_URI="http://cr.yp.to/checkpwd/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ epatch "${FILESDIR}"/${PV}-exit.patch
+
+ ht_fix_file Makefile print-cc.sh
+
+ use static && append-ldflags -static
+ qmail_set_cc
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ into /
+ dobin checkpassword || die
+ dodoc CHANGES README TODO VERSION FILES SYSDEPS TARGETS
+}
diff --git a/net-mail/checkpassword/files/0.90-exit.patch b/net-mail/checkpassword/files/0.90-exit.patch
new file mode 100644
index 000000000000..e8e4d2d1fc1e
--- /dev/null
+++ b/net-mail/checkpassword/files/0.90-exit.patch
@@ -0,0 +1,10 @@
+Index: checkpassword-0.90/checkpassword.c
+===================================================================
+--- checkpassword-0.90.orig/checkpassword.c
++++ checkpassword-0.90/checkpassword.c
+@@ -1,3 +1,5 @@
++#include <unistd.h>
++
+ #include "error.h"
+ #include "pathexec.h"
+ #include "prot.h"