summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-04-03 06:17:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-04-03 06:17:20 +0000
commit4624a2ac26fb57a72d153fb7757be2ff465996b5 (patch)
tree05beaa293d5c021f8fcf14b7d9d59e0444b571eb
parentBump (diff)
downloadgentoo-2-4624a2ac26fb57a72d153fb7757be2ff465996b5.tar.gz
gentoo-2-4624a2ac26fb57a72d153fb7757be2ff465996b5.tar.bz2
gentoo-2-4624a2ac26fb57a72d153fb7757be2ff465996b5.zip
Bump
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/webtest/ChangeLog7
-rw-r--r--dev-python/webtest/webtest-2.0.4.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index 4eb521133fbc..a211cf396a7f 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.57 2013/04/02 13:20:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.58 2013/04/03 06:17:20 patrick Exp $
+
+*webtest-2.0.4 (03 Apr 2013)
+
+ 03 Apr 2013; Patrick Lauer <patrick@gentoo.org> +webtest-2.0.4.ebuild:
+ Bump
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> webtest-1.4.3.ebuild:
Stable for s390, wrt bug #456616
diff --git a/dev-python/webtest/webtest-2.0.4.ebuild b/dev-python/webtest/webtest-2.0.4.ebuild
new file mode 100644
index 000000000000..987180aa53bc
--- /dev/null
+++ b/dev-python/webtest/webtest-2.0.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.4.ebuild,v 1.1 2013/04/03 06:17:20 patrick Exp $
+
+EAPI=5
+
+# sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_TESTS_RESTRICTED_ABIS="3.*"
+
+inherit distutils-r1
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/webob-0.9.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/waitress[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ dev-python/paste
+ dev-python/pastedeploy )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Why is it so?
+ if [[ ${EPYTHON} == python3* ]]; then
+ rm -f "${D}$(python_get_sitedir)"/webtest/lint3.py
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+}