summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-02-11 15:08:51 +0000
committerChristoph Mende <angelos@gentoo.org>2009-02-11 15:08:51 +0000
commit47b1a8acd36ecf74fc19e4a2b578c7993cc8e032 (patch)
treeb1edf9c5f7b7f3c3ce3c928e120db65ff88c7604
parentInitial import. (diff)
downloadgentoo-2-47b1a8acd36ecf74fc19e4a2b578c7993cc8e032.tar.gz
gentoo-2-47b1a8acd36ecf74fc19e4a2b578c7993cc8e032.tar.bz2
gentoo-2-47b1a8acd36ecf74fc19e4a2b578c7993cc8e032.zip
QA: Fix compilation with forced as-needed (bug 246880), respect LDFLAGS, respect CXX
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--app-editors/cssed/ChangeLog9
-rw-r--r--app-editors/cssed/cssed-0.4.0-r1.ebuild23
-rw-r--r--app-editors/cssed/files/cssed-0.4.0-asneeded.patch11
3 files changed, 35 insertions, 8 deletions
diff --git a/app-editors/cssed/ChangeLog b/app-editors/cssed/ChangeLog
index 294c2775aae1..a5b10f1483b1 100644
--- a/app-editors/cssed/ChangeLog
+++ b/app-editors/cssed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/cssed
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cssed/ChangeLog,v 1.19 2008/07/25 16:30:39 cardoe Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cssed/ChangeLog,v 1.20 2009/02/11 15:08:51 angelos Exp $
+
+ 11 Feb 2009; Christoph Mende <angelos@gentoo.org>
+ +files/cssed-0.4.0-asneeded.patch, cssed-0.4.0-r1.ebuild:
+ QA: Fix compilation with forced as-needed (bug 246880), respect LDFLAGS,
+ respect CXX
25 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-editors/cssed/cssed-0.4.0-r1.ebuild b/app-editors/cssed/cssed-0.4.0-r1.ebuild
index d4a12725bd2c..a9b2c8b36c1a 100644
--- a/app-editors/cssed/cssed-0.4.0-r1.ebuild
+++ b/app-editors/cssed/cssed-0.4.0-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cssed/cssed-0.4.0-r1.ebuild,v 1.4 2008/05/18 16:09:44 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cssed/cssed-0.4.0-r1.ebuild,v 1.5 2009/02/11 15:08:51 angelos Exp $
-DESCRIPTION="CSSED a GTK2 application to help create and maintain CSS style sheets for web developing"
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="a GTK2 application to help create and maintain CSS style sheets for web developing"
HOMEPAGE="http://cssed.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -19,11 +21,20 @@ RDEPEND=">=x11-libs/gtk+-2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ sed -i -e "/^cssed_LINK/s:g++:$(tc-getCXX) \$(LDFLAGS):" src/Makefile.am
+ eautoreconf
+}
+
src_compile() {
- econf $(use_with plugins plugin-headers) || die
- emake || die
+ econf $(use_with plugins plugin-headers)
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc AUTHORS ChangeLog NEWS README
}
diff --git a/app-editors/cssed/files/cssed-0.4.0-asneeded.patch b/app-editors/cssed/files/cssed-0.4.0-asneeded.patch
new file mode 100644
index 000000000000..cf208dc843cd
--- /dev/null
+++ b/app-editors/cssed/files/cssed-0.4.0-asneeded.patch
@@ -0,0 +1,11 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index a425281..9167c00 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -65,5 +65,5 @@ cssed_SOURCES = \
+ xpm-icons.h \
+ filetypes.h
+
+-cssed_LDADD = @PACKAGE_LIBS@ ../scintilla/gtk/libscintilla.a ../libcroco/parser/libcroco.a
++cssed_LDADD = ../scintilla/gtk/libscintilla.a ../libcroco/parser/libcroco.a @PACKAGE_LIBS@
+ cssed_LINK = g++ -DGTK -o cssed