summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-07-03 10:26:10 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-07-03 10:26:10 +0000
commit4ab640dfe53d474fc7b31b537446ab52aa6146c5 (patch)
tree303105b50f68f2dbfe09c42b167ab302563ec465
parentvanilla-3.2.60 + genpatches-3.2.16 + grsecurity-3.0-3.2.60-201407012149 (diff)
downloadgentoo-2-4ab640dfe53d474fc7b31b537446ab52aa6146c5.tar.gz
gentoo-2-4ab640dfe53d474fc7b31b537446ab52aa6146c5.tar.bz2
gentoo-2-4ab640dfe53d474fc7b31b537446ab52aa6146c5.zip
vanilla-3.14.10 + genpatches-3.14-14 + grsecurity-3.0-3.14.10-201407012152
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.14.10.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 02e5783f55df..1098aba29fdb 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1079 2014/07/03 10:24:27 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1080 2014/07/03 10:26:10 blueness Exp $
+
+*hardened-sources-3.14.10 (03 Jul 2014)
+
+ 03 Jul 2014; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.14.10.ebuild:
+ vanilla-3.14.10 + genpatches-3.14-14 + grsecurity-3.0-3.14.10-201407012152
*hardened-sources-3.2.60-r5 (03 Jul 2014)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.14.10.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.14.10.ebuild
new file mode 100644
index 000000000000..f0c49bd66ce2
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.14.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.14.10.ebuild,v 1.1 2014/07/03 10:26:10 blueness Exp $
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="14"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="
+ 1500_XATTR_USER_PREFIX.patch
+ 2900_dev-root-proc-mount-fix.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.0*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}