summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2007-02-16 03:56:51 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2007-02-16 03:56:51 +0000
commit4efe49fd2ca9f8c9a153d87c9c73453efbe824d0 (patch)
tree91de5d38648d37225ad73e812e99905598d54764
parentVersion bump. From upstream: (diff)
downloadgentoo-2-4efe49fd2ca9f8c9a153d87c9c73453efbe824d0.tar.gz
gentoo-2-4efe49fd2ca9f8c9a153d87c9c73453efbe824d0.tar.bz2
gentoo-2-4efe49fd2ca9f8c9a153d87c9c73453efbe824d0.zip
Version bump. Includes minor bugfixes.
(Portage version: 2.1.2-r9)
-rw-r--r--x11-apps/xdm/ChangeLog9
-rw-r--r--x11-apps/xdm/files/digest-xdm-1.1.43
-rw-r--r--x11-apps/xdm/xdm-1.1.4.ebuild59
3 files changed, 69 insertions, 2 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index 042b71c06029..61be656922e1 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdm
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.62 2006/12/16 17:05:38 joshuabaergen Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.63 2007/02/16 03:56:50 joshuabaergen Exp $
+
+*xdm-1.1.4 (16 Feb 2007)
+
+ 16 Feb 2007; Joshua Baergen <joshuabaergen@gentoo.org> +xdm-1.1.4.ebuild:
+ Version bump. Includes minor bugfixes.
*xdm-1.1.3 (16 Dec 2006)
diff --git a/x11-apps/xdm/files/digest-xdm-1.1.4 b/x11-apps/xdm/files/digest-xdm-1.1.4
new file mode 100644
index 000000000000..ef787e37d9f4
--- /dev/null
+++ b/x11-apps/xdm/files/digest-xdm-1.1.4
@@ -0,0 +1,3 @@
+MD5 a2b4c280f3e324d081a0d9ed76a8a123 xdm-1.1.4.tar.bz2 386272
+RMD160 40a13574822349e030310de0729eb0b37c95847a xdm-1.1.4.tar.bz2 386272
+SHA256 928238ea20e074372659b2902de0e0d754083196911319319795fdbfd1ca6073 xdm-1.1.4.tar.bz2 386272
diff --git a/x11-apps/xdm/xdm-1.1.4.ebuild b/x11-apps/xdm/xdm-1.1.4.ebuild
new file mode 100644
index 000000000000..433adf73de88
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.4.ebuild,v 1.1 2007/02/16 03:56:50 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit multilib x-modular pam
+
+DEFAULTVT="vt7"
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="xprint ipv6 pam"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ x11-libs/libXinerama
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-apps/sessreg"
+DEPEND="${RDEPEND}
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+PATCHES="${FILESDIR}/wtmp.patch
+ ${FILESDIR}/xwilling-hang.patch"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)
+ $(use_enable ipv6)
+ $(use_with pam)
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe ${FILESDIR}/Xsession
+ newpamd ${FILESDIR}/xdm.pamd xdm
+}
+
+pkg_preinst() {
+ x-modular_pkg_preinst
+
+ # Check for leftover /usr/lib/X11/xdm symlink
+ if [[ -L "/usr/lib/X11/xdm" ]]; then
+ ewarn "/usr/lib/X11/xdm is a symlink; deleting."
+ rm /usr/lib/X11/xdm
+ fi
+}