summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2004-07-04 06:09:08 +0000
committerBrad Laue <brad@gentoo.org>2004-07-04 06:09:08 +0000
commit52b63294b7a64660965e87b1cbc1f61252c8c14a (patch)
treef9a52c51706bc33c9e56fd9aa1afcbf014fb8967
parentUpdate to 0.7.1 (diff)
downloadgentoo-2-52b63294b7a64660965e87b1cbc1f61252c8c14a.tar.gz
gentoo-2-52b63294b7a64660965e87b1cbc1f61252c8c14a.tar.bz2
gentoo-2-52b63294b7a64660965e87b1cbc1f61252c8c14a.zip
Update to 0.9.1
-rw-r--r--net-www/mozilla-firefox-bin/ChangeLog7
-rw-r--r--net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-0.9.11
-rw-r--r--net-www/mozilla-firefox-bin/mozilla-firefox-bin-0.9.1.ebuild88
3 files changed, 95 insertions, 1 deletions
diff --git a/net-www/mozilla-firefox-bin/ChangeLog b/net-www/mozilla-firefox-bin/ChangeLog
index 3eb59ace850d..83952aca5482 100644
--- a/net-www/mozilla-firefox-bin/ChangeLog
+++ b/net-www/mozilla-firefox-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mozilla-firefox-bin
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox-bin/ChangeLog,v 1.16 2004/07/01 22:47:40 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox-bin/ChangeLog,v 1.17 2004/07/04 06:09:08 brad Exp $
+
+*mozilla-firefox-bin-0.9.1 (04 Jul 2004)
+
+ 04 Jul 2004; Brad Laue <brad@gentoo.org> +mozilla-firefox-bin-0.9.1.ebuild:
+ Update to 0.9.1
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
mozilla-firefox-bin-0.8-r1.ebuild, mozilla-firefox-bin-0.8.ebuild,
diff --git a/net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-0.9.1 b/net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-0.9.1
new file mode 100644
index 000000000000..dda24873e431
--- /dev/null
+++ b/net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-0.9.1
@@ -0,0 +1 @@
+MD5 b47060e273cd4d5ee521cb2d85a2ff06 firefox-0.9.1-i686-linux-gtk2+xft.tar.gz 8159403
diff --git a/net-www/mozilla-firefox-bin/mozilla-firefox-bin-0.9.1.ebuild b/net-www/mozilla-firefox-bin/mozilla-firefox-bin-0.9.1.ebuild
new file mode 100644
index 000000000000..2a0ef0ef9c93
--- /dev/null
+++ b/net-www/mozilla-firefox-bin/mozilla-firefox-bin-0.9.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox-bin/mozilla-firefox-bin-0.9.1.ebuild,v 1.1 2004/07/04 06:09:08 brad Exp $
+
+inherit nsplugins eutils mozilla-launcher
+
+IUSE="gnome"
+
+MY_PN=${PN/-bin/}
+S=${WORKDIR}/firefox
+DESCRIPTION="The Mozilla Firefox Web Browser"
+# Mirrors have it in one of the following places, depending on what
+# mirror you check and when you check it... :-(
+SRC_URI="
+ http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/firefox-${PV}-i686-linux-gtk2+xft.tar.gz
+ http://ftp.mozilla.org/pub/firefox/releases/${PV}/firefox-${PV}-i686-linux-gtk2+xft.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/firefox"
+RESTRICT="nostrip"
+
+KEYWORDS="-* ~x86 ~amd64"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/x11
+ x86? (
+ >=sys-libs/lib-compat-1.0-r2
+ >=x11-libs/gtk+-2.2
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ )
+ virtual/x11
+ >=net-www/mozilla-launcher-1.13"
+
+src_install() {
+ # Install firefox in /opt
+ dodir /opt
+ mv ${S} ${D}/opt/firefox
+
+ # Plugin path setup (rescuing the existing plugins)
+ src_mv_plugins /opt/firefox/plugins
+
+ # Fixing permissions
+ chown -R root:root ${D}/opt/firefox
+
+ # mozilla-launcher-1.8 supports -bin versions
+ dodir /usr/bin
+ dosym /usr/libexec/mozilla-launcher /usr/bin/firefox-bin
+
+ # Install icon and .desktop for menu entry
+ if use gnome; then
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/mozillafirefox-bin-icon.png
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillafirefox-bin.desktop
+ fi
+
+ # Normally firefox-bin-0.9 must be run as root once before it can
+ # be run as a normal user. Drop in some initialized files to
+ # avoid this.
+ einfo "Extracting firefox-bin-${PV} initialization files"
+ tar xjpf ${FILESDIR}/firefox-bin-0.9-init.tar.bz2 -C ${D}/opt/firefox
+}
+
+pkg_preinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/firefox
+
+ # Remove the old plugins dir
+ pkg_mv_plugins /opt/firefox/plugins
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/firefox
+
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}