summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-06-21 02:40:48 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-06-21 02:40:48 +0000
commit52e3d5bf6d3b7a56b1417b94e9d18e7ce9f5e21a (patch)
tree4843fff87978dd3f43975a83f4a2c12eb655dde4
parentNew ebuild. Original ebuild submitted in bug 11725 (diff)
downloadgentoo-2-52e3d5bf6d3b7a56b1417b94e9d18e7ce9f5e21a.tar.gz
gentoo-2-52e3d5bf6d3b7a56b1417b94e9d18e7ce9f5e21a.tar.bz2
gentoo-2-52e3d5bf6d3b7a56b1417b94e9d18e7ce9f5e21a.zip
New ebuild. Original ebuild submitted in bug 11725
-rw-r--r--dev-perl/Apache-Gallery/Apache-Gallery-0.6.ebuild60
-rw-r--r--dev-perl/Apache-Gallery/ChangeLog11
-rw-r--r--dev-perl/Apache-Gallery/Manifest3
-rw-r--r--dev-perl/Apache-Gallery/files/digest-Apache-Gallery-0.61
4 files changed, 74 insertions, 1 deletions
diff --git a/dev-perl/Apache-Gallery/Apache-Gallery-0.6.ebuild b/dev-perl/Apache-Gallery/Apache-Gallery-0.6.ebuild
new file mode 100644
index 000000000000..cdd56ed07e2a
--- /dev/null
+++ b/dev-perl/Apache-Gallery/Apache-Gallery-0.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Gallery/Apache-Gallery-0.6.ebuild,v 1.1 2003/06/21 02:40:44 mcummings Exp $
+
+inherit perl-module
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Apache gallery for mod_perl"
+SRC_URI="http://cpan.org/modules/by-module/Apache/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/author/LEGART/${P}"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+
+DEPEND="${DEPEND}
+ >=dev-perl/libapreq-1.0
+ >=media-libs/imlib2-1.0.6-r1
+ >=dev-perl/mod_perl-1.27-r1
+ >=dev-perl/ImageInfo-1.04-r2
+ >=dev-perl/ImageSize-2.99-r1
+ >=dev-perl/CGI-2.78-r3
+ >=dev-perl/CGI-FastTemplate-1.09
+ >=dev-perl/Parse-RecDescent-1.80-r3
+ >=dev-perl/Inline-0.43-r1
+ >=x11-base/xfree-4.2.1
+ "
+
+
+
+src_install() {
+ mydoc="INSTALL"
+
+ perl-module_src_install
+
+ insinto /home/httpd/icons
+ doins htdocs/*.png
+
+ insinto /etc/apache/gallery/templates
+ doins templates/*.tpl
+
+ insinto /etc/apache/conf
+ doins ${FILESDIR}/apache-gallery.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated."
+ einfo "You should then edit your /etc/apache/conf/apache-gallery.conf file to suit."
+ einfo
+}
+
+pkg_config() {
+ echo "Include conf/apache-gallery.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}
diff --git a/dev-perl/Apache-Gallery/ChangeLog b/dev-perl/Apache-Gallery/ChangeLog
new file mode 100644
index 000000000000..ff8cd523d94d
--- /dev/null
+++ b/dev-perl/Apache-Gallery/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-perl/Apache-Gallery
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Gallery/ChangeLog,v 1.1 2003/06/21 02:40:44 mcummings Exp $
+
+*Apache-Gallery-0.6 (20 Jun 2003)
+
+ 20 Jun 2003; Michael Cummings <mcummings@gentoo.org>
+ Apache-Gallery-0.6.ebuild:
+ New ebuild. Original ebuild submitted in bug 11725 by Jens Hilligsoee
+ <gentoo@hilli.dk>
+
diff --git a/dev-perl/Apache-Gallery/Manifest b/dev-perl/Apache-Gallery/Manifest
index 2c0aa38640c0..29a2ddca798c 100644
--- a/dev-perl/Apache-Gallery/Manifest
+++ b/dev-perl/Apache-Gallery/Manifest
@@ -1,2 +1,3 @@
-MD5 cdec642ab9c7c905ec7736af043ea96d Apache-Gallery-0.6.ebuild 1390
+MD5 ea38d79f92151d9b9bb22d9b14171836 Apache-Gallery-0.6.ebuild 1481
+MD5 f8e0d4d056b055ce312e978620eab042 ChangeLog 443
MD5 f372bf3342f63c4d3a680051e80b5571 files/digest-Apache-Gallery-0.6 69
diff --git a/dev-perl/Apache-Gallery/files/digest-Apache-Gallery-0.6 b/dev-perl/Apache-Gallery/files/digest-Apache-Gallery-0.6
new file mode 100644
index 000000000000..dc32649e0bd2
--- /dev/null
+++ b/dev-perl/Apache-Gallery/files/digest-Apache-Gallery-0.6
@@ -0,0 +1 @@
+MD5 78efe9884dc242ca50d4cc2e2fca9f44 Apache-Gallery-0.6.tar.gz 66429