summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-08-01 21:16:16 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-08-01 21:16:16 +0000
commit56280e3acc097397de0edc16a55e694278a10e0a (patch)
treec28b79c5bea9f97e6d610cfc49e4ebc1b5fe5417
parentVersion bump. (diff)
downloadgentoo-2-56280e3acc097397de0edc16a55e694278a10e0a.tar.gz
gentoo-2-56280e3acc097397de0edc16a55e694278a10e0a.tar.bz2
gentoo-2-56280e3acc097397de0edc16a55e694278a10e0a.zip
Version bump.
(Portage version: 2.2.0_alpha49/cvs/Linux x86_64)
-rw-r--r--x11-apps/xinit/ChangeLog8
-rw-r--r--x11-apps/xinit/xinit-1.3.1.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 4fc2b2d1dbe0..eb04fba7ba23 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.209 2011/05/04 11:18:34 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.210 2011/08/01 21:16:16 chithanh Exp $
+
+*xinit-1.3.1 (01 Aug 2011)
+
+ 01 Aug 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xinit-1.3.1.ebuild:
+ Version bump.
04 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
-files/0001-Gentoo-specific-customizations.patch, -files/xdm-setup.initd-1,
diff --git a/x11-apps/xinit/xinit-1.3.1.ebuild b/x11-apps/xinit/xinit-1.3.1.ebuild
new file mode 100644
index 000000000000..76311a9c24b8
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.3.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.3.1.ebuild,v 1.1 2011/08/01 21:16:16 chithanh Exp $
+
+EAPI=4
+
+inherit xorg-2
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+minimal"
+
+RDEPEND="
+ !<x11-base/xorg-server-1.8.0
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/0001-Gentoo-customizations.patch"
+)
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir=/etc/X11/xinit
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ doexe "${FILESDIR}"/xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/00-xhost"
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}