summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-13 14:50:49 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-13 14:50:49 +0000
commit602c238a1f71bcee33614c4b0d264ac6c6ed5445 (patch)
tree8d3bcf920f60e103d92257405271a286ec17de0a
parentupdate support libs for evolution; remove older versions (diff)
downloadgentoo-2-602c238a1f71bcee33614c4b0d264ac6c6ed5445.tar.gz
gentoo-2-602c238a1f71bcee33614c4b0d264ac6c6ed5445.tar.bz2
gentoo-2-602c238a1f71bcee33614c4b0d264ac6c6ed5445.zip
new version; removed older one
-rw-r--r--gnome-base/bonobo/bonobo-1.0.18.ebuild53
-rw-r--r--gnome-base/bonobo/files/digest-bonobo-1.0.181
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.18.ebuild b/gnome-base/bonobo/bonobo-1.0.18.ebuild
new file mode 100644
index 000000000000..67b629b6481c
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.18.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.18.ebuild,v 1.1 2002/01/13 14:50:49 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+
+RDEPEND=">=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/perl
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags print`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # make -j 4 didn't work
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
diff --git a/gnome-base/bonobo/files/digest-bonobo-1.0.18 b/gnome-base/bonobo/files/digest-bonobo-1.0.18
new file mode 100644
index 000000000000..90a955a546af
--- /dev/null
+++ b/gnome-base/bonobo/files/digest-bonobo-1.0.18
@@ -0,0 +1 @@
+MD5 40a0328bc525038129b9409861b94c8f bonobo-1.0.18.tar.gz 1286144