summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-07-15 02:20:12 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-07-15 02:20:12 +0000
commit62e45e97468d40e07e07ca2344072ba8bd36c5ab (patch)
tree594a5f043770f05a9673b981adf14083a0e53912
parentwhitespace (diff)
downloadgentoo-2-62e45e97468d40e07e07ca2344072ba8bd36c5ab.tar.gz
gentoo-2-62e45e97468d40e07e07ca2344072ba8bd36c5ab.tar.bz2
gentoo-2-62e45e97468d40e07e07ca2344072ba8bd36c5ab.zip
Bump. Enhancements to time zone map, including panning and zooming.
(Portage version: 2.1.3_rc8)
-rw-r--r--app-admin/system-config-date/ChangeLog10
-rw-r--r--app-admin/system-config-date/files/digest-system-config-date-1.9.13
-rw-r--r--app-admin/system-config-date/system-config-date-1.9.1.ebuild50
3 files changed, 61 insertions, 2 deletions
diff --git a/app-admin/system-config-date/ChangeLog b/app-admin/system-config-date/ChangeLog
index 08540a99a731..f45c6bff63fb 100644
--- a/app-admin/system-config-date/ChangeLog
+++ b/app-admin/system-config-date/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/system-config-date
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-date/ChangeLog,v 1.3 2006/12/20 06:21:40 dberkholz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-date/ChangeLog,v 1.4 2007/07/15 02:20:12 dberkholz Exp $
+
+*system-config-date-1.9.1 (15 Jul 2007)
+
+ 15 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +system-config-date-1.9.1.ebuild:
+ Bump. Enhancements to time zone map, including panning and zooming.
*system-config-date-1.8.11 (20 Dec 2006)
diff --git a/app-admin/system-config-date/files/digest-system-config-date-1.9.1 b/app-admin/system-config-date/files/digest-system-config-date-1.9.1
new file mode 100644
index 000000000000..9a90d5ae85a4
--- /dev/null
+++ b/app-admin/system-config-date/files/digest-system-config-date-1.9.1
@@ -0,0 +1,3 @@
+MD5 5714050215b360d76b8964656d27d3b7 system-config-date-1.9.1-1.fc8.src.rpm 668481
+RMD160 559b6a4ad257febf171cfc7707f46a67358a61d3 system-config-date-1.9.1-1.fc8.src.rpm 668481
+SHA256 61abdb8bbab22de5dce4820ec486eb35b2ffd2d68f6216339f8891278713efed system-config-date-1.9.1-1.fc8.src.rpm 668481
diff --git a/app-admin/system-config-date/system-config-date-1.9.1.ebuild b/app-admin/system-config-date/system-config-date-1.9.1.ebuild
new file mode 100644
index 000000000000..372b22653d7e
--- /dev/null
+++ b/app-admin/system-config-date/system-config-date-1.9.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-date/system-config-date-1.9.1.ebuild,v 1.1 2007/07/15 02:20:12 dberkholz Exp $
+
+inherit python eutils rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="8"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="A graphical interface for modifying system date and time"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="dev-lang/python
+ net-misc/ntp
+ =dev-python/pygtk-2*
+ =dev-python/gnome-python-2*
+ sys-apps/usermode
+ dev-python/rhpl
+ dev-libs/newt
+ www-client/htmlview
+ x11-themes/hicolor-icon-theme"
+# app-admin/anaconda
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool"
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/1.8.5-gentooify.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/{system-config-date,system-config-time,dateconfig}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}