summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2003-07-06 22:53:16 +0000
committerMasatomo Nakano <nakano@gentoo.org>2003-07-06 22:53:16 +0000
commit68fe2429dab103a2d448f26cbfb58e389a2a89cc (patch)
treed19ec6e34eda84942add7e4e1a38e63b9154aa2b
parentVersion bumped. (diff)
downloadgentoo-2-68fe2429dab103a2d448f26cbfb58e389a2a89cc.tar.gz
gentoo-2-68fe2429dab103a2d448f26cbfb58e389a2a89cc.tar.bz2
gentoo-2-68fe2429dab103a2d448f26cbfb58e389a2a89cc.zip
Version bumped.
-rw-r--r--app-emacs/wl/ChangeLog7
-rw-r--r--app-emacs/wl/Manifest4
-rw-r--r--app-emacs/wl/files/digest-wl-2.10.11
-rw-r--r--app-emacs/wl/wl-2.10.1.ebuild54
4 files changed, 63 insertions, 3 deletions
diff --git a/app-emacs/wl/ChangeLog b/app-emacs/wl/ChangeLog
index dcbade30d66a..d5b71678d754 100644
--- a/app-emacs/wl/ChangeLog
+++ b/app-emacs/wl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/wl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/wl/ChangeLog,v 1.7 2003/07/03 17:58:20 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/wl/ChangeLog,v 1.8 2003/07/06 22:53:05 nakano Exp $
+
+*wl-2.10.1 (06 Jul 2003)
+
+ 06 Jul 2003; Masatomo Nakano <nakano@gentoo.org> wl-2.10.1.ebuild:
+ Version bumped as unstable.
*wl-2.10.0-r1 (18 Jun 2003)
diff --git a/app-emacs/wl/Manifest b/app-emacs/wl/Manifest
index 5395cbbf0c86..36a0ac836404 100644
--- a/app-emacs/wl/Manifest
+++ b/app-emacs/wl/Manifest
@@ -1,8 +1,8 @@
MD5 a74545efb23ae006d89a69ead03f8313 wl-2.8.1.ebuild 1262
-MD5 4cc84521545c611ca411ab10625aa7e1 wl-2.10.1.ebuild 1260
+MD5 08de4690b21c5fe2ad9121478fc7fbeb wl-2.10.1.ebuild 1257
MD5 4694a65c4ac9fdb68c775efd35cc5c57 wl-2.10.0-r1.ebuild 1321
MD5 eca35eca5e14fd8d79c3e9662eb858c5 wl-2.10.0.ebuild 1255
-MD5 c948644679e24fff3eaf791df9e8abd9 ChangeLog 966
+MD5 848d4f416329d6b585f94f4c253c8313 ChangeLog 1092
MD5 c633c96cff2fe04a6aec8ba3a96440d7 files/70wl-gentoo.el 298
MD5 3ad7747decc89ea13c0b23de355b79bb files/digest-wl-2.10.0 61
MD5 2cc71c29a99b30471c7dbecae5f49382 files/digest-wl-2.10.1 61
diff --git a/app-emacs/wl/files/digest-wl-2.10.1 b/app-emacs/wl/files/digest-wl-2.10.1
new file mode 100644
index 000000000000..7cee3c3b53c6
--- /dev/null
+++ b/app-emacs/wl/files/digest-wl-2.10.1
@@ -0,0 +1 @@
+MD5 80cb1a4e3c76025284bf7eaa23faf1d6 wl-2.10.1.tar.gz 967205
diff --git a/app-emacs/wl/wl-2.10.1.ebuild b/app-emacs/wl/wl-2.10.1.ebuild
new file mode 100644
index 000000000000..03587deffde0
--- /dev/null
+++ b/app-emacs/wl/wl-2.10.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/wl/wl-2.10.1.ebuild,v 1.1 2003/07/06 22:53:05 nakano Exp $
+
+inherit elisp
+
+DESCRIPTION="wanderlust is a mail/news reader supporting IMAP4rev1 for emacsen"
+HOMEPAGE="http://www.gohome.org/wl/index.html"
+SRC_URI="ftp://ftp.gohome.org/wl/stable/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs
+ >=app-emacs/apel-10.3
+ >=app-emacs/flim-1.14.3
+ >=app-emacs/semi-1.14.3"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ make || die
+ make info || die
+}
+
+src_install() {
+ make \
+ LISPDIR=${D}/usr/share/emacs/site-lisp \
+ PIXMAPDIR=${D}/usr/share/${PN}/icons \
+ install || die
+
+ elisp-site-file-install ${FILESDIR}/70wl-gentoo.el
+
+ dodir /usr/share/${PN}/samples
+
+ insinto /usr/share/${PN}/samples/ja
+ doins samples/ja/*
+ insinto /usr/share/${PN}/samples/en
+ doins samples/en/*
+
+ doinfo doc/wl-ja.info doc/wl.info
+ dodoc BUGS* ChangeLog INSTALL* README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see /usr/share/doc/${P}/INSTALL.gz."
+ einfo "And Sample configuration files exist on /usr/share/${PN}/samples."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}