summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-10 19:11:41 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-10 19:11:41 +0000
commit6b2d5a46980ecfe5a1fcbf5ee0b8d03c671df61e (patch)
treea9ae1ad2bafb89cee5c96d3212f088bc911d363d
parentstable ppc, bug 342831 (diff)
downloadgentoo-2-6b2d5a46980ecfe5a1fcbf5ee0b8d03c671df61e.tar.gz
gentoo-2-6b2d5a46980ecfe5a1fcbf5ee0b8d03c671df61e.tar.bz2
gentoo-2-6b2d5a46980ecfe5a1fcbf5ee0b8d03c671df61e.zip
This requires a bump since we modify the gemspec file.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
-rw-r--r--dev-ruby/actionpack/ChangeLog8
-rw-r--r--dev-ruby/actionpack/actionpack-3.0.3-r1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 24822eef1244..b36524634f58 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.165 2011/01/10 19:10:38 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.166 2011/01/10 19:11:41 graaff Exp $
+
+*actionpack-3.0.3-r1 (10 Jan 2011)
+
+ 10 Jan 2011; Hans de Graaff <graaff@gentoo.org>
+ +actionpack-3.0.3-r1.ebuild:
+ This requires a bump since we modify the gemspec file.
10 Jan 2011; Hans de Graaff <graaff@gentoo.org> actionpack-3.0.3.ebuild:
Relax builder requirements for bug 351189.
diff --git a/dev-ruby/actionpack/actionpack-3.0.3-r1.ebuild b/dev-ruby/actionpack/actionpack-3.0.3-r1.ebuild
new file mode 100644
index 000000000000..bd28e209f34f
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.0.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.0.3-r1.ebuild,v 1.1 2011/01/10 19:11:41 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+#RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/erubis-2.6.6
+ >=dev-ruby/i18n-0.4.1:0.4
+ >=dev-ruby/rack-1.2.1
+ >=dev-ruby/rack-mount-0.6.12
+ >=dev-ruby/rack-test-0.5.4
+ >=dev-ruby/tzinfo-0.3.23"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/activerecord:${SLOT}
+ dev-ruby/actionmailer:${SLOT}
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Relax builder requirement to also support 3.0.0
+ sed -i -e 's/~> 2.1.2/>= 2.1.2/' actionpack.gemspec || die
+}