summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-08-31 05:54:47 +0000
committerTim Harder <radhermit@gentoo.org>2014-08-31 05:54:47 +0000
commit6bde612e1d9772785fecdff163aa34ac6f0327d8 (patch)
tree73d35410a123782f74bdffa3d7bcfb747d3a5339
parentVersion bump. (diff)
downloadgentoo-2-6bde612e1d9772785fecdff163aa34ac6f0327d8.tar.gz
gentoo-2-6bde612e1d9772785fecdff163aa34ac6f0327d8.tar.bz2
gentoo-2-6bde612e1d9772785fecdff163aa34ac6f0327d8.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
-rw-r--r--dev-vcs/tig/ChangeLog7
-rw-r--r--dev-vcs/tig/tig-2.0.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index 683fb3ceccce..06db3570d307 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tig
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.32 2014/08/04 17:01:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.33 2014/08/31 05:54:47 radhermit Exp $
+
+*tig-2.0.3 (31 Aug 2014)
+
+ 31 Aug 2014; Tim Harder <radhermit@gentoo.org> +tig-2.0.3.ebuild:
+ Version bump.
04 Aug 2014; Tim Harder <radhermit@gentoo.org> -tig-2.0.1-r1.ebuild:
Remove old.
diff --git a/dev-vcs/tig/tig-2.0.3.ebuild b/dev-vcs/tig/tig-2.0.3.ebuild
new file mode 100644
index 000000000000..30d37eac6be4
--- /dev/null
+++ b/dev-vcs/tig/tig-2.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-2.0.3.ebuild,v 1.1 2014/08/31 05:54:47 radhermit Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="unicode"
+
+DEPEND="sys-libs/ncurses[unicode?]
+ sys-libs/readline:0"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_prepare() {
+ # pre-generated manpages are in the root directory
+ sed -i '/^MANDOC/s#doc/##g' Makefile || die
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dohtml manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+}