summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-08-11 13:37:36 +0000
committerJim Ramsay <lack@gentoo.org>2010-08-11 13:37:36 +0000
commit6da8a5ad1d15d383f9c4970c7ceacd25f685a006 (patch)
treebcf0f0e5d07f40f69f6fafd1160479f55e2f1791
parentAdd patch to respect LDFLAGS (Bug #331831) (diff)
downloadgentoo-2-6da8a5ad1d15d383f9c4970c7ceacd25f685a006.tar.gz
gentoo-2-6da8a5ad1d15d383f9c4970c7ceacd25f685a006.tar.bz2
gentoo-2-6da8a5ad1d15d383f9c4970c7ceacd25f685a006.zip
Respect LDFLAGS (Bug #331873)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--x11-plugins/i8krellm/ChangeLog10
-rw-r--r--x11-plugins/i8krellm/files/i8krellm-2.5-Respect-LDFLAGS.patch12
-rw-r--r--x11-plugins/i8krellm/i8krellm-2.5-r1.ebuild22
3 files changed, 42 insertions, 2 deletions
diff --git a/x11-plugins/i8krellm/ChangeLog b/x11-plugins/i8krellm/ChangeLog
index 64bb53a6258e..cd071cac9700 100644
--- a/x11-plugins/i8krellm/ChangeLog
+++ b/x11-plugins/i8krellm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/i8krellm
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/i8krellm/ChangeLog,v 1.11 2007/03/12 21:13:44 lack Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/i8krellm/ChangeLog,v 1.12 2010/08/11 13:37:36 lack Exp $
+
+*i8krellm-2.5-r1 (11 Aug 2010)
+
+ 11 Aug 2010; Jim Ramsay <lack@gentoo.org> +i8krellm-2.5-r1.ebuild,
+ +files/i8krellm-2.5-Respect-LDFLAGS.patch:
+ Respect LDFLAGS (Bug #331873)
12 Mar 2007; Jim Ramsay <lack@gentoo.org> i8krellm-2.5.ebuild:
Updated to use new gkrellm-plugin eclass
diff --git a/x11-plugins/i8krellm/files/i8krellm-2.5-Respect-LDFLAGS.patch b/x11-plugins/i8krellm/files/i8krellm-2.5-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..bc740a415e35
--- /dev/null
+++ b/x11-plugins/i8krellm/files/i8krellm-2.5-Respect-LDFLAGS.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile b/Makefile
+index 443a911..ba83210 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,6 +3,7 @@
+ #
+
+ LFLAGS = -shared
++LFLAGS += $(LDFLAGS)
+
+
+ ## Support for GKrellM 2.0
diff --git a/x11-plugins/i8krellm/i8krellm-2.5-r1.ebuild b/x11-plugins/i8krellm/i8krellm-2.5-r1.ebuild
new file mode 100644
index 000000000000..837eccfd3e5d
--- /dev/null
+++ b/x11-plugins/i8krellm/i8krellm-2.5-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/i8krellm/i8krellm-2.5-r1.ebuild,v 1.1 2010/08/11 13:37:36 lack Exp $
+
+EAPI=3
+inherit gkrellm-plugin
+
+DESCRIPTION="GKrellM2 Plugin for the Dell Inspiron and Latitude notebooks"
+SRC_URI="http://www.coding-zone.com/${P}.tar.gz"
+HOMEPAGE="http://www.coding-zone.com/?page=i8krellm"
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~x86"
+
+RDEPEND=">=app-laptop/i8kutils-1.5"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+}