summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-05-09 20:12:09 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-05-09 20:12:09 +0000
commit6f4a87518f64f549e9a7aafd69b330c6acfd3c33 (patch)
treea29297cb6dbe063867f398afadebf4909d5bd370
parentReposition DOCS in the ebuild. (diff)
downloadgentoo-2-6f4a87518f64f549e9a7aafd69b330c6acfd3c33.tar.gz
gentoo-2-6f4a87518f64f549e9a7aafd69b330c6acfd3c33.tar.bz2
gentoo-2-6f4a87518f64f549e9a7aafd69b330c6acfd3c33.zip
fix build with >=freetype-2.5.1 wrt #509180
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
-rw-r--r--dev-games/cegui/ChangeLog8
-rw-r--r--dev-games/cegui/cegui-0.8.3.ebuild6
-rw-r--r--dev-games/cegui/files/cegui-0.8.3-freetype.patch20
3 files changed, 30 insertions, 4 deletions
diff --git a/dev-games/cegui/ChangeLog b/dev-games/cegui/ChangeLog
index 9c3288805194..6cbd517b9ac4 100644
--- a/dev-games/cegui/ChangeLog
+++ b/dev-games/cegui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/cegui
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cegui/ChangeLog,v 1.63 2013/12/30 22:19:19 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cegui/ChangeLog,v 1.64 2014/05/09 20:12:09 hasufell Exp $
+
+ 09 May 2014; Julian Ospald <hasufell@gentoo.org> cegui-0.8.3.ebuild,
+ +files/cegui-0.8.3-freetype.patch:
+ fix build with >=freetype-2.5.1 wrt #509180
*cegui-0.8.3 (30 Dec 2013)
diff --git a/dev-games/cegui/cegui-0.8.3.ebuild b/dev-games/cegui/cegui-0.8.3.ebuild
index 9137553c74e1..8ce374a0dd21 100644
--- a/dev-games/cegui/cegui-0.8.3.ebuild
+++ b/dev-games/cegui/cegui-0.8.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cegui/cegui-0.8.3.ebuild,v 1.1 2013/12/30 22:19:19 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cegui/cegui-0.8.3.ebuild,v 1.2 2014/05/09 20:12:09 hasufell Exp $
EAPI=5
@@ -56,6 +56,8 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
opengl? ( media-libs/glm )"
+PATCHES=( "${FILESDIR}"/${P}-freetype.patch )
+
src_configure() {
# http://www.cegui.org.uk/mantis/view.php?id=991
append-ldflags $(no-as-needed)
diff --git a/dev-games/cegui/files/cegui-0.8.3-freetype.patch b/dev-games/cegui/files/cegui-0.8.3-freetype.patch
new file mode 100644
index 000000000000..4c7cf5f627f5
--- /dev/null
+++ b/dev-games/cegui/files/cegui-0.8.3-freetype.patch
@@ -0,0 +1,20 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri May 9 19:56:34 UTC 2014
+Subject: fix build with >=freetype-2.5.1
+
+--- cegui/cmake/FindFreetype.cmake
++++ cegui/cmake/FindFreetype.cmake
+@@ -3,8 +3,12 @@
+ ################################################################################
+ include(FindPackageHandleStandardArgs)
+
+-find_path(FREETYPE_H_PATH_ft2build NAMES ft2build.h)
++find_path(FREETYPE_H_PATH_ft2build NAMES ft2build.h PATH_SUFFIXES include/freetype2 include)
+ find_path(FREETYPE_H_PATH_ftconfig NAMES freetype/config/ftconfig.h PATH_SUFFIXES freetype2)
++if(NOT FREETYPE_H_PATH_ftconfig)
++ find_path(FREETYPE_H_PATH_ftconfig NAMES config/ftconfig.h PATH_SUFFIXES include/freetype2 include)
++endif()
++
+ find_library(FREETYPE_LIB NAMES freetype2 freetype libfreetype PATH_SUFFIXES dynamic)
+ find_library(FREETYPE_LIB_DBG NAMES freetype_d libfreetype_d PATH_SUFFIXES dynamic)
+ mark_as_advanced(FREETYPE_H_PATH_ft2build FREETYPE_H_PATH_ftconfig FREETYPE_LIB FREETYPE_LIB_DBG)