summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-09 05:10:51 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-09 05:10:51 +0000
commit7119c714fb8c52b44a89cea1375aa8caaed89f68 (patch)
tree115c506a8e9c4e41213f21a0d5b9dc7c2c5c689b
parentAdd missing vital detail to ChangeLog (stable -r14 on x86). (diff)
downloadgentoo-2-7119c714fb8c52b44a89cea1375aa8caaed89f68.tar.gz
gentoo-2-7119c714fb8c52b44a89cea1375aa8caaed89f68.tar.bz2
gentoo-2-7119c714fb8c52b44a89cea1375aa8caaed89f68.zip
Add patch by the PaX Team to fix PIC/PIE issues in the netboot code and remove the chpax/paxctl stuff since the nxstack patch fixes hardened issues.
(Portage version: 2.0.51.21-r1)
-rw-r--r--sys-boot/grub/ChangeLog9
-rw-r--r--sys-boot/grub/files/grub-0.96-netboot-pic.patch15
-rw-r--r--sys-boot/grub/grub-0.96-r2.ebuild11
3 files changed, 27 insertions, 8 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 0386e9adf1b8..86289c92c2bf 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.39 2005/05/08 02:55:53 swegener Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.40 2005/05/09 05:10:51 vapier Exp $
+
+ 09 May 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/grub-0.96-netboot-pic.patch, grub-0.96-r2.ebuild:
+ Add patch by the PaX Team to fix PIC/PIE issues in the netboot code and
+ remove the chpax/paxctl stuff since the nxstack patch fixes hardened issues.
*grub-0.96-r2 (08 May 2005)
diff --git a/sys-boot/grub/files/grub-0.96-netboot-pic.patch b/sys-boot/grub/files/grub-0.96-netboot-pic.patch
new file mode 100644
index 000000000000..5cac692bb201
--- /dev/null
+++ b/sys-boot/grub/files/grub-0.96-netboot-pic.patch
@@ -0,0 +1,15 @@
+Patch by the PaX Team to fix PIC/PIE problems.
+
+http://bugs.gentoo.org/show_bug.cgi?id=85566
+
+--- netboot/main.c
++++ netboot/main.c
+@@ -701,7 +701,7 @@
+ "adcw %%ax,%0\n\t" /* add carry of previous iteration */
+ "loop 1b\n\t"
+ "adcw $0,%0" /* add carry of last iteration */
+- : "=b" (*sum), "=S"(start), "=c"(len)
++ : "=r" (*sum), "=S"(start), "=c"(len)
+ : "0"(*sum), "1"(start), "2"(len)
+ : "ax", "cc"
+ );
diff --git a/sys-boot/grub/grub-0.96-r2.ebuild b/sys-boot/grub/grub-0.96-r2.ebuild
index 1c734fc2ce83..8e77c2d43252 100644
--- a/sys-boot/grub/grub-0.96-r2.ebuild
+++ b/sys-boot/grub/grub-0.96-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.1 2005/05/08 02:55:53 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.2 2005/05/09 05:10:51 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -62,7 +62,10 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-xfs-writable-string.patch
# gcc4 patches; bug #85016
- epatch ${FILESDIR}/${P}-r1-gcc4.patch
+ epatch "${FILESDIR}"/${P}-r1-gcc4.patch
+
+ # fix PIC issues in netboot code #85566
+ epatch "${FILESDIR}"/${P}-netboot-pic.patch
# a bunch of patches apply to raw autotool files
autoconf || die "autoconf failed"
@@ -160,10 +163,6 @@ pkg_postinst() {
[[ -f ${x} ]] && cp -p ${x} /boot/grub
done
- # hardened voodoo
- [[ -x /sbin/chpax ]] && /sbin/chpax -spme /sbin/grub
- [[ -x /sbin/paxctl ]] && /sbin/paxctl -spme /sbin/grub
-
[[ -e /boot/grub/grub.conf ]] \
&& /sbin/grub \
--batch \