summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-02-02 08:07:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-02-02 08:07:12 +0000
commit721987217f05cad6964fed4641392df3780a9d5f (patch)
treefb83ce43c0b0316bfe2e94b570d685c9282f76cd
parentDepend on virtual/krb5 for USE=kerberos rather than gssglue #493912 by Torste... (diff)
downloadgentoo-2-721987217f05cad6964fed4641392df3780a9d5f.tar.gz
gentoo-2-721987217f05cad6964fed4641392df3780a9d5f.tar.bz2
gentoo-2-721987217f05cad6964fed4641392df3780a9d5f.zip
old
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--games-sports/trophy/ChangeLog9
-rw-r--r--games-sports/trophy/files/trophy-1.1.5-asneeded.patch25
-rw-r--r--games-sports/trophy/files/trophy-1.1.5-display-segv.patch11
-rw-r--r--games-sports/trophy/trophy-1.1.5.ebuild32
4 files changed, 7 insertions, 70 deletions
diff --git a/games-sports/trophy/ChangeLog b/games-sports/trophy/ChangeLog
index 9c1b2987a451..dd3d14bc9ccc 100644
--- a/games-sports/trophy/ChangeLog
+++ b/games-sports/trophy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/trophy
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/ChangeLog,v 1.13 2013/12/24 12:58:00 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/ChangeLog,v 1.14 2014/02/02 08:07:11 mr_bones_ Exp $
+
+ 02 Feb 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/trophy-1.1.5-asneeded.patch, -files/trophy-1.1.5-display-segv.patch,
+ -trophy-1.1.5.ebuild:
+ old
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> trophy-2.0.3.ebuild:
Stable for x86, wrt bug #491380
diff --git a/games-sports/trophy/files/trophy-1.1.5-asneeded.patch b/games-sports/trophy/files/trophy-1.1.5-asneeded.patch
deleted file mode 100644
index 2bd7e5f669f6..000000000000
--- a/games-sports/trophy/files/trophy-1.1.5-asneeded.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Fixing as-needed issues
-
-http://bugs.gentoo.org/show_bug.cgi?id=318139
-
---- configure.ac
-+++ configure.ac
-@@ -15,5 +15,6 @@
- # We try to link to clanSignals because this is the only library file that
- # doesn't need another one to be linked with.
- AC_CHECK_LIB(clanSignals, main, , echo "Trophy requires ClanLib to run."; exit 1)
-+PKG_CHECK_MODULES([CLAN], [clanSignals-0.8 clanGL-0.8 clanCore-0.8 clanSound-0.8 clanDisplay-0.8 clanApp-0.8])
-
- AC_OUTPUT(Makefile src/Makefile resources/Makefile)
---- src/Makefile.am
-+++ src/Makefile.am
-@@ -12,7 +12,6 @@
- caslotselectiondialog.cpp cafogbomb.h caimageview.h camenu.cpp canetclient.h capositiontable.cpp \
- caslotselectiondialog.h
-
--CLANLIB_MODULES = clanSignals-0.8 clanGL-0.8 clanCore-0.8 clanSound-0.8 clanDisplay-0.8 clanApp-0.8
--AM_LDFLAGS = `pkg-config --libs $(CLANLIB_MODULES)`
--INCLUDES = `pkg-config --cflags $(CLANLIB_MODULES)`
- AM_CPPFLAGS = -DPKGDATADIR=\"$(pkgdatadir)\"
-+trophy_CXXFLAGS = @CLAN_CFLAGS@
-+trophy_LDADD = @CLAN_LIBS@
diff --git a/games-sports/trophy/files/trophy-1.1.5-display-segv.patch b/games-sports/trophy/files/trophy-1.1.5-display-segv.patch
deleted file mode 100644
index 83860d229ec3..000000000000
--- a/games-sports/trophy/files/trophy-1.1.5-display-segv.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/caplayer.cpp.old 2007-08-30 02:52:11.000000000 +0200
-+++ src/caplayer.cpp 2007-08-30 02:52:58.000000000 +0200
-@@ -914,6 +914,8 @@
- void
- CAPlayer::display( int offsetX, int offsetY )
- {
-+ if (frame >= CA_FPR)
-+ frame = CA_FPR - 1;
- sprite[frame]->draw ( (int)(x+offsetX - sprite[ frame ]->get_width()/2),
- (int)(y+offsetY - sprite[ frame ]->get_height()/2) );
-
diff --git a/games-sports/trophy/trophy-1.1.5.ebuild b/games-sports/trophy/trophy-1.1.5.ebuild
deleted file mode 100644
index 83b307383131..000000000000
--- a/games-sports/trophy/trophy-1.1.5.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/trophy-1.1.5.ebuild,v 1.6 2012/05/03 03:35:39 jdhore Exp $
-
-EAPI=2
-inherit autotools eutils games
-
-DESCRIPTION="2D Racing Game"
-HOMEPAGE="http://trophy.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE=""
-
-RDEPEND="dev-games/clanlib:0.8[opengl]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-display-segv.patch \
- "${FILESDIR}"/${P}-asneeded.patch
- eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README TODO
- prepgamesdirs
-}