summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-18 11:56:18 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-18 11:56:18 +0000
commit74f5043e286eb2d76d5ac7d7639d5bc39bdb7b9d (patch)
treeaee3649c7ed50d65323d1e0853a8db63759703bb
parentUpdate lualatex-math to latest version as current one was broken, bug #446528... (diff)
downloadgentoo-2-74f5043e286eb2d76d5ac7d7639d5bc39bdb7b9d.tar.gz
gentoo-2-74f5043e286eb2d76d5ac7d7639d5bc39bdb7b9d.tar.bz2
gentoo-2-74f5043e286eb2d76d5ac7d7639d5bc39bdb7b9d.zip
Add patch for proper compilation with binutils 2.23, wrt bug #457980. Thanks to Andrew Savchenko for the patch
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
-rw-r--r--dev-util/dropwatch/ChangeLog9
-rw-r--r--dev-util/dropwatch/dropwatch-1.4.ebuild7
-rw-r--r--dev-util/dropwatch/files/dropwatch-1.4-binutils-2.23.patch68
3 files changed, 79 insertions, 5 deletions
diff --git a/dev-util/dropwatch/ChangeLog b/dev-util/dropwatch/ChangeLog
index 287bcf974190..de2a7bbdda58 100644
--- a/dev-util/dropwatch/ChangeLog
+++ b/dev-util/dropwatch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/dropwatch
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dropwatch/ChangeLog,v 1.1 2012/10/24 09:46:02 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dropwatch/ChangeLog,v 1.2 2013/02/18 11:56:18 pinkbyte Exp $
+
+ 18 Feb 2013; Sergey Popov <pinkbyte@gentoo.org> dropwatch-1.4.ebuild,
+ +files/dropwatch-1.4-binutils-2.23.patch:
+ Add patch for proper compilation with binutils 2.23, wrt bug #457980. Thanks
+ to Andrew Savchenko for the patch
*dropwatch-1.4 (24 Oct 2012)
diff --git a/dev-util/dropwatch/dropwatch-1.4.ebuild b/dev-util/dropwatch/dropwatch-1.4.ebuild
index 9fe1bd165c60..995ea397f5ed 100644
--- a/dev-util/dropwatch/dropwatch-1.4.ebuild
+++ b/dev-util/dropwatch/dropwatch-1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dropwatch/dropwatch-1.4.ebuild,v 1.1 2012/10/24 09:46:02 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dropwatch/dropwatch-1.4.ebuild,v 1.2 2013/02/18 11:56:18 pinkbyte Exp $
EAPI=4
@@ -22,7 +22,8 @@ DEPEND="${RDEPEND}
CONFIG_CHECK="~NET_DROP_MONITOR"
-PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+PATCHES=( "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-binutils-2.23.patch" )
src_compile() {
emake CC="$(tc-getCC)" -C src
diff --git a/dev-util/dropwatch/files/dropwatch-1.4-binutils-2.23.patch b/dev-util/dropwatch/files/dropwatch-1.4-binutils-2.23.patch
new file mode 100644
index 000000000000..43702c4ff385
--- /dev/null
+++ b/dev-util/dropwatch/files/dropwatch-1.4-binutils-2.23.patch
@@ -0,0 +1,68 @@
+diff -aurd src.orig/lookup.c src/lookup.c
+--- src.orig/lookup.c 2011-10-03 22:51:38.000000000 +0400
++++ src/lookup.c 2013-02-18 09:13:56.683214438 +0400
+@@ -27,13 +27,13 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <sys/utsname.h>
+-#include <bfd.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+ #include "lookup.h"
++#include <bfd.h>
+
+ extern struct lookup_methods bfd_methods;
+ extern struct lookup_methods kallsym_methods;
+diff -aurd src.orig/lookup.h src/lookup.h
+--- src.orig/lookup.h 2011-10-03 22:51:38.000000000 +0400
++++ src/lookup.h 2013-02-18 09:11:00.506895026 +0400
+@@ -28,6 +28,9 @@
+ #include <stdlib.h>
+ #include <asm/types.h>
+
++// satisfy PR 14072 in bfd.h
++#define PACKAGE 1
++#define PACKAGE_VERSION 1
+
+ /*
+ * Initalization routine
+diff -aurd src.orig/lookup_bfd.c src/lookup_bfd.c
+--- src.orig/lookup_bfd.c 2012-01-16 22:34:11.000000000 +0400
++++ src/lookup_bfd.c 2013-02-18 09:14:02.472984310 +0400
+@@ -25,13 +25,13 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <sys/utsname.h>
+-#include <bfd.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+ #include "lookup.h"
++#include <bfd.h>
+
+
+ static int lookup_bfd_init(void)
+diff -aurd src.orig/lookup_kas.c src/lookup_kas.c
+--- src.orig/lookup_kas.c 2012-05-31 02:43:23.000000000 +0400
++++ src/lookup_kas.c 2013-02-18 09:14:07.906101713 +0400
+@@ -25,7 +25,6 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <sys/utsname.h>
+-#include <bfd.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+@@ -33,6 +32,7 @@
+ #include <sys/queue.h>
+
+ #include "lookup.h"
++#include <bfd.h>
+
+ struct symbol_entry {
+ char *sym_name;