summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-08-05 13:52:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-08-05 13:52:21 +0000
commit78aaf211846a8031bb8c76cec3d94d64284823ab (patch)
tree074d388a630433fff945f7231a70a112514ecb0d
parentVersion bump (diff)
downloadgentoo-2-78aaf211846a8031bb8c76cec3d94d64284823ab.tar.gz
gentoo-2-78aaf211846a8031bb8c76cec3d94d64284823ab.tar.bz2
gentoo-2-78aaf211846a8031bb8c76cec3d94d64284823ab.zip
Version bump to latest rc.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
-rw-r--r--media-sound/pulseaudio/ChangeLog10
-rw-r--r--media-sound/pulseaudio/pulseaudio-0.9.16_rc4-r51.ebuild (renamed from media-sound/pulseaudio/pulseaudio-0.9.16_rc3-r51.ebuild)31
-rw-r--r--media-sound/pulseaudio/pulseaudio-0.9.16_rc4.ebuild (renamed from media-sound/pulseaudio/pulseaudio-0.9.16_rc3.ebuild)22
3 files changed, 52 insertions, 11 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index 61e981c840b1..e4d52035f6c8 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.139 2009/07/30 13:29:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.140 2009/08/05 13:52:21 flameeyes Exp $
+
+*pulseaudio-0.9.16_rc4-r51 (05 Aug 2009)
+*pulseaudio-0.9.16_rc4 (05 Aug 2009)
+
+ 05 Aug 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ -pulseaudio-0.9.16_rc3.ebuild, -pulseaudio-0.9.16_rc3-r51.ebuild,
+ +pulseaudio-0.9.16_rc4.ebuild, +pulseaudio-0.9.16_rc4-r51.ebuild:
+ Version bump to latest rc.
30 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org> ChangeLog:
Let's try to sign this…
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.16_rc3-r51.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.16_rc4-r51.ebuild
index 947031589142..003092f42d67 100644
--- a/media-sound/pulseaudio/pulseaudio-0.9.16_rc3-r51.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-0.9.16_rc4-r51.ebuild
@@ -1,18 +1,22 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.16_rc3-r51.ebuild,v 1.1 2009/07/30 13:27:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.16_rc4-r51.ebuild,v 1.1 2009/08/05 13:52:21 flameeyes Exp $
EAPI=2
-inherit eutils libtool flag-o-matic
+WANT_AUTOMAKE=1.11
-MY_P=${P/_rc/-test}
+inherit eutils libtool flag-o-matic autotools
DESCRIPTION="A networked sound server with an advanced plugin system"
HOMEPAGE="http://www.pulseaudio.org/"
-SRC_URI="http://0pointer.de/public/${MY_P}.tar.gz"
+if [[ ${PV/_rc/} == ${PV} ]]; then
+ SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+else
+ SRC_URI="http://0pointer.de/public/${P/_rc/-test}.tar.gz"
+fi
-S="${WORKDIR}/${MY_P}"
+S="${WORKDIR}/${P/_rc/-test}"
LICENSE="LGPL-2 GPL-2"
SLOT="0"
@@ -84,6 +88,13 @@ pkg_setup() {
}
src_prepare() {
+ # Not extremely nice but allows to avoid a bit of work in the case
+ # users don't request tests.
+ if use test; then
+ sed -i -e 's:\<mix-test::' src/Makefile.am || die
+
+ eautomake
+ fi
elibtoolize
}
@@ -95,9 +106,6 @@ src_configure() {
# proper dependency and fix this up. — flameeyes
append-ldflags -Wl,--no-as-needed
- # udev is disabled because we don't have the right version just
- # yet, and thus we need to avoid it for now. Once we have the
- # version I'll revbump PA. — flameeyes
econf \
--enable-largefile \
$(use_enable glib glib2) \
@@ -131,6 +139,13 @@ src_configure() {
fi
}
+src_test() {
+ # We avoid running the toplevel check target because that will run
+ # po/'s tests too, and they are broken. Officially, it should work
+ # with intltool 0.40.6, but that doesn't seem to be the case.
+ emake -C src check || die
+}
+
src_install() {
emake -j1 DESTDIR="${D}" install || die "make install failed"
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.16_rc3.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.16_rc4.ebuild
index ebe67d336d69..64df13db79d7 100644
--- a/media-sound/pulseaudio/pulseaudio-0.9.16_rc3.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-0.9.16_rc4.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.16_rc3.ebuild,v 1.1 2009/07/30 13:27:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.16_rc4.ebuild,v 1.1 2009/08/05 13:52:21 flameeyes Exp $
EAPI=2
-inherit eutils libtool flag-o-matic
+WANT_AUTOMAKE=1.11
+
+inherit eutils libtool flag-o-matic autotools
DESCRIPTION="A networked sound server with an advanced plugin system"
HOMEPAGE="http://www.pulseaudio.org/"
@@ -79,6 +81,13 @@ pkg_setup() {
}
src_prepare() {
+ # Not extremely nice but allows to avoid a bit of work in the case
+ # users don't request tests.
+ if use test; then
+ sed -i -e 's:\<mix-test::' src/Makefile.am || die
+
+ eautomake
+ fi
elibtoolize
}
@@ -86,6 +95,8 @@ src_configure() {
# To properly fix CVE-2008-0008
append-flags -UNDEBUG
+ # It's a binutils bug, once I can find time to fix that I'll add a
+ # proper dependency and fix this up. — flameeyes
append-ldflags -Wl,--no-as-needed
econf \
@@ -122,6 +133,13 @@ src_configure() {
fi
}
+src_test() {
+ # We avoid running the toplevel check target because that will run
+ # po/'s tests too, and they are broken. Officially, it should work
+ # with intltool 0.40.6, but that doesn't seem to be the case.
+ emake -C src check || die
+}
+
src_install() {
emake DESTDIR="${D}" install || die "make install failed"