summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-25 18:01:47 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-25 18:01:47 +0000
commit7d0cc3f2303474a97295ee1fc653b4d46b6b3663 (patch)
tree83477471562e2559b15e7dcb5cbdfefead928a56
parentDelete older ebuild. (diff)
downloadgentoo-2-7d0cc3f2303474a97295ee1fc653b4d46b6b3663.tar.gz
gentoo-2-7d0cc3f2303474a97295ee1fc653b4d46b6b3663.tar.bz2
gentoo-2-7d0cc3f2303474a97295ee1fc653b4d46b6b3663.zip
Version bump.
(Portage version: 2.2_rc86_p14/cvs/Linux x86_64)
-rw-r--r--net-zope/zope-container/ChangeLog8
-rw-r--r--net-zope/zope-container/zope-container-3.11.2.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/net-zope/zope-container/ChangeLog b/net-zope/zope-container/ChangeLog
index 5d3f969fd0fc..839c68bb30df 100644
--- a/net-zope/zope-container/ChangeLog
+++ b/net-zope/zope-container/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zope-container
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-container/ChangeLog,v 1.8 2010/05/27 20:43:34 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-container/ChangeLog,v 1.9 2010/09/25 18:01:47 arfrever Exp $
+
+*zope-container-3.11.2 (25 Sep 2010)
+
+ 25 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -zope-container-3.11.1.ebuild, +zope-container-3.11.2.ebuild:
+ Version bump.
*zope-container-3.11.1 (27 May 2010)
diff --git a/net-zope/zope-container/zope-container-3.11.2.ebuild b/net-zope/zope-container/zope-container-3.11.2.ebuild
new file mode 100644
index 000000000000..4815459067a7
--- /dev/null
+++ b/net-zope/zope-container/zope-container-3.11.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-container/zope-container-3.11.2.ebuild,v 1.1 2010/09/25 18:01:47 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope Container"
+HOMEPAGE="http://pypi.python.org/pypi/zope.container"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/zodb
+ net-zope/zope-app-dependable
+ net-zope/zope-broken
+ net-zope/zope-component
+ net-zope/zope-dottedname
+ net-zope/zope-event
+ net-zope/zope-filerepresentation
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-lifecycleevent
+ net-zope/zope-location
+ net-zope/zope-publisher
+ net-zope/zope-schema
+ net-zope/zope-security
+ net-zope/zope-size
+ net-zope/zope-traversing"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${PN/-//}"
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+}