summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-10-22 23:39:18 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-10-22 23:39:18 +0000
commit7f39eef1e6adf7e39ee97d6095700d421a9e35fa (patch)
treef76867a0ae6e9b3184c88b4bfb4a7376bd948b8b
parentopenexr gcc4 fix (diff)
downloadgentoo-2-7f39eef1e6adf7e39ee97d6095700d421a9e35fa.tar.gz
gentoo-2-7f39eef1e6adf7e39ee97d6095700d421a9e35fa.tar.bz2
gentoo-2-7f39eef1e6adf7e39ee97d6095700d421a9e35fa.zip
Allow the use of gfortran too for gcc4, closes bug 108781.
(Portage version: 2.0.53_rc6)
-rw-r--r--sci-mathematics/octave/ChangeLog5
-rw-r--r--sci-mathematics/octave/octave-2.1.71.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index eb1901fbb4d7..9d30e0c53908 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.14 2005/09/17 01:00:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.15 2005/10/22 23:39:18 cryos Exp $
+
+ 22 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> octave-2.1.71.ebuild:
+ Allow the use of gfortran too for gcc4, closes bug 108781.
17 Sep 2005; Aron Griffis <agriffis@gentoo.org> octave-2.1.69.ebuild:
Mark 2.1.69 stable on alpha
diff --git a/sci-mathematics/octave/octave-2.1.71.ebuild b/sci-mathematics/octave/octave-2.1.71.ebuild
index 96cda01c8ca8..f2403e475d95 100644
--- a/sci-mathematics/octave/octave-2.1.71.ebuild
+++ b/sci-mathematics/octave/octave-2.1.71.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.71.ebuild,v 1.1 2005/08/21 04:15:27 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.71.ebuild,v 1.2 2005/10/22 23:39:18 cryos Exp $
inherit flag-o-matic
@@ -32,7 +32,7 @@ DEPEND="virtual/libc
# more information
pkg_setup() {
- use ifc || if [ -z `which g77` ]; then
+ use ifc || if [ -z `which g77` ] && [ -z `which gfortran` ]; then
#if ifc is defined then the dep was already checked
eerror "No fortran compiler found on the system!"
eerror "Please add fortran to your USE flags and reemerge gcc!"